Subject: [WPTA] Still looking for Pitt Race/Kastner Cup Volunteers?

From: barrym56--- via Wpta <[email-masked]>
Date: Mon, 11 Jul 2022 17:47:01 -0400

If you still need volunteers for Pitt Race on Saturday I’m planning on attending. Should arrive by 9:00. Be happy to help out. Let me know.
The TR6 was fighting with me last week. First the heater valve started leaking. Replaced on Thursday and no leaks. Pulled into garage and noticed a puddle of oil. The oil filter canister started leaking. Managed to use a spin on conversion that came with the car and gaskets/seals sourced from NAPA but leaking a little. Let is sit till Saturday and all was good. Ran the PVGP kick off Rallye on Sunday with no problems. So I’ll make the run up to Pitt Race on Saturday.
Barry Martin
_______________________________________________
[email-masked]

-------------------------------------

http://www.wptriumph.org

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/archive
Unsubscribe/Manage: http://autox.team.net/mailman/options/wpta/[email-masked]

---

From: WPTA Webmaster-Secretary via Wpta <[email-masked]>
Date: Mon, 11 Jul 2022 21:36:16 -0400

Hi Barry,

I heard your name at the Kick-off Rallye, but didn’t bump into you! Hope you had fun.

Thanks for volunteering…I’ve got a list of places where I’m starting to fill people in. More details this week!

Thanks,
Dexter

> On Jul 11, 2022, at 17:47, barrym56--- via Wpta <[email-masked]> wrote:
> 
> Unsubscribe/Manage: http://autox.team.net/mailman/options/wpta/[email-masked]
> 
> 

http://www.wptriumph.org