Subject: Re: [TR] Bastuck steering rack for TR3

From: dave northrup <[email-masked]>
Date: Sun, 21 Dec 2025 16:24:26 +0000

I have been told that if you get the original steering rack rebuilt its almost as good as R&P.  not sure what that cost is; I'm about to find out!  Macy's Garage in Ohio? does it

-----Original Message-----
From: Triumphs <[email-masked]> On Behalf Of David P
Sent: Sunday, December 21, 2025 9:19 AM
To: Triumphs ([email-masked]) <[email-masked]>
Subject: [TR] Bastuck steering rack for TR3

  Just finishing up this conversion for a customer. If you want to do it
($) or have it done($$$) , but know there are concessions that come with it. Control head changes, coolant hose clearances, Steering wheel reach (if fitted), wiring additions. If you don't like the stock steering (some validity there) first check the condition of the steering gear box and all  the ball joints and the felt packings around the steering column..

DaveP

--
DBA Porter Custom Bicycles 2909 Arno St. NE Albuquerque, NM. 87107 ph 505-352-1378  My World go here: WWW.PORTERBIKES.COM/

** [email-masked] **

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/pipermail/triumphs  http://www.team.net/archive

Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]
** [email-masked] **

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/pipermail/triumphs  http://www.team.net/archive

Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: DAVE HOGYE <[email-masked]>
Date: Sun, 21 Dec 2025 11:48:48 -0800 (PST)

ChefTush YouTube channel shared an intensive 3 or 4 part video of installing the Bastuck rack and pinion conversion in a TR3.  I think the Bastuck kit is the best kit if interested in this conversion.  I recently purchase just the rack from Bastuck because the TR3 I was working on had a pre-2010 Moss kit and the Bastuck rack was basically a direct replacement to the early bracket design.  Since 2010 the Moss kit changed components.  The mounting brackets and rack are very different and I think the earlier design is better for a number of reasons.  
If it was up to me, I'd keep the original steering.  It is the path of least resistance.  You will see on ChefTush's video how difficult and fiddly, tedious, the Bastuck kit is to install. It is not really a direct bolt-in. 
I would sent the original box to Macy's Garage for a rebuild.  
I rebuilt mine myself and I think it's excellent. 
I haven't tested the steering wheel rotations between the rack and original, but I have been told that the rack is more turns lock to lock and the quick rack is too quick...less turns than original.

My two cents.
Cheers,
Dave H. 

> On 12/21/2025 7:19 AM PST David P <[email-masked]> wrote:
> 
>  
> ($) or have it done($$$) , but know there are concessions that come with 
> it. Control head changes, coolant hose clearances, Steering wheel reach 
> (if fitted), wiring additions. If you don't like the stock steering 
> (some validity there) first check the condition of the steering gear box 
> and all  the ball joints and the felt packings around the steering column..
> 
> DaveP
> 
> -- 
> Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]