Subject: [TR] TR4 rear dampers.

From: John Macartney <[email-masked]>
Date: Tue, 19 Aug 2025 12:32:32 +0100

Going way, way back to the days when these cars were going down the line, the leaf springs on those cars fitted with them were sprayed with something called Mecafluid diluted usually with paraffin (Kerosene). The objective was to offer some form of lubricant between the spring leaves and the process was recommended to be ‘re-anointed’ when the car was serviced. Mecafluid won’t be known now but it’s actually the same lubricant used in the chassis lubrication systems on heavy trucks. Highly beneficial on spring shackle pins and an excellent overall protectant for the underbody.
I’ve used gallons of the stuff down the years and to very good effect, though I’ve yet to see a classic car of any make with well lubed leaf springs. Seems most people don’t bother with springs now - and in much the same way that the majority of modern spanner-wankers seem to feel the use of washers with hardware is ‘old hat’.

Jonmac

> On 18 Aug 2025, at 19:00, [email-masked] wrote:
> 
> Send Triumphs mailing list submissions to
>    [email-masked]
> 
> To subscribe or unsubscribe via the World Wide Web, visit
>    http://autox.team.net/mailman/listinfo/triumphs
> or, via email, send a message with subject or body 'help' to
>    [email-masked]
> 
> You can reach the person managing the list at
>    [email-masked]
> 
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of Triumphs digest..."
> Today's Topics:
> 
>   1. Re: Light weight rear TR shock oil ? (Carl Sereda)
>   2. Re: TR4 rear dampers (Rye Livingston)
> <mime-attachment>
> <mime-attachment>
> _______________________________________________
> 
> Triumphs mailing list
> [email-masked]
> http://autox.team.net/mailman/listinfo/triumphs

** [email-masked] **

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/pipermail/triumphs  http://www.team.net/archive

Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: dave northrup <[email-masked]>
Date: Tue, 19 Aug 2025 14:59:04 +0000

Years ago I had an mgb whose rear shocks leaked oil like crazy.  Just for fun I filled them with 90 wt gear oil.  Suspension was rock hard for a few minutes until the oil leaked out again

-----Original Message-----
From: Triumphs <[email-masked]> On Behalf Of John Macartney
Sent: Tuesday, August 19, 2025 6:33 AM
To: [email-masked]
Subject: [TR] TR4 rear dampers.

Jonmac

>   2. Re: TR4 rear dampers (Rye Livingston) <mime-attachment> 
> <mime-attachment> _______________________________________________
> 
> Triumphs mailing list
> [email-masked]

Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]
** [email-masked] **