Subject: [TR] Storing my car

From: John Macartney <[email-masked]>
Date: Fri, 3 May 2024 13:22:26 +0100

Very close to my home in the UK is a disused WW2 airfield where I clearly remember spending many Saturday mornings in the 1960’s doing stock checks of new Triumphs that were awaiting shipment as finished new cars. I was there again only three days ago doing some work on our caravan which is dry stored on the very adjacent farm. Looking back to those now very distant days, all I recall were vast numbers of all models of Triumphs parked in long rows along the former taxiways, with many up to their axles in mud, water and or long grass as a result of blocked surface drainage. It wasn’t unusual for a car to be at Honeybourne for several months in the open air with no protection whatsoever. Reasons why are too long for this response. On that basis, I’m still truly amazed that so many have lasted as long as they have. Let’s face it, ten years at the very most was the anticipated life expectancy of any of those models and the amount of re-working we had to do before final shipment was usually horrendous.
In spite of all those early horrors, lots have somehow survived and been restored and in answer to the question of storage options, my only response would be a dry building that doesn’t leak and isn’t damp, a nice warm blanket, a thorough wax polish, a full tank of fresh fuel, ditto for engine oil and some lightweight machine oil sprayed into each cylinder. Ye gods, the car deserves it after the hellish it came to know when new.

Jonmac

** [email-masked] **

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/pipermail/triumphs  http://www.team.net/archive

Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: <[email-masked]>
Date: Fri, 3 May 2024 10:04:58 -0600

HA, I can't let my 2005 Jaguar XJ8 sit for more than two weeks or the calipers rust up, the 32 computers suck all power and drain the battery, the injectors don't want to spring back to life, or the ten million garbage plastic sensors get damaged and burn out due to the battery voltage falling below 12.25VDC!!

With my TR250 after sitting for months, I pump up the fuel from the fuel pump lever, check the fluids and tires, connect the battery, twist the key and drive away.

Technology ...

Glenn Merrell, CAP
StagByTriumph Garage
aka Stag-By-Triumph Garage (on FaceBook)
Remember, “the BEST trophies are: Miles on the Odometer; Stone chips in the paint; and DEAD BUGS on the windscreen … with the occasional smell of manure!”

-----Original Message-----
From: Triumphs <[email-masked]> On Behalf Of John Macartney
Sent: Friday, May 3, 2024 6:22 AM
To: [email-masked]
Subject: [TR] Storing my car

Jonmac

Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]