Subject: Re: [TR] TR6 Rear Half Shaft Play

From: Robert Rochlin <[email-masked]>
Date: Wed, 28 Feb 2024 20:57:22 -0500

Thanks for the input re: the Goodparts hubs guys.
   I checked the play in the sliding member on the half shafts and they seem to have  acceptable and look to be in good shape so I’m going to install a pair of Goodparts hubs.   Best
  Bob
Sent from my iPhone

> On Feb 28, 2024, at 7:25 PM, dave northrup <[email-masked]> wrote:
> 
>  +1 on the Goodparts hubs
> 
> 
> -------- Original message --------
> From: Chris Simo <[email-masked]>
> Date: 2/28/24 5:57 PM (GMT-06:00)
> To: Robert Rochlin <[email-masked]>
> Cc: [email-masked], [email-masked]
> Subject: Re: [TR] TR6 Rear Half Shaft Play
> 
> Those rear hubs can be dangerous, especially when worn. if it feels loose,  I'd do something about it.  My friend Jack Mac put the fear of God in me with stories of failed stock rear hubs......
> 
> I updated the hubs with goodparts version when I rebuilt the diff and boxed in the diff supports. 
> 
> Chris

** [email-masked] **

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/pipermail/triumphs  http://www.team.net/archive

Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: dave northrup <[email-masked]>
Date: Thu, 29 Feb 2024 11:33:58 +0000

You can't go wrong with Goodparts.  Our car is full of his stuff

 Many of them are far superior to what you can find elsewhere.  Case in point:  https://www.goodparts.com/product/shock-link-set-rear-tr4a-tr6-rod-end/