Subject: [TR] Sachs pressure plates

From: Tomislav Marincic <[email-masked]>
Date: Sat, 6 Jan 2024 21:48:46 -0500

“ We tried BPNW and they are out.  anyone know a source that has them in stock?”

Try the Roadster Factory
** [email-masked] **

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/pipermail/triumphs  http://www.team.net/archive

Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: <[email-masked]>
Date: Sun, 7 Jan 2024 15:39:44 -0500

Hope this suggestion is just because you have not read your other messages from the list re: the Christmas Day fire at TRF and not some attempt at humour.

Keith Stewart
[email-masked]
https://worldoftriumph.godaddysites.com/

-----Original Message-----
From: Tomislav Marincic <[email-masked]> 
Sent: Saturday, January 6, 2024 9:49 PM
To: [email-masked]; [email-masked]
Subject: [TR] Sachs pressure plates

Try the Roadster Factory