Subject: Re: [TR] Seat belts

From: Rye Livingston <[email-masked]>
Date: Tue, 23 Jan 2024 08:14:28 -0800

You could check with this company.  www.seatbeltplanet.com  For two other vintage cars, not Triumphs, I got retractable 3 point belts from them.

Rye

> On Jan 22, 2024, at 4:20 PM, dave northrup <[email-masked]> wrote:
> 
> Anyone know where i can get new belts that fit this?
> ** [email-masked] **
> 
> Donate: http://www.team.net/donate.html
> Archive: http://www.team.net/pipermail/triumphs  http://www.team.net/archive
> 
> Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]

** [email-masked] **

Archive: http://www.team.net/pipermail/triumphs  http://www.team.net/archive

---

From: Randy and Valerie DeRuiter <[email-masked]>
Date: Tue, 23 Jan 2024 16:55:24 +0000

I’d be surprised if you can find that style anymore I believe it’s just an early format when belts first came out.  

Sent from my iPhone

> On Jan 22, 2024, at 11:44 PM, dave northrup <[email-masked]> wrote:
> 
> Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]

Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: dave northrup <[email-masked]>
Date: Tue, 23 Jan 2024 19:49:28 +0000

I think that will work!  they basically do a reweb.

Thank you

-----Original Message-----
From: Rye Livingston <[email-masked]> 
Sent: Tuesday, January 23, 2024 10:14 AM
To: dave northrup <[email-masked]>
Cc: [email-masked]
Subject: Re: [TR] Seat belts

Rye