Subject: [TR] TR6 door mirrors

From: [email-masked]
Date: Fri, 13 Oct 2023 09:01:46 -0500

My '74 TR6 is not very original, but has one bullet-style mirror on the 
driver door. It's not really useful - very small mirror and difficult to 
adjust. I'd like to move to more traditional-style mirrors (and add one 
to the passenger side) that still look "correct" for the period.

Any suggestions?

Thanks!!
  Lee

'74 TR6 pimento; daily driver
'74 TR6 maple, w/OD, in 13,156 parts
** [email-masked] **

Archive: http://www.team.net/pipermail/triumphs  http://www.team.net/archive

---

From: Brian Kemp <[email-masked]>
Date: Tue, 17 Oct 2023 22:13:45 +0000

I have rectangular mirrors on both doors on my 72 TR6 and they work much better than the driver's bullet mirror on by GT6.  The GT6 doesn't have a passenger side mirror.

Brian
-----Original Message-----
From: robert rudolphi <[email-masked]>
Sent: Oct 17, 2023 12:52 PM
To: John Macartney <[email-masked]>, [email-masked] <[email-masked]>
Cc: [email-masked] <[email-masked]>
Subject: Re: [TR] TR6 door mirrors

Hi All,

Does anyone know if these "square" mirrors work better then the "bullet" mirrors on the passenger (right) side of a left hand drive TR6.

Thanks,

Robert 
74 TR6

On Tuesday, October 17, 2023 at 01:40:18 AM EDT, wrote:

Jonmac,

Wow, these are nice, and just the right style. THANKS!!!!
  Lee

On 2023-10-14 08:15, John Macartney wrote:
> Lee,
>
> Go to www.bbclassics.co.uk. The Astrali mirror at GBP49 the pair were
> Standard fit in 1974 on many Triumphs and other BL makes. I recall the
> other mirror types that were a stock fitment to US cars of the period
> were unique to the US as the Astrali type was the only one that was
> type approved for Europe and all other non US markets.
>
> Jonmac

On 2023-10-13 09:01, [email-masked] wrote:
> My '74 TR6 is not very original, but has one bullet-style mirror on
> the driver door. It's not really useful - very small mirror and
> difficult to adjust. I'd like to move to more traditional-style
> mirrors (and add one to the passenger side) that still look "correct"
> for the period.
>
> Any suggestions?
>
> Thanks!!
>  Lee
>

Archive:   http://www.team.net/archive (http://www.team.net/pipermail/triumphs)

Archive:  http://www.team.net/archive (http://www.team.net/pipermail/triumphs)