Subject: Re: [TR] Spinal Tappets

From: dave northrup <[email-masked]>
Date: Tue, 11 Jul 2023 16:52:59 +0000

John -

From across the pond - "mickey taking"?

Translation please?

Dave Northrup
Dallas, TX

-----Original Message-----
From: Triumphs <[email-masked]> On Behalf Of John Macartney
Sent: Tuesday, July 11, 2023 3:53 AM
To: [email-masked]
Subject: [TR] Spinal Tappets

I feel especially honoured by that fantastic group. In 2009,  when doing the Triumph Trans AmeriCan charity drive, ISOA put on an incredible event when I visited Joe PAWLAK and his team of busted knuckles who had previously rebuilt the Stag I was driving. The group was very much in evidence and sang an adapted song from its repertoire called “Johnnys got a brand new Stag”. Brought a CD home and played it to a bunch of TR Register arrogant, PITA stuffshirts here in the U.K. who claimed the material was sacrilegious to Triumph etc etc. I applaud the Spinal Tappets, as did many other *older* members of other U.K. clubs have heard and enjoyed that same CD. Too many younger ones just don’t get it / see the songs as mickey taking and especially so if they own a car of the same model. Vive les Spinal Tappets even though I believe they’ve disbanded. Sad, they were great.

Jonmac

> On 10 Jul 2023, at 19:00, [email-masked] wrote:
> 
> Send Triumphs mailing list submissions to
>    [email-masked]
> 
> To subscribe or unsubscribe via the World Wide Web, visit
>    http://autox.team.net/mailman/listinfo/triumphs
> or, via email, send a message with subject or body 'help' to
>    [email-masked]
> 
> You can reach the person managing the list at
>    [email-masked]
> 
> When replying, please edit your Subject line so it is more specific 
> than "Re: Contents of Triumphs digest..."
> Today's Topics:
> 
>   1. Has anyone one use K-seal in their Triumph? (Sujit Roy)
>   2. Re: Has anyone one use K-seal in their Triumph? (Chad)
>   3. Spinal Tappets (Paul Tegler)
>   4. Re: Spinal Tappets (Ronnie Babbitt)
>   5. Re: generator vs alternator ([email-masked])
> <mime-attachment>
> <mime-attachment>
> <mime-attachment>
> <mime-attachment>
> <mime-attachment>
> _______________________________________________
> 
> Triumphs mailing list
> [email-masked]
> http://autox.team.net/mailman/listinfo/triumphs

** [email-masked] **

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/pipermail/triumphs  http://www.team.net/archive

Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]
** [email-masked] **

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/pipermail/triumphs  http://www.team.net/archive

Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: John Macartney <[email-masked]>
Date: Tue, 11 Jul 2023 18:55:11 +0100

Sorry everyone, I thought the term ‘Mickey taking’ was originally a language import from North America? Clearly not - or it’s not a recognised term in Texas   :)

Anyway, the meaning as per Spinal Tappets. The small group from the TR Register felt the various song titles in which Triumph models are named, was an inappropriate and distasteful way of poking fun at our cars. They didn’t like it, it was unkind, it was not justified.

All I can say to those sensitive souls is they should have been at the factory and the two company owned Service Divisions in days of yore. If they had, they’d have heard multiple opinions regarding product quality, assembly practises and non-sensical “improvements”. All of them were described in basic Coventry-ese with generous servings of a myriad of expletives to ram the points home. I’ve repeated some of them (without the expletives) to various groups to whom I give talks throughout the year - and mostly the reactions are shock, horror and a good few ‘don’t knock the product’ comments. Ive come to the conclusion that many enthusiasts in the U.K. either have limited or non-existent imaginations, or they’re so besotted with their beloved cars that they can’t bear to see or hear them being criticised, even constructively. This probably explains why most of my former colleagues aren’t model or marque specific Triumph club members because they, like me, can’t cope with  the endemic “politics” that are so rife. Instead, we have our own little unofficial club where Standard cars (from 1920 onwards) Triumph cars (post 1945) and Ferguson tractors (post 1946) all mix together and everyone is happy. I understand much the same applies in the U.K. to former employees with big Healeys, Spridgets, Jaguars and MGs. We all muck in together but too many people are leaving us each year for another life beyond the stars where oil leaks are unknown and Lucas is far better and more reliable than anything which ever came out of Bosch or Magneti Marelli.

Have I clarified?

Jonmac

> On 11 Jul 2023, at 17:52, dave northrup <[email-masked]> wrote:
> 
> John -
>