Subject: [TR] Stainless steel - or The Gospel according to St. Glenn of Merrill

From: John Macartney <[email-masked]>
Date: Mon, 15 May 2023 22:34:43 +0100

Well, if you didn’t know about stainless and plating, my good friend Glenn has (hopefully) clarified or further confused those with enquiring minds.

For me, I’ve never been aware of stainless lookalike front or rear bumpers. It’s a long time ago since I rebuilt my now long gone and much missed big Triumph saloon, but when it came to replacing the front and rear ends, I handed the job to an old friend I’d made at Jaguar in the sixties. He had his own plating company (now sold and made him a millionaire) and he did my bumpers as per spec at Jaguar - viz copper, nickel, copper, chrome - and it wasn’t just “flashed” on. Done proper, ‘twas. Cost me a fortune but when they were fitted, that car looked the ‘dogs bollocks’.  Quality always shows in the end.

Jonmac
** [email-masked] **

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/pipermail/triumphs  http://www.team.net/archive

Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: Jeff Scarbrough <[email-masked]>
Date: Tue, 16 May 2023 08:45:53 -0400

On Mon, May 15, 2023 at 7:18 PM John Macartney <[email-masked]> wrote:
>
> Cost me a fortune but when they were fitted, that car looked the ‘dogs bollocks’.  Quality always shows in the end.

As do the dog's bollocks, coincidentally.
** [email-masked] **