Subject: [TR] Top

From: Carl Carlson <[email-masked]>
Date: Mon, 17 Jan 2022 11:39:08 -0800

Let’s support TRF when we can.
Carl
** [email-masked] **

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/pipermail/triumphs  http://www.team.net/archive

Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: dave northrup <[email-masked]>
Date: Mon, 17 Jan 2022 19:44:46 +0000

Why?  Because they lied to all of us who had invested in the company that our investment was secure and protected by a life insurance policy?  I guess you didn't lose money in that scam.

I think NOT!!!

-----Original Message-----
From: Triumphs <[email-masked]> On Behalf Of Carl Carlson
Sent: Monday, January 17, 2022 1:39 PM
To: [email-masked]
Subject: [TR] Top

Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]
** [email-masked] **