Subject: [TR] Suggestions on adding a oil catch can to a TR4A

From: Dave Connitt <[email-masked]>
Date: Thu, 27 Jan 2022 19:16:35 -0500

Hi all,
Just a little background first. I have a ‘67 TR4A IRS. About 2 years ago I removed the PCZv valve due to excessive carbon buildup and added a TR4 style crankcase vent pipe. 
That stopped my carbon buildup issue but created a new problem which is oil now is dripping off the bottom of the car.
Now to my question.. Has anyone out there done a similar change of adding a TR4 style crankcase vent tube and then plumbed in a oil catch tank? If so, please enlighten me!
Thanks,
Dave Connitt

Sent from my iPhone
** [email-masked] **

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/pipermail/triumphs  http://www.team.net/archive

Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: Dave Connitt <[email-masked]>
Date: Thu, 27 Jan 2022 22:44:22 -0500

Thanks Dave!
I really appreciate it.
Dave Connitt

Sent from my iPhone

> On Jan 27, 2022, at 10:06 PM, DAVE HOGYE <[email-masked]> wrote:
> 
> Triumph gang,
> Please enjoy my video.
> The crankcase vent system starts at 6:35.  With the o-ring fitting that I designed, this system is completely leak free and efficient. 
> The factory vent tube has a cut in it and is a slip fit.  Oil can leak freely.  
> Dave H.
> https://www.youtube.com/watch?v=UW-cSGzyKXs
> 
>> On 01/27/2022 4:16 PM Dave Connitt <[email-masked]> wrote:
>> 
>> 
>> Hi all,
>> Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]