Subject: [TR] 72 Alternator update

From: Bob <[email-masked]>
Date: Wed, 11 Aug 2021 08:38:22 -0400

Hello,

Just received a call from the auto electric shop on my alternator.

Good news is all parts are available because it is a Delco. Will take 2 
days. He is replacing just about everything. Even re-varnishing the 
field coils. He stated that the alternator will be basically brand new 
when he is finished.

I tried to get a replacement and use this rebuild as a spare but it 
seems even rebuilt units (Oriely, Advanced Auto and Rock Auto are NLA). 
Even TRF it is NLA.

So by Friday afternoon I will be back in business. Peninsula Imports 
never returned my email about a unit that may have worked. Not sure what 
is going on there. If it was NLA I would have appreciated a return email 
at least.

Bob

** [email-masked] **

Archive: http://www.team.net/pipermail/triumphs  http://www.team.net/archive

---

From: Dave Connitt <[email-masked]>
Date: Wed, 11 Aug 2021 09:13:08 -0400

Glad to hear you have found a solution and will be on the road again.
Dave Connitt 

Sent from my iPhone

> On Aug 11, 2021, at 8:38 AM, Bob <[email-masked]> wrote:
> 
> Hello,
> 
> Good news is all parts are available because it is a Delco. Will take 2 days. He is replacing just about everything. Even re-varnishing the field coils. He stated that the alternator will be basically brand new when he is finished.
> 
> I tried to get a replacement and use this rebuild as a spare but it seems even rebuilt units (Oriely, Advanced Auto and Rock Auto are NLA). Even TRF it is NLA.
> 
> So by Friday afternoon I will be back in business. Peninsula Imports never returned my email about a unit that may have worked. Not sure what is going on there. If it was NLA I would have appreciated a return email at least.
> 
> Bob
> 
> Donate: http://www.team.net/donate.html
> Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/pipermail/triumphs  http://www.team.net/archive

Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: Bob <[email-masked]>
Date: Fri, 13 Aug 2021 12:48:15 -0400

All,

Ok, picked up my rebuilt Delco this afternoon and all is well again. 
Hope the rain holds off so we can go to a car hop tonight.

The good news is Delco had all the parts required in stock believe it or 
not. And all std. Delco parts not replacements.

It is nice to have that type of expertise available so close to home.

Bob