Subject: Re: [TR] Triumphs Digest, Vol 14, Issue 166

From: Michael Coe <[email-masked]>
Date: Sun, 25 Jul 2021 12:19:58 -0600

Hi:

I need a spare set of keys for my Triumph TR8.

Any suggestions for a legitimate supplier?

Cheers
Mike Coe. Calgary. Alberta

> On Jul 25, 2021, at 12:00 PM, [email-masked] wrote:
> 
> Send Triumphs mailing list submissions to
> 	[email-masked]
> 
> To subscribe or unsubscribe via the World Wide Web, visit
> 	http://autox.team.net/mailman/listinfo/triumphs
> or, via email, send a message with subject or body 'help' to
> 	[email-masked]
> 
> You can reach the person managing the list at
> 	[email-masked]
> 
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of Triumphs digest..."
> 
> 
> Today's Topics:
> 
>   1. Re: Mixed Oil OK? (Q)
> 
> 
> ----------------------------------------------------------------------
> 
> Message: 1
> Date: Sat, 24 Jul 2021 12:08:35 -0700
> From: Q <[email-masked]>
> To: [email-masked]
> Subject: Re: [TR] Mixed Oil OK?
> Message-ID: <[email-masked]>
> Content-Type: text/plain; charset=utf-8; format=flowed
> 
> Just as a note you should not use GL-5 trans oil in TR transmissions as 
> it attacks the brass/bronze devices within such as sycro rings.? GL-4 
> rated is what is recommended.
> 
> RedLine MTL seems fine and I have used it in several OD transmissions 
> for years.
> 
> 
> Edward Hamer
> 
> Petaluma CA
> 
> 
> 
> ------------------------------
> 
> Subject: Digest Footer
> 
> _______________________________________________
> 
> Triumphs mailing list
> [email-masked]
> http://autox.team.net/mailman/listinfo/triumphs
> 
> 
> ------------------------------
> 
> End of Triumphs Digest, Vol 14, Issue 166
> *****************************************

** [email-masked] **

Archive: http://www.team.net/pipermail/triumphs  http://www.team.net/archive

---

From: Brian Kemp <[email-masked]>
Date: Sun, 25 Jul 2021 14:13:48 -0700

Check a local locksmith.  I was able to get keys made for both my TR6 
and GT6 from blanks they had in stock.

On 7/25/2021 11:19 AM, Michael Coe wrote:
> Donate: http://www.team.net/donate.html
> Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/pipermail/triumphs  http://www.team.net/archive

Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: [email-masked]
Date: Sun, 25 Jul 2021 21:54:56 -0500

The go-to for British keys has been Pete Groh. The web site appears to 
be still active, check it out and let us know how it goes:
   http://britishcarkeys.com/

Cheers,
  Lee