Subject: [TR] Early TR4 dash

From: Thomas Fansher <[email-masked]>
Date: Mon, 7 Jun 2021 11:46:43 -0400

I’m in need of an early TR4 metal glove box door and hardware.  If I have to buy the whole dash, that’s fine. Just let me know. Any ideas where? 
Tom Fansher
61 TR3A
62 TR4 - soon going for rebuild (finally)
73 Stag

Sent from my iPad
** [email-masked] **

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/pipermail/triumphs  http://www.team.net/archive

Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: Jim Henningsen <[email-masked]>
Date: Mon, 7 Jun 2021 11:58:05 -0400

I’ll check my parts tonight  I have an early dash from a parts car in my garage rafters.

> On Jun 7, 2021, at 11:48 AM, Thomas Fansher <[email-masked]> wrote:
> 
> Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]