Subject: [TR] TR3A QUESTION

From: Jim Henningsen <[email-masked]>
Date: Sat, 24 Apr 2021 17:07:00 -0400

Are there any replacements for the brass overdrive drain plug on 61 3a?  Mine is worn a little making it difficult to tighten and loosen with socket.  What tricks are there to stop leaks out of this plug? 

Question 2.  Anyone have a good used Tr3a hood latch.  My neighbors has the lever arm broken off making it difficult to unlatch.  Attaches to the hood.  

Many thanks,
Jim Henningsen
Ocala fl

** [email-masked] **

Archive: http://www.team.net/pipermail/triumphs  http://www.team.net/archive

---

From: James Henningsen <[email-masked]>
Date: Sun, 25 Apr 2021 17:15:30 -0400

After going through  my TR2 factory parts manual found out TRF does have a safety catch assembly for $20.  Good news is a fellow TR list
Member had an original one he could part with. 
Love this list! 
Cheers
Jim Henningsen 

> On Apr 25, 2021, at 2:21 PM, [email-masked] wrote:
> 
> I had the same problem, the arm broke off. I bought a new one from TRF. Do
> they no longer carry them?
> 
> 
> Keith Stewart
> [email-masked]
> 
> 
> -----Original Message-----
> From: Jim Henningsen <[email-masked]> 
> Sent: April 24, 2021 5:07 PM
> To: TR3 Triumphs <[email-masked]>
> Subject: [TR] TR3A QUESTION
> 
> Are there any replacements for the brass overdrive drain plug on 61 3a?
> Mine is worn a little making it difficult to tighten and loosen with socket.
> What tricks are there to stop leaks out of this plug? 
> 
> Question 2.  Anyone have a good used Tr3a hood latch.  My neighbors has the
> lever arm broken off making it difficult to unlatch.  Attaches to the hood.
> 
> 
> Many thanks,
> Jim Henningsen
> Ocala fl
> 
> 
> 

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/pipermail/triumphs  http://www.team.net/archive

Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]