Subject: Re: [TR] TR3A QUESTION

From: "Alex & Janet Thomson" <[email-masked]>
Date: Sat, 24 Apr 2021 17:20:14 -0400

For the drain plug, go to a good NAPA store. I have changed some of my
tractors over to hex head pipe plugs since the square heads can round off so
easily. Of course, those machines date back to the 50's and before. They
should have them in brass, as well. They also have a good listing for
straight thread, flanged plugs, as well. Is that overdrive drain plug an
oddball thread?

Sorry - can't help with question #2.

Alex Thomson

-----Original Message-----
From: Triumphs [mailto:[email-masked]] On Behalf Of Jim
Henningsen
Sent: Saturday, April 24, 2021 5:07 PM
To: TR3 Triumphs
Subject: [TR] TR3A QUESTION

Are there any replacements for the brass overdrive drain plug on 61 3a?
Mine is worn a little making it difficult to tighten and loosen with socket.
What tricks are there to stop leaks out of this plug? 

Question 2.  Anyone have a good used Tr3a hood latch.  My neighbors has the
lever arm broken off making it difficult to unlatch.  Attaches to the hood.

Many thanks,
Jim Henningsen
Ocala fl

** [email-masked] **

Archive: http://www.team.net/pipermail/triumphs  http://www.team.net/archive

http://autox.team.net/mailman/options/triumphs/[email-masked]

** [email-masked] **

Archive: http://www.team.net/pipermail/triumphs  http://www.team.net/archive

---

From: "Jim Henningsen" <[email-masked]>
Date: Sat, 24 Apr 2021 18:50:55 -0400

Alex, the is the large brass drain plug under the OD if you were thinking of
the small square one under the main tranny.  It has a hex head on it.  I
think it is 1 1/16 inch size.  It is different than the brass drain plug on
my TR4 a type.  For that one Moss has a special wrench tool which works
great.  I may need to get a wrench for the 3 plug as that might work better
than a socket.  
Jim

-----Original Message-----
From: Alex & Janet Thomson <[email-masked]> 
Sent: Saturday, April 24, 2021 5:20 PM
To: 'Jim Henningsen' <[email-masked]>; 'TR3 Triumphs'
<[email-masked]>
Subject: RE: [TR] TR3A QUESTION

Alex Thomson

-----Original Message-----

Many thanks,
Jim Henningsen
Ocala fl

---

From: "Notakitcar" <[email-masked]>
Date: Sat, 24 Apr 2021 18:07:19 -0500

If it is part number 500620, TRF has them at the modest price of $99.95ea.
Bill

-----Original Message-----
From: Triumphs [mailto:[email-masked]] On Behalf Of Jim
Henningsen
Sent: Saturday, April 24, 2021 5:51 PM
To: 'Alex & Janet Thomson' <[email-masked]>; 'TR3 Triumphs'
<[email-masked]>
Subject: Re: [TR] TR3A QUESTION

-----Original Message-----
From: Alex & Janet Thomson <[email-masked]>
Sent: Saturday, April 24, 2021 5:20 PM
To: 'Jim Henningsen' <[email-masked]>; 'TR3 Triumphs'

Alex Thomson

-----Original Message-----

Many thanks,
Jim Henningsen
Ocala fl

http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: "Alex & Janet Thomson" <[email-masked]>
Date: Sat, 24 Apr 2021 20:49:00 -0400

Ooohh - That's a lot of 6 packs!
Alex Thomson

-----Original Message-----
From: Alex & Janet Thomson <[email-masked]>
Sent: Saturday, April 24, 2021 5:20 PM
To: 'Jim Henningsen' <[email-masked]>; 'TR3 Triumphs'

Alex Thomson

-----Original Message-----

Many thanks,
Jim Henningsen
Ocala fl

---

From: DAVID MASSEY <[email-masked]>
Date: Sun, 25 Apr 2021 11:51:33 +0000 (UTC)

--===============5162825995401554713==
	boundary="----=_Part_185571_1045074157.1619351493819"

------=_Part_185571_1045074157.1619351493819
Content-Transfer-Encoding: quoted-printable

 It is a machined part, in brass, produced in small volumes.=C2=A0 It's lik=
e home brewing a batch of beer that costs you $75 in supplies, $1000 in equ=
ipment and 5 hours of your time.
=20
Dave=20

=20
=20
-----Original Message-----
From: Alex & Janet Thomson <[email-masked]>
To: 'Notakitcar' <[email-masked]>; 'Jim Henningsen' <[email-masked]=
m>; 'TR3 Triumphs' <[email-masked]>
Sent: Sat, Apr 24, 2021 7:49 pm
Subject: Re: [TR] TR3A QUESTION

-----Original Message-----

Alex, the is the large brass drain plug under the OD if you were thinking o=
f
the small square one under the main tranny.=C2=A0 It has a hex head on it.=
=C2=A0 I
think it is 1 1/16 inch size.=C2=A0 It is different than the brass drain pl=
ug on
my TR4 a type.=C2=A0 For that one Moss has a special wrench tool which work=
s
great.=C2=A0 I may need to get a wrench for the 3 plug as that might work b=
etter
than a socket.=C2=A0=20
Jim

-----Original Message-----
From: Alex & Janet Thomson <[email-masked]>
Sent: Saturday, April 24, 2021 5:20 PM
To: 'Jim Henningsen' <[email-masked]>; 'TR3 Triumphs'

tractors over to hex head pipe plugs since the square heads can round off s=
o

Alex Thomson

-----Original Message-----

Are there any replacements for the brass overdrive drain plug on 61 3a?
Mine is worn a little making it difficult to tighten and loosen with socket=
.
What tricks are there to stop leaks out of this plug?=20

Question 2.=C2=A0 Anyone have a good used Tr3a hood latch.=C2=A0 My neighbo=
rs has the
lever arm broken off making it difficult to unlatch.=C2=A0 Attaches to the =
hood.

Many thanks,
Jim Henningsen
Ocala fl

Archive: http://www.team.net/pipermail/triumphs  http://www.team.net/archiv=
e

Archive: http://www.team.net/pipermail/triumphs  http://www.team.net/archiv=
e

Archive: http://www.team.net/pipermail/triumphs  http://www.team.net/archiv=
e

[email-masked]

------=_Part_185571_1045074157.1619351493819
Content-Transfer-Encoding: 7bit

<div style="color:black;font: 12pt Arial, Helvetica, sans-serif;">
<div> <font size="3">It is a machined part, in brass, produced in small volumes.&nbsp; It's like home brewing a batch of beer that costs you $75 in supplies, $1000 in equipment and 5 hours of your time.</font><br>
</div>

<div> <br>
</div>

<div style="clear:both"><font size="4">Dave </font><br>
<br>
</div>

<div> <br>
</div>

<div> <br>
</div>

<div style="font-family:arial,helvetica;font-size:10pt;color:black"><font size="2">-----Original Message-----<br>
From: Alex &amp; Janet Thomson &lt;[email-masked]&gt;<br>
To: 'Notakitcar' &lt;[email-masked]&gt;; 'Jim Henningsen' &lt;[email-masked]&gt;; 'TR3 Triumphs' &lt;[email-masked]&gt;<br>
Sent: Sat, Apr 24, 2021 7:49 pm<br>
Subject: Re: [TR] TR3A QUESTION<br>
<br>

<div dir="ltr">Ooohh - That's a lot of 6 packs!<br>
</div>

<div dir="ltr">Alex Thomson<br>
</div>

<div dir="ltr"><br>
</div>

<div dir="ltr">-----Original Message-----<br>
</div>

<div dir="ltr">From: Notakitcar [mailto:<a ymailto="mailto:[email-masked]" href="mailto:[email-masked]">[email-masked]</a>] <br>
</div>

<div dir="ltr">Sent: Saturday, April 24, 2021 7:07 PM<br>
</div>

<div dir="ltr">To: 'Jim Henningsen'; 'Alex &amp; Janet Thomson'; 'TR3 Triumphs'<br>
</div>

<div dir="ltr">Subject: RE: [TR] TR3A QUESTION<br>
</div>

<div dir="ltr"><br>
</div>

<div dir="ltr">If it is part number 500620, TRF has them at the modest price of $99.95ea.<br>
</div>

<div dir="ltr">Bill<br>
</div>

<div dir="ltr"><br>
</div>

<div dir="ltr">-----Original Message-----<br>
</div>

<div dir="ltr">From: Triumphs [mailto:<a ymailto="mailto:[email-masked]" href="mailto:[email-masked]">[email-masked]</a>] On Behalf Of Jim<br>
</div>

<div dir="ltr">Henningsen<br>
</div>

<div dir="ltr">Sent: Saturday, April 24, 2021 5:51 PM<br>
</div>

<div dir="ltr">To: 'Alex &amp; Janet Thomson' &lt;<a ymailto="mailto:[email-masked]" href="mailto:[email-masked]">[email-masked]</a>&gt;; 'TR3 Triumphs'<br>
</div>

<div dir="ltr">&lt;<a ymailto="mailto:[email-masked]" href="mailto:[email-masked]">[email-masked]</a>&gt;<br>
</div>

<div dir="ltr">Subject: Re: [TR] TR3A QUESTION<br>
</div>

<div dir="ltr"><br>
</div>

<div dir="ltr">Alex, the is the large brass drain plug under the OD if you were thinking of<br>
</div>

<div dir="ltr">the small square one under the main tranny.&nbsp; It has a hex head on it.&nbsp; I<br>
</div>

<div dir="ltr">think it is 1 1/16 inch size.&nbsp; It is different than the brass drain plug on<br>
</div>

<div dir="ltr">my TR4 a type.&nbsp; For that one Moss has a special wrench tool which works<br>
</div>

<div dir="ltr">great.&nbsp; I may need to get a wrench for the 3 plug as that might work better<br>
</div>

<div dir="ltr">than a socket.&nbsp; <br>
</div>

<div dir="ltr">Jim<br>
</div>

<div dir="ltr"><br>
</div>

<div dir="ltr">-----Original Message-----<br>
</div>

<div dir="ltr">From: Alex &amp; Janet Thomson &lt;<a ymailto="mailto:[email-masked]" href="mailto:[email-masked]">[email-masked]</a>&gt;<br>
</div>

<div dir="ltr">Sent: Saturday, April 24, 2021 5:20 PM<br>
</div>

<div dir="ltr">To: 'Jim Henningsen' &lt;<a ymailto="mailto:[email-masked]" href="mailto:[email-masked]">[email-masked]</a>&gt;; 'TR3 Triumphs'<br>
</div>

<div dir="ltr">&lt;<a ymailto="mailto:[email-masked]" href="mailto:[email-masked]">[email-masked]</a>&gt;<br>
</div>

<div dir="ltr">Subject: RE: [TR] TR3A QUESTION<br>
</div>

<div dir="ltr"><br>
</div>

<div dir="ltr">For the drain plug, go to a good NAPA store. I have changed some of my<br>
</div>

<div dir="ltr">tractors over to hex head pipe plugs since the square heads can round off so<br>
</div>

<div dir="ltr">easily. Of course, those machines date back to the 50's and before. They<br>
</div>

<div dir="ltr">should have them in brass, as well. They also have a good listing for<br>
</div>

<div dir="ltr">straight thread, flanged plugs, as well. Is that overdrive drain plug an<br>
</div>

<div dir="ltr">oddball thread?<br>
</div>

<div dir="ltr"><br>
</div>

<div dir="ltr">Sorry - can't help with question #2.<br>
</div>

<div dir="ltr"><br>
</div>

<div dir="ltr">Alex Thomson<br>
</div>

<div dir="ltr"><br>
</div>

<div dir="ltr">-----Original Message-----<br>
</div>

<div dir="ltr">From: Triumphs [mailto:<a ymailto="mailto:[email-masked]" href="mailto:[email-masked]">[email-masked]</a>] On Behalf Of Jim<br>
</div>

<div dir="ltr">Henningsen<br>
</div>

<div dir="ltr">Sent: Saturday, April 24, 2021 5:07 PM<br>
</div>

<div dir="ltr">To: TR3 Triumphs<br>
</div>

<div dir="ltr">Subject: [TR] TR3A QUESTION<br>
</div>

<div dir="ltr"><br>
</div>

<div dir="ltr">Are there any replacements for the brass overdrive drain plug on 61 3a?<br>
</div>

<div dir="ltr">Mine is worn a little making it difficult to tighten and loosen with socket.<br>
</div>

<div dir="ltr">What tricks are there to stop leaks out of this plug? <br>
</div>

<div dir="ltr"><br>
</div>

<div dir="ltr">Question 2.&nbsp; Anyone have a good used Tr3a hood latch.&nbsp; My neighbors has the<br>
</div>

<div dir="ltr">lever arm broken off making it difficult to unlatch.&nbsp; Attaches to the hood.<br>
</div>

<div dir="ltr"><br>
</div>

<div dir="ltr"><br>
</div>

<div dir="ltr">Many thanks,<br>
</div>

<div dir="ltr">Jim Henningsen<br>
</div>

<div dir="ltr">Ocala fl<br>
</div>

<div dir="ltr"><br>
</div>

<div dir="ltr">** <a ymailto="mailto:[email-masked]" href="mailto:[email-masked]">[email-masked]</a> **<br>
</div>

<div dir="ltr"><br>
</div>

<div dir="ltr">Donate: <a href="http://www.team.net/donate.html" target="_blank">http://www.team.net/donate.html</a><br>
</div>

<div dir="ltr">Archive: <a href="http://www.team.net/pipermail/triumphs" target="_blank">http://www.team.net/pipermail/triumphs </a> <a href="http://www.team.net/archive" target="_blank">http://www.team.net/archive</a><br>
</div>

<div dir="ltr"><br>
</div>

<div dir="ltr">Unsubscribe/Manage:<br>
</div>

<div dir="ltr"><a href="http://autox.team.net/mailman/options/triumphs/[email-masked]" target="_blank">http://autox.team.net/mailman/options/triumphs/[email-masked]</a><br>
</div>

<div dir="ltr"><br>
</div>

<div dir="ltr"><br>
</div>

<div dir="ltr">** <a ymailto="mailto:[email-masked]" href="mailto:[email-masked]">[email-masked]</a> **<br>
</div>

<div dir="ltr"><br>
</div>

<div dir="ltr">Donate: <a href="http://www.team.net/donate.html" target="_blank">http://www.team.net/donate.html</a><br>
</div>

<div dir="ltr">Archive: <a href="http://www.team.net/pipermail/triumphs" target="_blank">http://www.team.net/pipermail/triumphs </a> <a href="http://www.team.net/archive" target="_blank">http://www.team.net/archive</a><br>
</div>

<div dir="ltr"><br>
</div>

<div dir="ltr">Unsubscribe/Manage:<br>
</div>

<div dir="ltr"><a href="http://autox.team.net/mailman/options/triumphs/[email-masked]" target="_blank">http://autox.team.net/mailman/options/triumphs/[email-masked]</a><br>
</div>

<div dir="ltr"><br>
</div>

<div dir="ltr">** <a ymailto="mailto:[email-masked]" href="mailto:[email-masked]">[email-masked]</a> **<br>
</div>

<div dir="ltr"><br>
</div>

<div dir="ltr">Donate: <a href="http://www.team.net/donate.html" target="_blank">http://www.team.net/donate.html</a><br>
</div>

<div dir="ltr">Archive: <a href="http://www.team.net/pipermail/triumphs" target="_blank">http://www.team.net/pipermail/triumphs </a> <a href="http://www.team.net/archive" target="_blank">http://www.team.net/archive</a><br>
</div>

<div dir="ltr"><br>
</div>

<div dir="ltr">Unsubscribe/Manage: <a href="http://autox.team.net/mailman/options/triumphs/[email-masked]" target="_blank">http://autox.team.net/mailman/options/triumphs/[email-masked]</a><br>
</div>
</font></div>
</div>

------=_Part_185571_1045074157.1619351493819--

--===============5162825995401554713==
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

--===============5162825995401554713==--

---

From: <[email-masked]>
Date: Sun, 25 Apr 2021 14:21:43 -0400

I had the same problem, the arm broke off. I bought a new one from TRF. Do
they no longer carry them?

Keith Stewart
[email-masked]

-----Original Message-----
From: Jim Henningsen <[email-masked]> 
Sent: April 24, 2021 5:07 PM
To: TR3 Triumphs <[email-masked]>
Subject: [TR] TR3A QUESTION

Many thanks,
Jim Henningsen
Ocala fl