Subject: [TR] Powdercoating top frame

From: robert rudolphi <[email-masked]>
Date: Sat, 13 Mar 2021 16:14:19 +0000 (UTC)

Hi List,

I am replacing the top on my 74 TR6. I am considering have the frame powder coated and some firms are telling me no problem, others are saying they can not because "These are too intricate and the coating could reduce the mobility of the top". Looking for any feedback as to been there done that.

Thanks,

Robert
** [email-masked] **

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/pipermail/triumphs  http://www.team.net/archive

Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: Dennis and Bridget <[email-masked]>
Date: Sat, 13 Mar 2021 17:51:51 -0800

I had my ’71 TR6 top frame powdered coated in semi-gloss black about two years ago.  The frame looks and works fine.  A single drop of 3-in-1 oil on each joint and voila, no issues.  Just my single experience of course...
Dennis

> On Mar 13, 2021, at 8:14 AM, robert rudolphi <[email-masked]> wrote:
> 
> Hi List,
> 
> Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]