Subject: [TR] Ford Fiesta Bosch Alternator - was Headlight round Connection

From: "Bill Brewer" <[email-masked]>
Date: Sat, 13 Feb 2021 06:44:40 -0800

Good luck finding a Ford Fiesta alternator. I bought one about 10 years ago for a TR6 and they were everywhere and cheap. About a year ago I wanted one for a Morgan and they were nowhere to be found. I found some originals in France on Ebay, but they were not rebuilt or anything and they wanted over $300 + shipping. The other ones I found were always Remy "Bosch replacement", Motorcraft or "Fits" Fiesta alternator and they weren't even close to what I was looking for.
     Does anyone have a source for the original Fiesta Bosch alternator? I think that I got my last one from RockAuto and they don't have them now.
	https://www.rockauto.com/en/catalog/ford,1980,fiesta,1.6l+98cid+l4,1128293,electrical,alternator+/+generator,2412
     I ended up using a Dyno-alt from British Parts Northwest and have been happy. Looking like a generator but is an alternator. Looks great in the Morgan.
	https://www.bpnorthwest.com/triumph/tr2-tr3-tr4-tr4a/engine-electrical/charging-system/alternator-generator-new-tr2-to-tr4a.html
     But they are out of stock at the present...

     -Bill Brewer

-----Original Message-----
From: Paul Tegler [mailto:[email-masked]] 
Sent: Thursday, February 11, 2021 7:42 PM
To: [email-masked]
Subject: Re: [TR] Headlight round Connection

a typical 55W high beam headlamp =    55W / 13.5V = 4.07 Amps x2 = 8.14 
amps for both lights (give or take....)

Your stock alt should be fine while driving. BUT  The typical Lucas 26 
amp alternator though, is notorious for dropping out of regulation at an 
idle which does pull more current (55W / 12V = 4.5A. )

Unless your stuck on being super' original'...find a Bosch alt 
replacement. ('78 fiesta?) The stock Lucas connector will plug right in.

jfft

ptegler

On 2/11/2021 10:20 PM, WILLIAM SMITH wrote:
> Thanks to everyone who responded with possible answers and 
> recommendations.  As usual, I believe Dave Massey was spot-on with the 
> '72 headlight ground connection being a push-on connector attached to 
> the inner side of the front valance.  As my car is not back yet from 
> the body shop (long story/TMI), I can't actually test that connection 
> until I get it back.  However, I do have the original valance and 
> spotted the tab for the connector after Dave mentioned it in his reply 
> --- thanks Dave!   If cleaning that ground connection doesn't brighten 
> the lights, I'll have to probe further.
>
> As for those who suggested the headlight relay kit, I've been toying 
> with that idea for a while, so thanks for reminding me.  As the 
> original headlights were never bright enough, I was thinking of doing 
> the relay with a set of halogen sealed beams. Oh, and that would 
> probably call for an alternator upgrade, as well.  It never ends😊
>
> Bill Smith
>
> '72 TR6
>
> '80 TR7
>
>
-- 
Paul Tegler
[email-masked]  www.teglerizer.com

** [email-masked] **

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/pipermail/triumphs  http://www.team.net/archive

Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: Paul Tegler <[email-masked]>
Date: Sat, 13 Feb 2021 10:07:25 -0500

half a dozen listed....
https://www.google.com/search?q=bosch+replacement+for+lucas+alternator&client=firefox-b-1-d&source=lnms&tbm=isch&sa=X&ved=2ahUKEwic4eWikefuAhVLEVkFHZ3YBesQ_AUoA3oECAcQBQ&biw=850&bih=450 
<https://www.google.com/search?q=bosch+replacement+for+lucas+alternator&client=firefox-b-1-d&source=lnms&tbm=isch&sa=X&ved=2ahUKEwic4eWikefuAhVLEVkFHZ3YBesQ_AUoA3oECAcQBQ&biw=850&bih=450>

Fiesta was just on place that used a Bosch with a Lucas style connector

ptegler

---

From: Paul Tegler <[email-masked]>
Date: Sat, 13 Feb 2021 10:10:24 -0500

even better,,,Even on ebay and advancedauto

plenty around at under $100

https://www.google.com/search?client=firefox-b-1-d&ei=T-snYN71ArTk5NoPsYiz-AE&q=1978+Fiesta+Alternator&oq=1978+Fiesta+Alternator&gs_lcp=Cgdnd3Mtd2l6EAMyBwgAEEcQsAMyBwgAEEcQsAMyBwgAEEcQsAMyBwgAEEcQsANQ5dACWOXQAmDq1AJoA3ABeACAAUWIAX6SAQEymAEAoAEBqgEHZ3dzLXdpesgBBMABAQ&sclient=gws-wiz&ved=0ahUKEwie2ZvykefuAhU0MlkFHTHEDB8Q4dUDCAw&uact=5 
<https://www.google.com/search?client=firefox-b-1-d&ei=T-snYN71ArTk5NoPsYiz-AE&q=1978+Fiesta+Alternator&oq=1978+Fiesta+Alternator&gs_lcp=Cgdnd3Mtd2l6EAMyBwgAEEcQsAMyBwgAEEcQsAMyBwgAEEcQsAMyBwgAEEcQsANQ5dACWOXQAmDq1AJoA3ABeACAAUWIAX6SAQEymAEAoAEBqgEHZ3dzLXdpesgBBMABAQ&sclient=gws-wiz&ved=0ahUKEwie2ZvykefuAhU0MlkFHTHEDB8Q4dUDCAw&uact=5>

ptegler

---

From: Paul Tegler <[email-masked]>
Date: Sat, 13 Feb 2021 10:12:12 -0500

rockauto lists them too

ptegler

---

From: "Bill Brewer" <[email-masked]>
Date: Sat, 13 Feb 2021 07:53:22 -0800

While all of these say Bosch, will they fit a TR engine? The ones I checked all said for Mercedes Benz. If you search Ebay for a 1980 Ford Fiesta alternator, essentially all of them are different from the original Bosch That I have used in the past. They may or may not fit. You can make anything fit. I have even seen Kubota alternators on TR's, but wouldn't do that myself. The original Ford Fiesta Bosch just bolted right in and everything matched.
     I recently tried fitting a GM 10si alternator into my Standard Vanguard powered Morgan (essentially the same block as a TR) and the alternator wouldn't fit. It was similar to the last GM alternator I used, but there were interferences.

     -Bill Brewer

-----Original Message-----
From: Paul Tegler [mailto:[email-masked]] 
Sent: Saturday, February 13, 2021 7:10 AM
To: Bill Brewer; [email-masked]
Subject: Re: Ford Fiesta Bosch Alternator - was Headlight round Connection note @2

ptegler

---

From: Paul Tegler <[email-masked]>
Date: Sat, 13 Feb 2021 21:45:12 -0500

I personally have a 10si in FIS6 (6 cyl TR) without any fitment issues
for the one I used, I simply swapped out the serpentine belt pulley for 
a stock fan belt pulley

Ha...funny part... I'm in MD. the last alt that went in was in the 
middle of nowhere in Sandusky Ohio during a looonnng road trip to Mid 
Ohio races. The local O'Reilys where I got the replacement, even lent me 
a battery powered impact driver driver and let me swap pulleys on a work 
bench in back.

ptegler