Subject: [TR] Free Spark Plugs

From: "Jim Henningsen" <[email-masked]>
Date: Mon, 8 Feb 2021 09:48:46 -0500

I found I had four new Autolite AP64 Platinum spark plugs.  They are not for
any of my TRs.  Turns out they fit Stag, Spitfire 1500, Mark 2-4, Herald and
GT6 Mark 1-3.  They list at $3.79 each on advance auto parts.  Happy to
offer them to anyone for cost of shipping a small envelope.  Otherwise they
will end up in the trash. New in the box.  Email me off list please if
interested.  
Jim Henningsen 
Ocala FL

** [email-masked] **

Archive: http://www.team.net/pipermail/triumphs  http://www.team.net/archive

---

From: Bud Rolofson <[email-masked]>
Date: Mon, 8 Feb 2021 09:17:54 -0700

Hi Jim,

I use the AP64s in my Spitfire. I’ll take them if no else has already.

Thanks
Bud

> On Feb 8, 2021, at 7:48 AM, Jim Henningsen <[email-masked]> wrote:
> 
> Donate: http://www.team.net/donate.html
> Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]

Bud Rolofson

Extreme Parts Racing (more than just a haircut)

71TR6 CC57365 (Good 6)
71 Spitfire MK IV Race Car #3
69 Spitfire MK III (back up FE engine/dinghy car)
93 Minnie Winnie Race Support Vehicle 
77 Z-50A Hardly Davidson Honda Mini-Trail Bike (Triumph Pit Bike)

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/pipermail/triumphs  http://www.team.net/archive

Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]