Subject: [TR] Electric fan for TR2

From: John Deluca <[email-masked]>
Date: Sun, 27 Sep 2020 10:44:23 -0500

Listers,
Looking for a recommendation for an electric fan for my TR2.  I am not comfortable with those that attach with what look like cable ties.  Thermostatically controlled is not necessary.  On/off switch is good.  Am looking for adequate cooling, good fit and relatively simple installation.  Any comments always appreciated.
John DeLuca
St. Louis

Sent from my iPad
** [email-masked] **

Archive: http://www.team.net/pipermail/triumphs  http://www.team.net/archive

---

From: <[email-masked]>
Date: Sun, 27 Sep 2020 12:17:19 -0400

I had a great experience with a company called C, G and J in Gadsden,
Alabama.  I ended up with an aluminum radiator with an electric fan attached
by brackets.  I did get the thermostatically-controlled fan which I love.
As I get older and forgetful I don't have to remember to turn it on at the
stop lights!

Andrew Uprichard
Jackson, Michigan

-----Original Message-----
From: Triumphs <[email-masked]> On Behalf Of John Deluca
Sent: Sunday, September 27, 2020 11:44 AM
To: <[email-masked]> <[email-masked]>
Subject: [TR] Electric fan for TR2

Listers,
Looking for a recommendation for an electric fan for my TR2.  I am not
comfortable with those that attach with what look like cable ties.
Thermostatically controlled is not necessary.  On/off switch is good.  Am
looking for adequate cooling, good fit and relatively simple installation.
Any comments always appreciated.
John DeLuca
St. Louis

Sent from my iPad

http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: DAVE HOGYE <[email-masked]>
Date: Sun, 27 Sep 2020 09:23:34 -0700 (PDT)

Puller fans with shroud mounting is most efficient, but that means removing the original fan.  Front/push mounting can block normal flow.  The cable tie attachment is quick and easy, but can cause eventual damage to the radiator.  MGBs use a front mounted pusher fans with brackets.  You might consider this type of arrangement.  The MG auxiliary fans have a more classic look and might fit nicely with custom fabricated brackets.  Cobras use a similar arrangement.  I don't know how compatible this would be with the standard grill and opening of a TR2.  I don't think there is room between the grill and radiator for a modern low profile fan.   
I have a Griffin aluminum radiator with a puller fan and shroud, all purchased as a unit from Griffin.  Not inexpensive at $700, but it's a quality setup.  There are less expensive (cheaper) options. 
Good luck,
Dave H.
> On 09/27/2020 8:44 AM John Deluca <[email-masked]> wrote:
> 
>  
> Listers,
> Donate: http://www.team.net/donate.html
> Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]