Subject: [TR] The U.K. TR6 driver

From: John Macartney <[email-masked]>
Date: Mon, 7 Sep 2020 00:16:39 +0100

I think it’s unlikely this owner is on this list - but just in case, this is for him.

Remember yesterday on the A46 near Bidford on Avon? I was the bloke in the black Volvo C70  convertible who took pity on you stranded at the roadside with a  fuel  metering unit whose timing was out of whack. Some things for you to remember for future reference:

1. I stopped to offer you help out of kindness and curiosity. No emergency mechanic will understand the Lucas injection system fitted on your TR6. I do, having worked on many cars with that equipment when new and I’ve owned three myself.

2. If you choose to drive a classic car, One jack without a handle, no wheelnut spanner at all and a sloppy adjustable spanner does NOT represent a toolkit! Wasn’t it handy that mine was available?

3. If you paid £30,000 for that car, the seller saw you coming. The engine needs a major rebuild from the racket it makes at idle, the electrics look positively dangerous and the fuel pump is over-fuelling the metering unit. What I did at the roadside in re-timing your metering unit to squirt the correct pipe at least got you running on all six, albeit not smoothly but enough to get you home.

4. I hope you enjoyed the lunch you never stopped telling me you were likely to miss as I worked on your car and...

5. If anyone else ever stops to help you at the roadside when they had no need to themselves, remember it’s customary to say just two words before storming off in a cloud of smoke and crashing gears. Those words? Thank you is the customary in England and a few other places too.

Sproutpicker!

Jonmac

Bessie Braddock: “Winston! You’re drunk”.
Churchill: “and you, Madam, are ugly. But tomorrow, I shall be sober but you will still be ugly”.
** [email-masked] **

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/pipermail/triumphs  http://www.team.net/archive

Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: bill beecher <[email-masked]>
Date: Sun, 6 Sep 2020 21:36:00 -0500

John,
Well done, as expected you are a true gentleman on it off the road.  

£30k for a TR6?  Sorry you didn’t get his name and number, I have a clapped out Landie I might let go for about £40k to the right guy.  

Now, I must go re-check my toolkit. 

Bill B
‘58 TR3A
‘54 Morgan Plus 4
‘68 Land Rover
‘48 Jeepster

#dontkillgrandma

On Sep 6, 2020, at 6:34 PM, Bob <[email-masked]> wrote:

Jonmac,

I have no idea what a Sproutpicker is but I can guess.

You did what good folks do. And I thank you for it.

But did he really pay 30,000 pounds for a TR6? And one that needs another 5K in engine work?

Wow. I'll try to remember that the next time I take the 6 out for a spin. It has HS6s but runs and sounds just fine.

And no the 6 is not yellow, the 3 is!

By the way, we did pick up a number of British slang terms on the TV show "Line of Duty". Great show for anyone interested. My late mom would have loved it!

Bob

> On 9/6/20 7:16 PM, John Macartney wrote:
> Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]

Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]