Subject: [TR] Randall Young

From: Ann Carletta <[email-masked]>
Date: Fri, 24 Jul 2020 19:16:38 +0000 (UTC)

--===============6405134011309997392==
	boundary="----=_Part_4768732_512372554.1595618198866"

------=_Part_4768732_512372554.1595618198866
Content-Transfer-Encoding: quoted-printable

Says a=C2=A0 lot about a man who made such positive impressions on so many =
people, many he'd never even met.
We'll miss you, Randall.
Thanks for your wisdom.
Ann60 TR365 Daimler V8 2.5 L12 Jag XF
------=_Part_4768732_512372554.1595618198866
Content-Transfer-Encoding: 7bit

<html><head></head><body><div class="yahoo-style-wrap" style="font-family:Helvetica Neue, Helvetica, Arial, sans-serif;font-size:16px;"><div dir="ltr" data-setdir="false">Says a&nbsp; lot about a man who made such positive impressions on so many people, many he'd never even met.</div><div dir="ltr" data-setdir="false"><br></div><div dir="ltr" data-setdir="false">We'll miss you, Randall.</div><div dir="ltr" data-setdir="false"><br></div><div dir="ltr" data-setdir="false">Thanks for your wisdom.</div><div dir="ltr" data-setdir="false"><br></div><div dir="ltr" data-setdir="false">Ann</div><div dir="ltr" data-setdir="false">60 TR3</div><div dir="ltr" data-setdir="false">65 Daimler V8 2.5 L</div><div dir="ltr" data-setdir="false">12 Jag XF</div></div></body></html>
------=_Part_4768732_512372554.1595618198866--

--===============6405134011309997392==
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

** [email-masked] **

Archive: http://www.team.net/pipermail/triumphs  http://www.team.net/archive

--===============6405134011309997392==--

---

From: Dave MacKay <[email-masked]>
Date: Fri, 24 Jul 2020 18:09:15 -0400

Like so many of us, I never met Randall but I felt as if he was an old
friend. I certainly benefited from his knowledge about all things Triumph,
and from his generosity in sharing that knowledge.

The Triumph community is much smaller without Randall's presence. I'll
miss him.

Dave MacKay
1960 Triumph TR3A
s/n 68639L
near Toronto, Canada

>From: "andrew uprichard" <[email-masked]>
>To: <[email-masked]>,	"'6-Pack'" <[email-masked]>
>Subject: [TR] Randall Young
>
>I just got a call from Randall's wife, Mei.  Randall died 2 days ago.  He
>was only 64.  Very sad indeed.
>
>Mei asked me to let his Triumph friends know, so I have posted a note on
TRE
>as well as this email.  Anyone who knew Randall should feel free to post
to
>other sites where he was active.
>
>Mei told me they are planning a funeral in the Midwest (Missouri, I
believe,
>but she was very emotional and hard to follow).  She said any friends who
>want to know more should call her on her cell phone:  (562) 303 8007.
Her
>address is 5754 Coke Avenue, Lakewood, CA  90712-1605.
>
 >Rest in peace, Randall - we will miss you.
>
>Andrew