Subject: Re: [TR] Floor Jack

From: Chris Simo <[email-masked]>
Date: Mon, 28 Oct 2019 22:46:29 -0400

--===============2601211333505012677==

--000000000000454f85059603a09b

I have the low profile steel one. Very happy. The orange one I had blew a
seal, but was a work horse for many years

--000000000000454f85059603a09b

<div dir="auto"><div data-smartmail="gmail_signature">I have the low profile steel one. Very happy. The orange one I had blew a seal, but was a work horse for many years</div></div>

--000000000000454f85059603a09b--

--===============2601211333505012677==
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

** [email-masked] **

Archive: http://www.team.net/pipermail/triumphs  http://www.team.net/archive

--===============2601211333505012677==--

---

From: Rochlin Robert <[email-masked]>
Date: Tue, 29 Oct 2019 08:43:02 -0400

I’ve had a 3 ton HF aluminum jack for about 2 years. It really is much easier than my steel jacks to muscle around and, on sale, it was really reasonable.  It seems that the chief criticism for all of the HF jacks in the rating is that the seals fail, sometimes almost immediately, and there are no rebuild kits or replacement seals available.  My guess is that if the seals seat correctly when new the HF jacks are pretty reliable.
	Best,
	Bob

> On Oct 28, 2019, at 10:46 PM, Chris Simo <[email-masked]> wrote:
> 
> I have the low profile steel one. Very happy. The orange one I had blew a seal, but was a work horse for many years
> Donate: http://www.team.net/donate.html
> Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/pipermail/triumphs  http://www.team.net/archive

Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]