Subject: [TR] American Collectors

From: "Fisher, Ed" <[email-masked]>
Date: Fri, 19 Oct 2018 10:37:33 +0000

I have insured classics with American Collectors and have had a claim.  It was a fair assessment for repair, though not generous by any means, and the drama was absent which worked for me.  Timely response, quick turn on check, and deal done.  

Ed in Dallas

Sent from a wireless device 
** [email-masked] **

Archive: http://www.team.net/pipermail/triumphs  http://www.team.net/archive

---

From: Frank Magnusson <[email-masked]>
Date: Fri, 19 Oct 2018 19:57:05 -0500

Good to know, Ed.  I have them also and have not had a claim yet, but wondered how they would be.  In other respects, they seem better than alot of the other companies.

Thanks for posting,

Frank
'72 Stag

Sent from my iPad