Subject: [TR] Powder Coat Fuel Pump

From: Roger Elliott <[email-masked]>
Date: Sun, 14 Aug 2016 16:45:11 -0500

Hi,

Can a lever type fuel pump be powder coated successfully?   I know Fred 
seemed to suggest powder coating just about everything.

I have the fuel pump all apart except the lever -  It looks like there 
are seals underneath where the lever attaches to the body and I can't 
figure out away to get the lever off.

I do  have the cup and the seals underneath it out.

Thanks,
Roger

** [email-masked] **

Archive: http://www.team.net/archive

---

From: "[email-masked]" <[email-masked]>
Date: Sun, 14 Aug 2016 17:01:43 -0500

Don't see why not as long as all the rubber and moving bits are separated.  

Sent from my Altair 8800

On Aug 14, 2016, at 4:45 PM, Roger Elliott <[email-masked]> wrote:

Hi,

Can a lever type fuel pump be powder coated successfully?   I know Fred seemed to suggest powder coating just about everything.

I have the fuel pump all apart except the lever -  It looks like there are seals underneath where the lever attaches to the body and I can't figure out away to get the lever off.

Thanks,
Roger