Subject: Re: [TR] VTR

From: darrell floyd <[email-masked]>
Date: Wed, 2 Mar 2016 15:45:28 -0500

>From the picture, I'm thinking I was at the Mall of America at the
time hanging out at Hooters for lunch and this was from the Convention
in Hudson, Wisconsin but that can't be right can it?
Darrell

On Wed, Mar 2, 2016 at 7:58 AM, Dave <[email-masked]> wrote:
> 1995 or 2005?  I'm thinkin' 1995.
>
>
> Dave Massey
>
>
>
> -----Original Message-----
> From: Mark J Bradakis <[email-masked]>
> To: triumphs <[email-masked]>
> Sent: Tue, Mar 1, 2016 10:30 pm
> Subject: Re: [TR] VTR
>
> Duh.
>
>
>
> ** [email-masked] **
>
> Donate: http://www.team.net/donate.html
> Archive: http://www.team.net/archive
> Forums: http://www.team.net/forums
> Unsubscribe/Manage:
> http://autox.team.net/mailman/options/triumphs/[email-masked]
>
>
>
> ** [email-masked] **
>
> Donate: http://www.team.net/donate.html
> Archive: http://www.team.net/archive
> Forums: http://www.team.net/forums
> Unsubscribe/Manage:
> http://autox.team.net/mailman/options/triumphs/[email-masked]
>

** [email-masked] **

Archive: http://www.team.net/archive

---

From: Jack Mc <[email-masked]>
Date: Wed, 2 Mar 2016 16:44:08 -0500

Sign in picture has "Time Museum" on it
So I was thinking the first Rockford, Ill convention 

Sent from my iPad

> On Mar 2, 2016, at 3:45 PM, darrell floyd <[email-masked]> wrote:
> 
> Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]