Subject: Re: [TR] Insurance question

From: "[email-masked]" <[email-masked]>
Date: Sun, 20 Mar 2016 13:05:40 -0500

I have Hagerty Ins, they are always helpful with questions.  Rates seemed to be about the same as others for similar coverage.  

When I lost my TR3 to fire last year they paid the agreed amount without hesitation.   Wish I could say the same for my homeowners policy that covered the contents.  ISTR they don't care as much about when/where you are driving as much as the mileage, I think my limit is 2,000. 

Sent from my VIC-64

On Mar 20, 2016, at 11:33 AM, <[email-masked]> <[email-masked]> wrote:

I have used J.C. Taylor for my TR250 and now my Porsche, I haven't compared lately, but they were slightly cheaper than Hagerty when I got my quote, and I have always told them that the car gets more use than club events and parades, that I drive them for pleasure and may even occasionally drive them to work.  They seem to be ok with that, at least they went ahead and took the policy, I haven't had a claim with them yet, so can't comment on that important aspect of their service.

Greg Lemon
TR250

---- [email-masked] wrote: 
> That's who I use, would be curious on the percentage increase?
> 
> All auto insurance rates are going up since late last year.
> 
> Craig
> TR6 
> 
> 
> On 03/20/16, Andrew Uprichard wrote:
> 
> 
> 
> 
> I know this subject was raised in the past, so sorry for the repetition, but my insurer (American Collectors in NJ) seems to have had an increase in rates and I was wondering who most of you use.  I have a multi-car policy and think I can do better than this latest bill.
> 
> 
> 
> Andrew Uprichard
> 
> 
> ** [email-masked] **
> 
> Donate: http://www.team.net/donate.html
> Archive: http://www.team.net/archive
> Forums: http://www.team.net/forums
> Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]
> 
> ** [email-masked] **
> 
> Donate: http://www.team.net/donate.html
> Archive: http://www.team.net/archive
> Forums: http://www.team.net/forums
> Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]

** [email-masked] **

Archive: http://www.team.net/archive

** [email-masked] **

Archive: http://www.team.net/archive

---

From: Jeff Scarbrough <[email-masked]>
Date: Sun, 20 Mar 2016 20:02:35 -0400

On Sun, Mar 20, 2016 at 2:05 PM, [email-masked] <[email-masked]> wrote:
> I have Hagerty Ins [...] ISTR they don't care as much about when/where you are driving as much as the mileage, I think my limit is 2,000.

>From the Hagery FAQ:

Our policy is a flexible, limited use policy. We do not, however,
limit you to just show and club use. Occasional pleasure driving fits
our underwriting guidelines, but our policy is not intended for
vehicles regularly driven to work or school or for running errands. We
look for usage that is consistent with owning a valuable automobile
and the availability of insured regular-use vehicles for daily
transportation. While the average mileage generally put on a collector
vehicle is approximately 2,000-3,000 miles annually, our policy
language does not state a specific mileage limitation.

This limited, flexible use policy includes coverage for pleasure
driving. That may mean taking your family out to dinner, out for ice
cream or on an enjoyable Sunday cruise, for example. Taking the
vehicle once in a blue moon to work to show it off is acceptable as
well. We ask that you as the owner of a collectible vehicle make the
decisions that are right for your situations.  We have not had a
problem with our clients abusing the privilege of flexible usage, so
we are able to continue without the strict guidelines that some of our
competitors may have. We would prefer that you do not take the vehicle
to high-risk parking lots, such as the gym or the mall.

https://www.hagerty.com/articles-videos/ask-hagerty/what-is-limited-use

So no limit, except common sense.

Jeff Scarbrough
Corrosion Acres, Ga.