Subject: Re: [TR] in a word,which top

From: Frank Magnusson <[email-masked]>
Date: Sat, 6 Feb 2016 13:47:10 -0600

As far as suppliers, I'd go with TRF.  Their parts, from dealing with them over many years, are as close to original as you can get and very high quality.  Moss is descent. VB is a distant last.  Generic junk.

Sent from my iPad

** [email-masked] **

Archive: http://www.team.net/archive

---

From: Jeff Scarbrough <[email-masked]>
Date: Sat, 6 Feb 2016 14:59:39 -0500

On Sat, Feb 6, 2016 at 2:47 PM, Frank Magnusson <[email-masked]> wrote:
> As far as suppliers, I'd go with TRF.

And convertible tops will be going on sale sometime in the next few weeks...

-- Thrifty Jeff