Subject: Re: [TR] How much oil pressure is too much?

From: david brady <[email-masked]>
Date: Sun, 20 Sep 2015 20:46:23 -0400

I just ordered a 12 pk of Brad Penn, Penn Grade 1, 20w-50 on Amazon for 
$77.00.

Because I'm running an Elgin 715-18 cam and that's where the power is. 
It actually produces good power from 2K to 6K rpms.

Triple webers, shaved head, heavily ported and matched, 1.65:1 roller 
rockers, tubular push rods, cam bearings, etc, etc. 150hp at the wheels, 
dyno-ed.

David Brady
'68 TR250
CD8124L

On 9/20/2015 7:51 PM, Chad wrote:
> Why are you revving it that high?
>
> Sent from Yahoo Mail on Android 
> <https://overview.mail.yahoo.com/mobile/?.src=Android>
>
> ------------------------------------------------------------------------
> *From*:"david brady" <[email-masked]>
> *Date*:Sun, Sep 20, 2015 at 4:49 PM
> *Subject*:[TR] How much oil pressure is too much?
>
> Folks,
>
> My '68 TR250 delivers 50 to 55 psi at 2000 rpm but at 5500 rpm the oil
> pressure is as high as 85psi. This is with a thoroughly warmed up engine
> on a warm day. Is this too high? I'm thinking my pressure relief valve
> is stuck. Thoughts?
>
> Thanks,
> David Brady
> '68 TR250
> CD8124L
>
> ** [email-masked] <javascript:return> **
>
> Donate: http://www.team.net/donate.html
> Archive: http://www.team.net/archive
> Forums: http://www.team.net/forums
> Unsubscribe/Manage: 
> http://autox.team.net/mailman/options/triumphs/[email-masked]
>

** [email-masked] **

Archive: http://www.team.net/archive

---

From: Ted Schumacher <[email-masked]>
Date: Mon, 21 Sep 2015 15:07:10 -0400

A few years ago when the zinc issue was just starting to raise its ugly 
head, we spent a year looking at what oil to offer. Finally settled on 
Brad Penn.  Good product and they offer a break-in oil which was a real 
perk since we rebuild a lot of engines. We also (commercial message) 
sell it for $72/case. Ted

On 9/20/2015 8:46 PM, david brady wrote:
> I just ordered a 12 pk of Brad Penn, Penn Grade 1, 20w-50 on Amazon 
> for $77.00.
>
> rockers, tubular push rods, cam bearings, etc, etc. 150hp at the 
> wheels, dyno-ed.
>
> David Brady
> '68 TR250
> CD8124L
>
> http://autox.team.net/mailman/options/triumphs/[email-masked]
>
>

-- 
Ted Schumacher
[email-masked]
http://www.tsimportedautomotive.com
108 S. Jefferson St.
Pandora, Ohio, USA 45877
Fax: 419.384.3272 (24 Hrs.)
Phone: 800.543.6648 (US & Canada)
Tech/ Gen. Information/ Worldwide: 419.384.3022