Subject: [TR] How much oil pressure is too much?

From: david brady <[email-masked]>
Date: Sun, 20 Sep 2015 17:48:59 -0400

Folks,

My '68 TR250 delivers 50 to 55 psi at 2000 rpm but at 5500 rpm the oil 
pressure is as high as 85psi. This is with a thoroughly warmed up engine 
on a warm day. Is this too high? I'm thinking my pressure relief valve 
is stuck. Thoughts?

Thanks,
David Brady
'68 TR250
CD8124L

** [email-masked] **

Archive: http://www.team.net/archive

---

From: david brady <[email-masked]>
Date: Sun, 20 Sep 2015 18:15:50 -0400

Thanks Craig,

I appreciate it. What's your favorite oil to run? Is Brad Penn still the 
preferred choice for it's ZDDP content?

Thanks,
David Brady
'68 TR250
CD8124L

On 9/20/2015 5:54 PM, [email-masked] wrote:
> Sounds fine to me.
>
> Craig 72 TR6
>   
>
> On 09/20/15, david brady wrote:
>
> Folks,
>
> Donate: http://www.team.net/donate.html
> Forums: http://www.team.net/forums
> Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]
>

---

From: Chad <[email-masked]>
Date: Sun, 20 Sep 2015 16:51:21 -0700

--===============4601537337697192359==

--1167350687-1209945134-1442793081=:88927

Why are you revving it that high?

Sent from Yahoo Mail on Android

From:"david brady" <[email-masked]>
Date:Sun, Sep 20, 2015 at 4:49 PM
Subject:[TR] How much oil pressure is too much?

Folks,

Thanks,
David Brady
'68 TR250
CD8124L

--1167350687-1209945134-1442793081=:88927

<table cellspacing="0" cellpadding="0" border="0"><tr><td valign="top">Why are you revving it that high?<br><br><p><a href="https://overview.mail.yahoo.com/mobile/?.src=Android">Sent from Yahoo Mail on Android</a></p> <hr><table cellspacing="0" cellpadding="0" border="0"> <tbody> <tr> <td valign="top"> <div style="font-family:Roboto, sans-serif;color:#7e7d80;"><b>From</b>:"david brady" &lt;[email-masked]&gt;<br><b>Date</b>:Sun, Sep 20, 2015 at 4:49 PM<br><b>Subject</b>:[TR] How much oil pressure is too much?<br><br></div> <div id="msgSandbox_AMi2FimIAAALpVf8p7Q7sUKxw7Vg_TEXT" class="msgSandbox" style="padding: 1.5em 0.5em 0.5em 1.2em; word-wrap: break-word;">Folks,<br><br>My '68 TR250 delivers 50 to 55 psi at 2000 rpm but at 5500 rpm the oil <br>pressure is as high as 85psi. This is with a thoroughly warmed up engine <br>on a warm day. Is this too high? I'm thinking my pressure relief valve <br>is stuck. Thoughts?<br><br>Thanks,<br>David
 Brady<br>'68 TR250<br>CD8124L<br><br>** <a ymailto="mailto:[email-masked]" href="javascript:return">[email-masked]</a> **<br><br>Donate: <a href="http://www.team.net/donate.html" target="_blank">http://www.team.net/donate.html</a><br>Archive: <a href="http://www.team.net/archive" target="_blank">http://www.team.net/archive</a><br>Forums: <a href="http://www.team.net/forums" target="_blank">http://www.team.net/forums</a><br>Unsubscribe/Manage: <a href="http://autox.team.net/mailman/options/triumphs/[email-masked]" target="_blank">http://autox.team.net/mailman/options/triumphs/[email-masked]</a><br></div></td>  </tr>   </tbody>   </table></td></tr></table>
--1167350687-1209945134-1442793081=:88927--

--===============4601537337697192359==
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

--===============4601537337697192359==--