Subject: [TR] TR3 Panel Switches

From: [email-masked]
Date: Sun, 12 Jul 2015 14:31:46 +0000 (UTC)

All right.  For the past 10 years, I've driven with the original switches.  The spring-loaded button that holds the knobs on were long gone.  To get the knobs on, I've drilled and tapped and managed to keep them on with a variety of allen screws and even wood screws when the holes got too buggered.

Headlamp switch has now failed, the dash panel is pulled and I'm thinking now's the time to replace them all.

Question:  is there a difference in quality between the ones offered by Moss as compared to TRF?  Please, I don't mean this to be a referendum on the quality of either supplier, only a question about this particular part type since the original Lucas design is tricky to begin with.  I've enjoyed great service and quality products from both Moss and TRF over the years.

Thank you, everyone.

Terry Smith, '59 TR3A
New Hampshire

** [email-masked] **

Archive: http://www.team.net/archive

---

From: Don Hiscock <[email-masked]>
Date: Sun, 12 Jul 2015 10:16:31 -0500

I've found all the replacements to be about equal, and all of them
deficient compared to original (in period) Lucas switchgear.

For example, an original headlamp switch on my TR3B (not the one that
came on my car; that's still MIA in the barn where it spent twenty
years) broke a Bakelite lug.  I replaced it with a Moss switch and was
puzzled when for a few months I kept losing headlight power due to
wires breaking at a switch terminal. Turned out the replacement's
terminal screws had a sharpish edge around what should have been a
flat-ended screw.  Appeared to be due to the way the threads were
rolled onto the screw.  That sharp ring at the end of the screw was
cutting through the copper strands.  A few minutes on a file and they
were all fixed. That's NOT something one would see with old Lucas
stuff.

I try to keep my old stuff in service, or at least hunt down good
original Lucas.

On 7/12/15, [email-masked] <[email-masked]> wrote:
>
> All right.  For the past 10 years, I've driven with the original switches.
> The spring-loaded button that holds the knobs on were long gone.  To get the
> knobs on, I've drilled and tapped and managed to keep them on with a variety
> of allen screws and even wood screws when the holes got too buggered.
>
> Question:  is there a difference in quality between the ones offered by Moss
> as compared to TRF?  Please, I don't mean this to be a referendum on the
> quality of either supplier, only a question about this particular part type
> since the original Lucas design is tricky to begin with.  I've enjoyed great
> service and quality products from both Moss and TRF over the years.
>
> Thank you, everyone.
>
> Terry Smith, '59 TR3A
> New Hampshire
>
> Donate: http://www.team.net/donate.html
> Forums: http://www.team.net/forums
> Unsubscribe/Manage:
> http://autox.team.net/mailman/options/triumphs/[email-masked]
>