Subject: [TR] Lucas Fog Light Switch

From: Joe <[email-masked]>
Date: Thu, 23 Jul 2015 17:31:37 -0400

Hello to all,

My original fog light/driving light switch (in plinth with light) just 
croaked for some reason. I can't seem to find a replacement. It is a 
standard looking black toggle switch with two positions. Down for off 
and mid for on.  I've tried British Miles with no luck.   Any other 
suggestions?

Thanks,

Joe B

** [email-masked] **

Archive: http://www.team.net/archive

---

From: Thomas Fansher <[email-masked]>
Date: Thu, 23 Jul 2015 17:56:01 -0500

You might try Holden in the UK.  
Tom

Sent from my iPhone

> On Jul 23, 2015, at 4:31 PM, Joe <[email-masked]> wrote:
> 
> Hello to all,
> 
> My original fog light/driving light switch (in plinth with light) just croaked for some reason. I can't seem to find a replacement. It is a standard looking black toggle switch with two positions. Down for off and mid for on.  I've tried British Miles with no luck.   Any other suggestions?
> 
> Thanks,
> 
> Joe B
> 
>