Subject: [TR] TR3 Radiator Design

From: Hoyt Duff <[email-masked]>
Date: Sun, 17 May 2015 17:21:06 -0400

I know the popular mod to the radiator is to re-core it to eliminate
the hole for the starter handle.

And the "performance" replacements all appear to be essentially
aluminum duplicates of the original design.

Has anyone looked at triple-pass crossflow radiators? I realize that
the original rad is narrow, but only to clear the steering box; it
looks like it could be extended on the passenger side.

Combined with a shrouded electric puller fan, it seems like that would
be a worthwhile improvement.

-- 
Hoyt

** [email-masked] **

Archive: http://www.team.net/archive

---

From: David Friedlander <[email-masked]>
Date: Mon, 18 May 2015 09:13:24 -0400

--===============2041012696234899895==

--001a1133dd744a38b005165af7bf

Hoyt and all;

Have you seen *this *page?

http://www.wizardcooling.com/triumph-tr3-s/1913.htm

I've heard nothing but good things about Wizard Cooling's quality...

Dave Friedlander

On Sun, May 17, 2015 at 5:21 PM, Hoyt Duff <[email-masked]> wrote:

> Donate: http://www.team.net/donate.html
> Forums: http://www.team.net/forums
> Unsubscribe/Manage:
> http://autox.team.net/mailman/options/triumphs/[email-masked]
>

--001a1133dd744a38b005165af7bf
Content-Transfer-Encoding: quoted-printable

<div dir=3D"ltr"><div class=3D"gmail_default" style=3D"font-family:comic sa=
ns ms,sans-serif;color:rgb(0,0,153)">Hoyt and all;<br><br></div><div class=
=3D"gmail_default" style=3D"font-family:comic sans ms,sans-serif;color:rgb(=
0,0,153)">Have you seen <i>this </i>page?<br><br><a href=3D"http://www.wiza=
rdcooling.com/triumph-tr3-s/1913.htm">http://www.wizardcooling.com/triumph-=
tr3-s/1913.htm</a><br><br>I&#39;ve heard nothing but good things about Wiza=
rd Cooling&#39;s quality...<br></div><div class=3D"gmail_default" style=3D"=
font-family:comic sans ms,sans-serif;color:rgb(0,0,153)"><br></div><div cla=
ss=3D"gmail_default" style=3D"font-family:comic sans ms,sans-serif;color:rg=
b(0,0,153)">Dave Friedlander<br><br></div><div class=3D"gmail_extra"><br><d=
iv class=3D"gmail_quote">On Sun, May 17, 2015 at 5:21 PM, Hoyt Duff <span d=
ir=3D"ltr">&lt;<a href=3D"mailto:[email-masked]" target=3D"_blank">hoyt=
[email-masked]</a>&gt;</span> wrote:<br><blockquote class=3D"gmail_quote" s=
tyle=3D"margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">I kn=
ow the popular mod to the radiator is to re-core it to eliminate<br>
the hole for the starter handle.<br>
<br>
And the &quot;performance&quot; replacements all appear to be essentially<b=
r>
aluminum duplicates of the original design.<br>
<br>
Has anyone looked at triple-pass crossflow radiators? I realize that<br>
the original rad is narrow, but only to clear the steering box; it<br>
looks like it could be extended on the passenger side.<br>
<br>
Combined with a shrouded electric puller fan, it seems like that would<br>
be a worthwhile improvement.<br>
<span class=3D"HOEnZb"><font color=3D"#888888"><br>
--<br>
Hoyt<br>
<br>
** <a href=3D"mailto:[email-masked]">[email-masked]</a> *=
*<br>
<br>
//www.team.net/donate.html</a><br>
Archive: <a href=3D"http://www.team.net/archive" target=3D"_blank">http://w=
ww.team.net/archive</a><br>
Forums: <a href=3D"http://www.team.net/forums" target=3D"_blank">http://www=
.team.net/forums</a><br>
hs/[email-masked]" target=3D"_blank">http://autox.team.net/mailman/opti=
ons/triumphs/[email-masked]</a><br>
</font></span></blockquote></div><br></div></div>

--001a1133dd744a38b005165af7bf--

--===============2041012696234899895==
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

--===============2041012696234899895==--

---

From: "[email-masked]" <[email-masked]>
Date: Mon, 18 May 2015 10:31:09 -0400

--===============2465607913635210354==
	boundary="----=_Part_0_1431959469905"

------=_Part_0_1431959469905
	charset=utf-8
Content-Transfer-Encoding: base64
Content-Disposition: inline

------=_Part_0_1431959469905
	charset=utf-8
Content-Transfer-Encoding: base64
Content-Disposition: inline

------=_Part_0_1431959469905--

--===============2465607913635210354==
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

--===============2465607913635210354==--

---

From: Don Hiscock <[email-masked]>
Date: Mon, 18 May 2015 23:07:36 +0100

I had a Wizard Cooling radiator in my car when it came back on the
road in 2012.  Two of 'em in fact.  The first one had a upper tank
hose inlet that would have taken a truly interesting piece of hose to
connect with the thermostat housing.  It was offset by several inches
from being lined up.

Turns out Wizard Cooling were subcontracting work to people who had
wrong drawings or couldn't read the right ones, and it had to go back
to them.  The next one fit, but I was never convinced tank volumes or
flow rates were quite sufficient.  My car puked coolant every time I
drove it for about a year.  I went to a recored original.  Maybe it
was unrelated changes such as better tuning and engine break-in, but
the car seems much happier now.  The gently-used Wizard radiator is in
my parts stash.  If somebody is really eager for one, lemme know.

So here's a least one voice with something other than good things to
say about them...