Subject: [TR] bulb question

From: Alexander Delis <[email-masked]>
Date: Fri, 17 Apr 2015 21:33:16 -0400

List!

All of this talk about using LEDs as brighter and more efficient lighting got me thinking about doing this myself

I have a pair of Lucas 700 tripods on my TR3

It is my recollection that it uses H4 bulbs

I found these 

http://www.aliexpress.com/item/UPGRADE-NEW-1x-2014-Just-Plug-Play-CREE-LED-H4-H4-3-HB2-9003-30W-3000LM/32219472835.html

That looks interesting

Will they fit?

Will they work?

Opinions?

Thanks

Alex

1958 TR3 TS33884LO
1968 GT6 KC10303

** [email-masked] **

Archive: http://www.team.net/archive

---

From: "Randall" <[email-masked]>
Date: Fri, 17 Apr 2015 20:55:11 -0700

> It is my recollection that it uses H4 bulbs

Make sure they actually take H4 bulbs.  ISTR the original PL700s took a different bulb (although some repros do use H4).

-- Randall