Subject: [TR] TR3A Rear Shock Links

From: [email-masked]
Date: Mon, 23 Mar 2015 22:44:09 +0000 (UTC)

Car is a 1959 TR3a that was not "restored" until I took it on in 2004.  ISTR that I re-used the original shock links.  While I have the car on blocks, I'm considering replacing.  

1.  How do you know if they're bad? 

2.  Can I just remove and replace with the lever shocks still in place?

Checked archives and can't find a definitive answer.

Thank you, everyone!

Terry Smith, '59 TR3A
New Hampshire, where winter is hanging on like a starved dung beetle.

** [email-masked] **

Archive: http://www.team.net/archive

---

From: "Randall" <[email-masked]>
Date: Mon, 23 Mar 2015 17:05:37 -0700

> Car is a 1959 TR3a that was not "restored" until I took it on 
> in 2004.  ISTR that I re-used the original shock links.  
> While I have the car on blocks, I'm considering replacing.  
> 

In my case, it's always been easy.  The rubber in the joint at the shock "goes away" until you can move the shock arm up and down
with the link attached.  I'm actually trying replacing the rubber with Delrin, which seems to be working OK so far.

> 2.  Can I just remove and replace with the lever shocks still 

Might be possible, but I found it a lot easier to take the shock loose.  The link hits the frame before the pin comes out of the
shock lever.

-- Randall