Subject: Re: [TR] TR4 Chassis Issues

From: Hoyt Duff <[email-masked]>
Date: Wed, 18 Feb 2015 17:01:51 -0500

RATCO manufactures frames for TR2 thru TR6.
https://www.sites.google.com/site/tonyratco/frames
A local Triumph club member purchased one and was very happy with it.

If it were my TR with that kind of frame problem, I would bite the
bullet and go with the RATCO frame.

-- 
Hoyt

** [email-masked] **

Archive: http://www.team.net/archive

---

From: Jeffrey Gayton <[email-masked]>
Date: Thu, 19 Feb 2015 14:04:54 -0800

Thanks, as always, to everyone who replied. I’m relieved to hear that finding a good Triumph frame might not be as difficult as I’d been lead to believe. I’m in Southern Oregon (making Kentucky a bit of a trek, Brad!). What’s the price range on decent frames?

I *think* I’d enjoy the frame swap work. It’s well beyond anything I’ve undertaken, but I really enjoy learning on the job. As for cost, I’m still cautiously optimistic that the frame is the only major issue. Frankly, given the photos I have of the PO’s restoration and the binder full or receipts, I’m surprised the frame was mishandled so badly. The engine runs quite well and the only other issues my local shop found were related to the rear: No more adjustment available in the rear brakes, tired lever arms, etc. 

As for cost, everything is relative. I do know that unless I find something else seriously wrong with the car, I want to keep it. I still can’t believe my wife signed off on the purchase in the first place, and I’m not sure she’d be willing to sign off again!

> On Feb 18, 2015, at 1:42 PM, Jeffrey Gayton <[email-masked]> wrote:
> 
> Greetings. So after some trouble with the tow company, I did manage to get my ball-dis-jointed TR4 to a good local shop. Sadly, they found significant problems with the frame: Poor welding and alignment of the front suspension supports leading to front wheels with positive and negative camber (the tops of both wheels lean in the same direction – the top part of both front wheels lean toward the passenger side).
> 
> On a lift, when pointed out by a pro, the problems are obvious. From one side to the other, things are just not aligned the same way. One looks pretty good and the other looks bodged, with what was colorfully described as “bird shit” welding in some areas. On the ground, the problems are less obvious, but still visible. The shop thinks the camber issue must have been present before my ball-joint failure. I feel I’d have noticed the significant positive camber on the front passenger side, but hindsight is 20-20, so who knows? 
> 
> Anyway, the shop recommends replacing the frame because of the difficulty finding a place that has the knowledge needed to straighten everything out. I do have a full-size frame diagram from the previous owner, but have no idea how accurate it is. The shop is looking for a new frame, but they’ve not had much luck so far.
> 
> I’m curious to know the list’s collective thinking about what I should do: Repair the frame, replace with an old frame, or replace with a Ratco frame. Given my penchant for (in-period) originality, I’m surprised to find myself considering the latter, but I’m still relatively young and would like to keep and drive the car for many years. A new Ratco frame would give me peace of mind for a long time, and has the additional advantage of not needing any work. Presumably, a Triumph replacement frame would.
> 
> By the way, a shout-out to Hagerty Insurance for eventually making good with the towing issues. The truck and driver that turned up at my house on the day told me that they were not informed that a wheel was partially off when they accepted the job. I ended up having to pay out of pocket for another truck to come out and tow the car to the shop. Hagerty was not helpful on the phone, but when I emailed them a copy of the receipt and an account of what happened, I received a check covering the full cost in a couple of weeks.
> 
> Thanks.
> 
> Jeff Gayton
> 
> 1962 Triumph TR4
> 

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/archive
Forums: http://www.team.net/forums
Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]