Subject: Re: [TR] TR3 rear spring specification

From: "dave n" <[email-masked]>
Date: Sun, 22 Feb 2015 13:23:50 -0600

in case anyone is interested, I have a pair of TR3 (not TR3a) springs with 
the spacers that came off a 57.  make me an offer.  they are in good shape, 
not rusted.

** [email-masked] **

Archive: http://www.team.net/archive

---

From: Hoyt Duff <[email-masked]>
Date: Sun, 22 Feb 2015 14:59:53 -0500

Has anyone ever checked with Eaton Detroit Springs to see if they
could repair or manufacture TR3 springs? I've been to their plant
where they make leaf springs.
http://www.eatondetroitspring.com/

On 2/22/15, dave n <[email-masked]> wrote:
> Donate: http://www.team.net/donate.html
> Forums: http://www.team.net/forums
> Unsubscribe/Manage:
> http://autox.team.net/mailman/options/triumphs/[email-masked]
>

-- 
Hoyt