Subject: [TR] Time for the pros.

From: Jeffrey Gayton <[email-masked]>
Date: Mon, 12 Jan 2015 09:39:48 -0800

Greetings, again. Thanks to Randall and Dave for taking the time to write. Randall's detailed explanation of what to do makes me nervous and I think Dave is right that this work is beyond me. It's one thing for me to learn the ropes in terms of maintenance, but this is major repair work and a safety issue. I'll contact my insurance company about getting the car out of my garage. Hopefully, they'll cover it.

Thanks again. You folks are an amazing resource.

Take care.

-- Jeff

** [email-masked] **

Archive: http://www.team.net/archive

---

From: "Randall" <[email-masked]>
Date: Mon, 12 Jan 2015 11:29:02 -0800

> I'll contact my insurance company about getting the 
> car out of my garage. Hopefully, they'll cover it.

I can't imagine that they wouldn't.  But if not, you might consider joining AAA.  Although their base plan has limited distance
towing to your choice of destination, they do guarantee towing to a shop of their choosing.  And the AAA Plus plan covers towing to
100 miles to your choice of destination.  You may have to wait a few days to get on AAA Plus, but IMO it's worthwhile having it.

-- Randall