Subject: Re: [TR] Bullet Connectors

From: Chad <[email-masked]>
Date: Tue, 9 Dec 2014 06:56:15 -0800

I've been satisfied with the ones from British Wiring.

Chad in Tulsa

------------------------------
On Tue, Dec 9, 2014 7:29 AM CST Greg Lemon wrote:

>I have more than a couple bullet connectors on the old TR250 that are marginal, I am talking about the external piece that the wires plug into in Lucas harnesses to make connections for Triumphs (and MGs, and Austin Healeys, etc.).  I have never purchased one to my knowledge because I always have old spares lying around, but I have a few I would like to replace that just don't seem to grip the wire ends reliably.  I have tried crimping them down, but the internal metal seems as prone to breaking as it is to bending.
>
>So anyway, this is my long winded way of asking, are the current items sold as new decent and are they all created equal?  if not who makes, and more importantly sells, the good ones?
>
>Thanks, Greg Lemon
>TR250
>
>** [email-masked] **
>
>Donate: http://www.team.net/donate.html
>Archive: http://www.team.net/archive
>Forums: http://www.team.net/forums
>Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]

** [email-masked] **

Archive: http://www.team.net/archive

---

From: Chris Kantarjiev <[email-masked]>
Date: Tue, 09 Dec 2014 11:37:45 -0800

I get them from British Wiring. The ones I bought from TRF many years 
ago were good, too.

And spend the money for the crimping tool, it *really* makes the job 
easier and your connections will last another 35 years.

---

From: Randall <[email-masked]>
Date: Wed, 10 Dec 2014 1:34:58 +0000

> So anyway, this is my long winded way of asking, are the current items sold 
> as new decent and are they all created equal?  if not who makes, and more 
> importantly sells, the good ones?

I got mine from TRF.  They seem well made and work OK, but don't look quite the same as the almost 60 year old originals.  I believe that is because the vinyl outer sleeve on the originals has shrunk over the years.  

Likely the new ones will eventually shrink as well, but for now the outer insulating sleeve slides fairly easily on the inner metal connector.  So in most cases I have to re-center the outer sleeve after installing the wires.

Replacing them is a good idea though.  I've had several tough-to-find problems that turned out to be bullet sleeves that were broken internally.  With the shrunken vinyl, it's hard to tell if the bullet is being gripped by the metal connector or just the vinyl.

Randall