Subject: [TR] grommet woes

From: Bob Peglow <[email-masked]>
Date: Sat, 01 Nov 2014 17:01:15 -0400 (EDT)

B 
> To: Andrew Uprichard ,

Harbor Freight Part # 67582 180 piece grommet set.

Regards,
Bob
B B 
B 

** [email-masked] **

Archive: http://www.team.net/archive

---

From: "Randall" <[email-masked]>
Date: Sat, 1 Nov 2014 14:14:54 -0700

> Harbor Freight Part # 67582 180 piece grommet set.

Only problem; most of the original grommets on a TR3 were "webbed", meaning there is a flexible filler panel in the middle of the
grommet.  This helps seal against air and water.  Moss, TRF et al offer reproductions of those original grommets, but most other
sources (including HF) do not.

Randall