Subject: [TR] tr-3 diff. oil seal or speedi sleeve or both?

From: Gary Nafziger <[email-masked]>
Date: Sat, 22 Nov 2014 19:41:20 +0000 (UTC)

I continually get diff leaks (newly restored tr-3)B  always dripping from the
bottom of cover, however I've taken the cover off, cleaned up the mating
service to fit nicely against the diff and also put on a thicker gasket.B 
Made sure the overflow tube is open.B  Still leaking.B  Next step is pinion
area.B  I'm thinking it's leaking there and blowing back to bottom of diff
then dripping off.B  Make sense?B  Any other opinions?
Winter project will be dropping drive shaft at diff, removing oil seal and
installing oil seal and possibley speedi sleeve.B  What recommended?B  Only
speedi seal?B  only oil seal?B  or both?B 

Also I have a hell of a time finding TRF parts through the "search" click.B 
put in pinion, diff, speedi seal whatever.......usually hopeless.B  Moss is so
much easierB  but I love TRF and they're seemingly "homier" atmosphere.gary
n.

** [email-masked] **

Archive: http://www.team.net/archive

---

From: "Randall" <[email-masked]>
Date: Sat, 22 Nov 2014 15:22:35 -0800

> I'm thinking it's leaking there and blowing back to 
> bottom of diff
> then dripping off.B  Make sense?

Yup, that's what mine was doing.

> What recommended?B  Only

If you open it up, I would definitely replace the seal.  If you can polish away the mark left by the seal on the surface of the
flange, then you probably don't need a Speedi-sleeve.

> put in pinion, diff, speedi seal whatever.......usually 
> hopeless.B 

It works much better to first look up what you need in the factory 'Spare Parts Catalogue' and then use the TRF database search
function on that number.  I actually keep an icon on my toolbar that opens the PDF version of the SPC; which you can download from
http://tinyurl.com/q5lx2gw

As far as I know, Moss & TRF don't offer a Speedi-sleeve to fit.  You'll need to pick that up at your local NAPA or perhaps RockAuto
has them listed.  One of my local NAPA stores doesn't even carry the Speedi-sleeve brand any more, but the other store could order
it for me.

Randall