Subject: [TR] TR6 Seat Tilt Lever, I'll try again. It is plain text.

From: Joe DeMuth <[email-masked]>
Date: Mon, 10 Nov 2014 14:19:45 -0600

Does anybody have an extra TR6 seat tilt lever?
I need one for the driver side seat, although I doubt the levers are
bhanded.b

** [email-masked] **

Archive: http://www.team.net/archive

---

From: [email-masked]
Date: Tue, 11 Nov 2014 21:45:05 -0500

> Donate: http://www.team.net/donate.html
> Forums: http://www.team.net/forums
> Unsubscribe/Manage:
> http://autox.team.net/mailman/options/triumphs/[email-masked]
>
Here is a used one on EBAY.
http://www.ebay.com/itm/TRIUMPH-TR6-SEAT-HANDLE-/111360716248?hash=item19ed9dadd8&vxp=mtr

New from Moss is a little more $.

Greg G.