Subject: Re: [TR] Non-Triumph question about Lotus Europa

From: Mark J Bradakis <[email-masked]>
Date: Sat, 18 Oct 2014 15:42:51 -0600

Try www.davebean.com

mjb.

** [email-masked] **

Archive: http://www.team.net/archive

---

From: "Greg Lemon" <[email-masked]>
Date: Sat, 18 Oct 2014 17:08:15 -0500

You might try going down a different road, what kind of carbs does if have, 
I am going to assume Strombergs or Webers, both should have a low pressure 
pump, if you go here there is a listing of several aftermarket pumps 
suitable for SU, Weber, or Stromberg carbs.

Look here for some likely 
options--http://www.healey6.com/replacement_parts.htm  scroll down.

Greg

--------------------------------------------------
From: "Alexander Delis" <[email-masked]>
Sent: Saturday, October 18, 2014 4:15 PM
To: "Triumph List" <[email-masked]>
Subject: [TR] Non-Triumph question about Lotus Europa

> List
>
> I am getting a 1973 Lotus Europa twin cam ready to sell for the widow of 
> an
> old friend of mine
>
> It has been sitting for a few years, but all it seems to need is a fuel 
> pump.
>
> I am not connected with the Lotus community as I am with the Triumph 
> community
> and have no idea where to source a pump for it
>
> My google-fu is failing me! I have found a few sources in the UK, but the 
> only
> places I have found selling Lotus parts in the US are selling Elise and 
> Exige
> parts
>
> Any ideas?
>
> I would not be surprised if it was the same one in a TR3- it certainly 
> looks
> similar!
>
> Thanks
>
> Alex
>
> 1958 TR3 TS33884LO
> 1968 GT6 KC10303
>
> Donate: http://www.team.net/donate.html
> Forums: http://www.team.net/forums
> Unsubscribe/Manage: 
> http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: "Dixie4" <[email-masked]>
Date: Sat, 18 Oct 2014 23:33:49 +0100

There were two engines fitted to The Lotus Europa .
The single cam was a Renault 16 engine.
The twin cam being Ford based.
Therefore the mechanical fuel pump is a universal British Ford fitment made 
in the millions.
It was fitted to all OHV Pre crosflow and cross flow engines 1100, 1200, 
1300,1600cc from the late 50's until early 80's.
The cars it was fitted to are Anglia, Cortina Mk 1, 2, 3, 4, 5, Capri Mk 1, 
2, 3, Escort Mk1, 2, Fiesta  and Mk3 Escort (ohv only),
Plenty of models to choose from, many exported to US sometimes under 
different model names.
Early ones had a glass fuel chamber, later ones tin. Some with push 
connections some screw type. If you have trouble locating one I could source 
one here in UK. Although I do not think you will have much trouble locating 
one in the US if you know what you are looking for.
The Triumph pump will not fit.

Adrian
Wales, UK
TR and Lotus Owner

----- Original Message ----- 
From: "Alexander Delis" <[email-masked]>
To: "Triumph List" <[email-masked]>
Sent: Saturday, October 18, 2014 10:15 PM
Subject: [TR] Non-Triumph question about Lotus Europa

> http://autox.team.net/mailman/options/triumphs/[email-masked]
>
>
> -----
> No virus found in this message.
> Checked by AVG - www.avg.com
> Version: 2014.0.4765 / Virus Database: 4040/8410 - Release Date: 10/18/14

---

From: "Dixie4" <[email-masked]>
Date: Sat, 18 Oct 2014 23:48:56 +0100

This is the pump you need.