Subject: [TR] Aluminum radiator

From: "Andrew Uprichard" <[email-masked]>
Date: Tue, 14 Oct 2014 17:18:22 -0400

Thinking about an aluminum radiator for a TR3 project and see several from
China on eBay.  Questions - does anyone out there have experience with any
of these? And for a standard engine is there any advantage of the three-row
radiators versus two-row?

Andrew Uprichard

Nothing but  TR3s right now.

** [email-masked] **

Archive: http://www.team.net/archive

---

From: "Jonas Payne" <[email-masked]>
Date: Tue, 14 Oct 2014 15:16:58 -0700

A guy in our club is using one from one of the ebay vendors  to great effect
in his AH sprite - very inexpensive and the quality looked pretty good.

Jonas Payne
PBR Consulting Services, LLC
702.882.6711

-----Original Message-----
From: Triumphs [mailto:[email-masked]] On Behalf Of Andrew
Uprichard
Sent: Tuesday, October 14, 2014 2:18 PM
To: [email-masked]
Subject: [TR] Aluminum radiator

Andrew Uprichard

Archive: http://www.team.net/archive
http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: "Dixie4" <[email-masked]>
Date: Wed, 15 Oct 2014 05:32:42 +0100

Hi Andrew,

Extra cooling is an advantage. Three row will have extra capacity in reserve 
if and when needed.
Under normal use you will never know the difference as the thermostat 
controls the running temperature.
Aluminium/Aluminum radiators are more efficient and durable.

Go for it, three row that is, not forgetting a higher mix of 
antifreeze/anticorrosion additive. Possibly 50/50.
Aluminium/Aluminum does not like plain water although radiators are of an 
alloy so do not suffer from this problem as much as alloy engines. Belts and 
braces spring to mind.

Adrian,
1966 TR4A CT64306 O
Wales, UK
----- Original Message ----- 
From: "Andrew Uprichard" <[email-masked]>
To: <[email-masked]>
Sent: Tuesday, October 14, 2014 10:18 PM
Subject: [TR] Aluminum radiator

> Donate: http://www.team.net/donate.html
> Forums: http://www.team.net/forums
> Unsubscribe/Manage: 
> http://autox.team.net/mailman/options/triumphs/[email-masked]
>
>
> -----
> No virus found in this message.
> Checked by AVG - www.avg.com
> Version: 2014.0.4765 / Virus Database: 4040/8388 - Release Date: 10/14/14