Subject: Re: [TR] grommet woes

From: "Jonas Payne" <[email-masked]>
Date: Thu, 30 Oct 2014 14:33:17 -0700

Try British Wiring at www.britishwiring.com

Jonas Payne
PBR Consulting Services, LLC
702.882.6711

-----Original Message-----
From: Triumphs [mailto:[email-masked]] On Behalf Of Andrew
Uprichard
Sent: Thursday, October 30, 2014 2:19 PM
To: [email-masked]
Subject: [TR] grommet woes

These TR3s have grommets everywhere:  in the frame, under the gas tank, in
the firewall, for the wiring harness.  I find I am always looking for one or
another.  I know Moss sells individual ones, but is anyone aware of a source
where I could get "a bunch" ?

Andrew Uprichard

** [email-masked] **

Archive: http://www.team.net/archive
http://autox.team.net/mailman/options/triumphs/[email-masked]

** [email-masked] **

Archive: http://www.team.net/archive

---

From: "dave n" <[email-masked]>
Date: Thu, 30 Oct 2014 17:09:11 -0500

+1

-----Original Message----- 
From: Jonas Payne 
Sent: Thursday, October 30, 2014 4:33 PM 
To: 'Andrew Uprichard' ; [email-masked] 
Subject: Re: [TR] grommet woes 

Jonas Payne