Subject: Re: [TR] Any recommendations on where to get LED brake and tail lights?

From: Thomas Boggiano <[email-masked]>
Date: Thu, 04 Sep 2014 20:46:36 -0400

I used http://www.classicautoleds.com/
When I changed mine over

Tom

On 9/4/14, 8:30 PM, "Sujit Roy" <[email-masked]> wrote:

>for LBCs?
>Regards, Sujit
>
>** [email-masked] **
>
>Donate: http://www.team.net/donate.html
>Archive: http://www.team.net/archive
>Forums: http://www.team.net/forums
>Unsubscribe/Manage:
>http://autox.team.net/mailman/options/triumphs/[email-masked]

** [email-masked] **

Archive: http://www.team.net/archive

---

From: "Alex&Janet Thomson" <[email-masked]>
Date: Thu, 4 Sep 2014 21:05:16 -0400

Try http://www.litezupp.com/  Simply purchasing bubble packed items at a
chain auto parts store doesn't always work that well.

Alex Thomson

-----Original Message-----
From: Triumphs [mailto:[email-masked]] On Behalf Of Sujit
Roy
Sent: Thursday, September 04, 2014 8:31 PM
To: Triumphs
Subject: [TR] Any recommendations on where to get LED brake and tail lights?

for LBCs?
Regards, Sujit

Archive: http://www.team.net/archive
http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: "dave n" <[email-masked]>
Date: Thu, 4 Sep 2014 23:09:26 -0500

+1

-----Original Message----- 
From: Alex&Janet Thomson
Sent: Thursday, September 4, 2014 8:05 PM
To: 'Sujit Roy' ; 'Triumphs'
Subject: Re: [TR] Any recommendations on where to get LED brake and tail 
lights?

Alex Thomson

-----Original Message-----

for LBCs?
Regards, Sujit