Subject: [TR] 73 TR6 oil filter

From: Frank Fisher <[email-masked]>
Date: Sun, 17 Aug 2014 13:03:03 -0700

i have buddies 73 TR6 in may garage that im free to play with. looks nice next to the TR3.
seems 1973 was not the year to own. so many differences from 72 and 74.
so 2 problems.

bought a modern oil filter kit from moss. the existing canister has a hydraulic line that comes out of the canister and goes into the block just below the oil pressure gage sender. of course the moss unit is not set up for this. what is that hydraulic line doing? are all the TR6 like that?

water pump. not available for 1973! may be able to use a later model. anyone tried?

thanks
Frank

** [email-masked] **

Archive: http://www.team.net/archive

---

From: Greg Gelhar <[email-masked]>
Date: Sun, 17 Aug 2014 20:00:24 -0500

That is not what my 73 TR6 filter looks like. And yes, only the later water pump with the dual groove pulley is available. It functions just fine.

T-Mobile. Americabs First Nationwide 4G Network

Frank Fisher <[email-masked]> wrote:

>Donate: http://www.team.net/donate.html
>Forums: http://www.team.net/forums
>Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]