Subject: Re: [TR] Newbie oil filter question

From: "dave n" <[email-masked]>
Date: Tue, 12 Aug 2014 15:45:26 -0500

http://www.ranteer.com/davescars/tr6/filters/

I believe that all the spin on adapters are the same.  please correct me if 
I am wrong

btw my preference is wix; wix also makes the filters for napa; drop the 
first digit from the wix number and you'll have the napa number

-----Original Message----- 
From: Jeffrey Gayton
Sent: Tuesday, August 12, 2014 11:42 AM
To: [email-masked]
Subject: [TR] Newbie oil filter question

Greetings. I just checked the oil on my new-to-me 1962 TR4 and need to 
replace
it. The car has a Mann W719/14 filter on a Purolator filter adapter. What
model K&N filter should I buy?

Thanks for putting up with such a noob question! 

** [email-masked] **

Archive: http://www.team.net/archive

---

From: [email-masked]
Date: Tue, 12 Aug 2014 21:48:41 +0000 (UTC)

>first digit from the wix number and you'll have the napa number

Ditto on WIX and NAPA.  Quality filters.  

Terry Smith, '59 TR3A  TS 58667
New Hampshire