Subject: [TR] Downloadable, printable fastener reference info

From: Don Hiscock <[email-masked]>
Date: Fri, 8 Aug 2014 09:45:20 -0500

This might be useful to a number of us:
http://www.boltdepot.com/fastener-information/Printable-Tools/Default.aspx

Don
1962 TR3B TSF202L

** [email-masked] **

Archive: http://www.team.net/archive

---

From: "dave n" <[email-masked]>
Date: Fri, 8 Aug 2014 11:31:30 -0500

thank you!  this is great!!!