Subject: Re: [TR] Not TR - MGB

From: "Jonas Payne" <[email-masked]>
Date: Fri, 15 Aug 2014 17:47:30 -0700

Don,

Good point, but the fact that it cuts out instantly and the fact that if it's
jacked up at the front, the fuel pump is still pumping just fine.

Loose wires are "plumb bobs" they very much care about inclination if they are
shorting against something.  I have no idea what is happening inside the black
boxes - are they sensitive to gravity when they are failing?

Fuel starvation is generally accompanied by some sort of coughing or
sputtering or lack of power, not instantaneous death.

Jonas Payne
PBR Consulting Services, LLC
702.882.6711

-----Original Message-----
From: Don Hiscock [mailto:[email-masked]]
Sent: Friday, August 15, 2014 5:39 PM
To: Jonas Payne
Subject: Re: [TR] Not TR - MGB

Boy, gravity normally points to fuel flow -- electrons don't care about up and
down that much.

What makes you sure it's ignition?  I'd have guessed fuel delivery.

Rgds,

Don

On 8/15/14, Jonas Payne <[email-masked]> wrote:
> I have a 1980 MGB in the shop with the original OPUS electronic ignition.
>
> When the car is warm and it gets on an incline, it suddenly quits - no
> coughing, sputtering, anything.  It then fires up after a couple
> minutes and goes along fine.
>
> I'm convinced it is an ignition problem, but clearly not the coil,
> wires or plugs.
>
> Car is in very good shape with no obvious loose wires, grounds, etc.
>
> The dist. is effectively 2 black boxes, so I'm at a loss as to how to
> diagnose it.
>
> I can put in a 45D dist, new points, condenser and coil for less than
> $150, and put it back to 1972 spec, which is probably less than the
> time it will take to try and diagnose the other unit and at least at
> that point, I have a system that somebody of reasonable intelligence
> can sort out.
>
> If anybody has any experience with these things, your comments would
> be greatly appreciated.
>
>
>
>
>
> Jonas Payne
> PBR Consulting Services, LLC
> 702.882.6711
>
> ** [email-masked] **
>
> Donate: http://www.team.net/donate.html
> Archive: http://www.team.net/archive
> Forums: http://www.team.net/forums
> Unsubscribe/Manage:
> http://autox.team.net/mailman/options/triumphs/[email-masked]

** [email-masked] **

Archive: http://www.team.net/archive

---

From: "Greg Lemon" <[email-masked]>
Date: Fri, 15 Aug 2014 20:19:27 -0500

I can't think of the name, but the late cars have an "impact switch" that 
shuts the car off if it gets too big a jolt, I think it is supposed to stop 
the fuel pump in case of an accident, now I remember, inertia switch, if 
that was overly sensitive could cause similar symptoms, I believe it is on 
the left side driver's footwell, when I had an 80 MGB it slipped off the 
floor jack once and I thought I had killed it until I found the switch.

Greg Lemon

---

From: "dave n" <[email-masked]>
Date: Fri, 15 Aug 2014 21:29:42 -0500

there is also an mg list; you might try there

---

From: Jeff Scarbrough <[email-masked]>
Date: Sat, 16 Aug 2014 07:22:59 -0400

My only experience is with Spitfires, but it's my understanding that
the late OPUS ignition with the remote control box is nothing but  GM
ignition module in a black box with Lucas written on it.  I think it's
pretty simple to open the box and replace the module for about $40.

Still, depending on the condition of the distributor (wobble, etc.),
it might be best to replace it.  You can then put in electronic
ignition if desired.  One thing to consider is the issue of vacuum
advance/retard in your current vs. replacement distributor.

Jeff Scarbrough
Corrosion Acres, Ga.

On Fri, Aug 15, 2014 at 8:32 PM, Jonas Payne <[email-masked]> wrote:
> coughing, sputtering, anything.  It then fires up after a couple minutes and
> goes along fine.
>
> I'm convinced it is an ignition problem, but clearly not the coil, wires or
> plugs.
>
> I can put in a 45D dist, new points, condenser and coil for less than $150,
> and put it back to 1972 spec, which is probably less than the time it will
> take to try and diagnose the other unit and at least at that point, I have a
> system that somebody of reasonable intelligence can sort out.
>
> If anybody has any experience with these things, your comments would be
> greatly appreciated.
>
>
>
>
>
> Jonas Payne
> Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: Dave <[email-masked]>
Date: Sat, 16 Aug 2014 09:08:03 -0400 (EDT)

It might be something as simple as the ignition switch.  What does the 
tach
do at this time?  (The MGB has an electronic tach and if the 
switch is
cutting out it should drop to zero immediately even if the 
engine is still
winding down.)  Also, does the heater fan and/or wipers 
cut out at the same
time?

I had a dodgy switch on my MGB (back in the day) and on my TR6.  And
I 
hear GM has had some issues as well.

Dave

-----Original
Message-----
From: Jonas Payne <[email-masked]>
To: triumphs
<[email-masked]>
Sent: Fri, Aug 15, 2014 7:32 pm
Subject: [TR] Not
TR - MGB

I have a 1980 MGB in the shop with the original OPUS electronic
ignition.

When the car is warm and it gets on an incline, it suddenly quits
- no
coughing, sputtering, anything.  It then fires up after a couple
minutes and
goes along fine.

I'm convinced it is an ignition problem, but
clearly not the coil, 
wires or
plugs.

Car is in very good shape with no
obvious loose wires, grounds, etc.

The dist. is effectively 2 black boxes,
so I'm at a loss as to how to
diagnose it.

I can put in a 45D dist, new
points, condenser and coil for less than 
$150,
and put it back to 1972
spec, which is probably less than the time it 
will
take to try and diagnose
the other unit and at least at that point, I 
have a
system that somebody of
reasonable intelligence can sort out.

If anybody has any experience with
these things, your comments would be
greatly appreciated.

Jonas
Payne

**
[email-masked] **

Archive: http://www.team.net/archive
http://autox.team.net/mailman/options/triumphs/[email-masked]