Subject: [TR] Not TR - MGB

From: "Jonas Payne" <[email-masked]>
Date: Fri, 15 Aug 2014 17:32:15 -0700

I have a 1980 MGB in the shop with the original OPUS electronic ignition.  

When the car is warm and it gets on an incline, it suddenly quits - no
coughing, sputtering, anything.  It then fires up after a couple minutes and
goes along fine.

I'm convinced it is an ignition problem, but clearly not the coil, wires or
plugs.

Car is in very good shape with no obvious loose wires, grounds, etc.

The dist. is effectively 2 black boxes, so I'm at a loss as to how to
diagnose it.

I can put in a 45D dist, new points, condenser and coil for less than $150,
and put it back to 1972 spec, which is probably less than the time it will
take to try and diagnose the other unit and at least at that point, I have a
system that somebody of reasonable intelligence can sort out.

If anybody has any experience with these things, your comments would be
greatly appreciated.

Jonas Payne
PBR Consulting Services, LLC
702.882.6711

** [email-masked] **

Archive: http://www.team.net/archive

---

From: "Randall" <[email-masked]>
Date: Sat, 16 Aug 2014 06:57:27 -0700

> I had a dodgy switch on my MGB (back in the day) and on my TR6.  And
> I 
> hear GM has had some issues as well.

I find it amusing that the GM problem was actually a deliberate design change, to make the switch easier to turn.  Marketing felt
that the old switch was too "notchy" and felt cheap.  The "issue" is that the weight of big wads of keys can actually turn the
modified switch.  So it was the marketing requirement that was defective, not the switch.

But engineering will still get blamed, as usual.

Randall

---

From: Dave <[email-masked]>
Date: Sat, 16 Aug 2014 12:16:01 -0400 (EDT)

In my case (MGB) it was a burnt contact and a slight wiggle of the keys
would move the contacts slightly enough move the contacts from a good 
place
to a not so good place.  When switches get old stuff happens.

A better
switch would help but Purchasing makes too many decisions.

Dave
-----Original Message-----
From: Randall <[email-masked]>
To: triumphs
<[email-masked]>
Sent: Sat, Aug 16, 2014 8:57 am
Subject: Re: [TR]
Not TR - MGB

> hear GM has had some issues as well.

I find it amusing
that the GM problem was actually a deliberate design 
change,
to make the
switch easier to turn.  Marketing felt
that the old switch was too "notchy"
and felt cheap.  The "issue" is 
that the
weight of big wads of keys can
actually turn the
modified switch.  So it was the marketing requirement that
was 
defective, not
the switch.

But engineering will still get blamed, as
usual.

Randall

Donate:
Archive: http://www.team.net/archive
Forums:
http://www.team.net/forums
http://autox.team.net/mailman/options/triumphs/[email-masked]