Subject: [TR] Speedi-Sleeve for TR3

From: William Brewer <[email-masked]>
Date: Fri, 15 Aug 2014 12:22:51 -0700

I rebuilt my TR3 engine with a new used crank. I polished up the area of
the crank where the front seal goes using a very fine sandpaper and
wet-sanding it with oil lubricant. Probably a mistake because 1000 miles later
it is puking oil out the front seal. I am thinking about trying a
Speedi-Sleeve as sold by Moss and TRF. 
     I also installed a crankcase
evacuation system. I got the idea from Kas Kastner's book. I have only driven
it once since installing the system. It appears to be working, just not at the
front seal...
     I have a few questions:

1. Can it be installed with the
crank still in the engine but the timing cover off? Or do you have to pull the
crank?

2. Would it be possible to install without pulling the bumpers, grill,
front panel, radiator, cross member and everything else that we have to do to
get at the front of the engine? Probably just a pipedream, but one never
knows. Maybe it is possible.

3. Do they work well and are they worth the
trouble?

4. Has anyone else used one of these recently?

     TIA,

     Bill
Brewer
     Tehachapi, CA

** [email-masked] **

Archive: http://www.team.net/archive

---

From: Randall <[email-masked]>
Date: Fri, 15 Aug 2014 21:55:20 +0000

---- William Brewer <[email-masked]> wrote: 
> the crank where the front seal goes 

I'm confused, Bill.  The front seal doesn't ride on the crank at all; instead it rides on the hub for the pulley.

I've put a Speedi-sleeve on the hub, no problem.  First one I picked out of the catalog by size; but later I noticed that they actually have the TR3 (or maybe it was TR4, same part) listed by application.  The application listing was for a shorter sleeve, but the longer one worked fine for me.  All done with the crank still in the engine and engine still in the car. 

It shouldn't be possible to leak oil through the center of the hub, since the whole stack of extension, hub, gear and shims should be clamped firmly against the cheek of the front crank throw by the dog bolt.  But it wouldn't hurt to put a thin smear of Hylomar on the back surface of the hub when you install it.  I wouldn't use RTV though, as it will get squeezed out of the joint and I don't like strings of RTV running around loose inside the engine.  Hylomar will stay put.

Randall

---

From: "Randall" <[email-masked]>
Date: Sat, 16 Aug 2014 06:32:49 -0700

>      You know, my life is kind of a blur right now and I 
> might not be thinking
> straight. I put in a harmonic balancer when I rebuilt the 
> engine. 

Could this be the kit that uses an MGB dampener?  If so, there is a sleeve required for the seal to ride on.  Perhaps the sleeve got
left out?

P/N TT11322 here
http://www.mossmotors.com/graphics/products/PDF/837-508.pdf

Randall