Subject: Re: [TR] LED Taillights

From: Irv Korey <[email-masked]>
Date: Wed, 16 Jul 2014 11:28:21 -0500

http://www.litezupp.com/

Irv Korey
74 TR6 CF22767U
Highland Park, IL

** [email-masked] **

Archive: http://www.team.net/archive

---

From: "dave n" <[email-masked]>
Date: Wed, 16 Jul 2014 12:10:01 -0500

LitesZupp

http://www.litezupp.com/

they are here in the dallas/fort worth area

jim thompson   [email-masked]

I have their lights on several cars.  really makes a difference; well worth 
it

-----Original Message----- 
From: marty
Sent: Wednesday, July 16, 2014 11:03 AM
To: Triumph List
Subject: [TR] LED Taillights

There was a company peddling LED taillight bulbs at the VTR convention at
Jekyll Island some years ago.  Anybody remember their name?  They still in
business?

Thanks,