Subject: [TR] TR4 Oil Pump Priming

From: "James Henningsen" <[email-masked]>
Date: Thu, 24 Jul 2014 18:40:15 -0400

I read that you are supposed to prime a new oil pump with Vaseline or other
substance.  I didn't prime the new pump and it is installed with oil pan
buttoned up.  It is an uprated pump by Steve Yott.  Do I need to pull the
pan and prime this thing??

Thanks in advance,

Jim Henningsen

Ocala FL

62 TR4 x2

75 TR6

69 Land Rover Series IIa

** [email-masked] **

Archive: http://www.team.net/archive

---

From: "Randall" <[email-masked]>
Date: Thu, 24 Jul 2014 16:35:52 -0700

> pan and prime this thing??

Unlike most other engines, the TR2-4 motor actually submerges the pump in the oil.  Gravity will prime the pump.

It wouldn't hurt to spin the engine a few revolutions with the spark plugs out, to fill the oil galleries & filter as well; but I
certainly would not take it apart to pack the pump.

Besides, having all that Vaseline get pushed into the filter may not be the best thing anyway.

Randall

---

From: [email-masked]
Date: Fri, 25 Jul 2014 21:28:45 +0000 (UTC)

Just curious.  I understand the need for lubrication on a fresh rebuild.  But isn't that the purpose of putting that viscous engine rebuild lube on moving parts during assembly?

Terry Smith, '59 TR3A
New Hampshire