Subject: Re: [TR] The List

From: Mark J Bradakis <[email-masked]>
Date: Wed, 23 Jul 2014 13:42:43 -0600

George Haynes wrote:
> I still miss Scott Fisher and Ray Gibbons.  May he rest in peace.  Thanks,
> Mark!

You are welcome. Scott Fisher is one of my Facebook friends, so I hear from him on a regular basis.

mjb.

** [email-masked] **

Archive: http://www.team.net/archive

---

From: Philip Ethier <[email-masked]>
Date: Wed, 23 Jul 2014 21:01:23 -0500

I see Scott on Flickr.com now and again.  Met him in person in 2009 in
Oregon.