Subject: Re: [TR] TR4A carburetors woes

From: "Jeff" <[email-masked]>
Date: Tue, 29 Jul 2014 15:31:53 -0600

I replaced the Grose float valves with needle valves.  I also put in new
fixed floats.  I used a color tune and set the carbs to the proper mixture
(I think) The Colortune goes yellow at high RPM but is blue at idle.  I
checked the mechanical fuel pump which seams to pump a good flow of gas.  It
ran great and I thought I was done, but after going up a hill for about a
mile it started to stutter.  I noticed if I pull out the choke it runs
better.  Any suggestions?  Could the gas be bad?  It's been in the car for
about 6 months.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Sunday, July 06, 2014 7:51 PM
To: Jeff
Cc: 'Randall'; [email-masked]
Subject: Re: [TR] TR4A carburetors woes

A while back, I rebuilt the fuel pump on my TR6. I got to wondering why
with over a hundred horsepower powering the pump what kept it from
delivering sky high pressures. After I had it apart, I realized the
engine's cam only moves the pumps diaphragm to suck in fuel. It is the
spring on the diaphragm that pushes the fuel to the carbs. So no, I don't
think the pump can overpower the carb's float valves.

Greg G.
Osseo, MN

> Thanks for the input.  I'm ordering the viton tip needle.  My fuel pump is
> the stock mechanical pump.  Can that put out to much pressure?
>
> -----Original Message-----
> From: Randall [mailto:[email-masked]]
> Sent: Saturday, July 05, 2014 6:40 PM
> To: 'Jeff'; [email-masked]
> Subject: RE: [TR] TR4A carburetors woes
>
>
>> When I take it for a spin though I can only get about 2
>> blocks and it starts
>> missing badly.  I get it home and pull the plugs and they are
>> really sooty.
>
> Others will disagree, I'm sure.  But my first step would be to replace the
> Grose Jets with the proper needle valves.  I don't fully
> understand why, but I've fixed several cars with similar symptoms that
> way.
>
> Or if you happen to have an adjustable fuel pressure regulator installed,
> try turning it down a bit.
>
> Randall
>
> ** [email-masked] **
>
> Donate: http://www.team.net/donate.html
> Archive: http://www.team.net/archive
> Forums: http://www.team.net/forums
> Unsubscribe/Manage:
> http://autox.team.net/mailman/options/triumphs/[email-masked]
>

---
This email is free from viruses and malware because avast! Antivirus protection is active.
http://www.avast.com

** [email-masked] **

Archive: http://www.team.net/archive

---

From: "Jeff" <[email-masked]>
Date: Sat, 5 Jul 2014 18:23:03 -0600

I've been trying to get my TR4A on the road before winter sets in again.
I'm having a heck of a time getting my SU HS6 carburetors tuned.  I pulled
the floats and checked the fuel in the chamber.  They have Grose Jets in
them.  Both chambers have fuel about 1/2 way up the bowl.  I've done the
tuning on both carbs to where when you lift the piston the engine RPM seems
to rise and fall.  The engine runs great, I can rev it with no hesitation
and it seems very smooth.  I pulled the plugs and they were normal color.
When I take it for a spin though I can only get about 2 blocks and it starts
missing badly.  I get it home and pull the plugs and they are really sooty.
What am I missing?

---

From: Wbeech <[email-masked]>
Date: Sat, 5 Jul 2014 19:43:58 -0500

Sounds like the choke linkage is not returning all the way.  From under the
hood (bonnet) manually see that the linkage is fully returned to the off
positions, then take a spin.

Sometimes it is some simple.

Bill

Sent from mobile Bill

On Jul 5, 2014, at 7:23 PM, "Jeff" <[email-masked]> wrote:

Archive: http://www.team.net/archive
http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: "TeriAnn J. Wakeman" <[email-masked]>
Date: Sat, 05 Jul 2014 20:53:19 -0700

Grose jets tend to stick.  I had a pair on an MGBGT.  They didn't stay 
there very long.  I suggest going back to stock.

TeriAnn

---

From: Frank Fisher <[email-masked]>
Date: Sun, 6 Jul 2014 11:42:28 -0700

in my case it was a very weak coil
frank 

On Saturday, July 5, 2014 8:53 PM,
TeriAnn J. Wakeman <[email-masked]> wrote:

Grose jets tend to
stick.  I had a pair on an MGBGT.  They didn't stay 
there very long.  I
suggest going back to stock.

TeriAnn

On 7/5/14, 5:23 PM, Jeff wrote:
> I've
been trying to get my TR4A on the road before winter sets in again.
> I'm
having a heck of a time getting my SU HS6 carburetors tuned.  I pulled
> the
floats and checked the fuel in the chamber.  They have Grose Jets in
> them. 
Both chambers have fuel about 1/2 way up the bowl.  I've done the
> tuning on
both carbs to where when you lift the piston the engine RPM seems
> to rise
and fall.  The engine runs great, I can rev it with no hesitation
> and it
seems very smooth.  I pulled the plugs and they were normal color.
> When I
take it for a spin though I can only get about 2 blocks and it starts
What am I missing?

Donate:
Archive: http://www.team.net/archive
Forums:
http://www.team.net/forums
http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: "Jeff" <[email-masked]>
Date: Sun, 6 Jul 2014 17:18:44 -0600

-----Original Message-----
From: Randall [mailto:[email-masked]] 
Sent: Saturday, July 05, 2014 6:40 PM
To: 'Jeff'; [email-masked]
Subject: RE: [TR] TR4A carburetors woes

Others will disagree, I'm sure.  But my first step would be to replace the
Grose Jets with the proper needle valves.  I don't fully
understand why, but I've fixed several cars with similar symptoms that way.

Randall

---

From: Geo Hahn <[email-masked]>
Date: Sun, 6 Jul 2014 17:27:29 -0700

> the stock mechanical pump.  Can that put out to much pressure?

I see no way that could occur.

BTW - I've had Grose jets on the TR3A for 30+ years -- one did stick closed
once after a long sit years ago, otherwise no issues.  I'm not recommending
them, just saying they are not always a problem.

No harm in replacing them, but my guess is that you have an ignition
problem and will still get the miss after the change.

Sometimes ignition components fail completely but I have known some to only
fail once they warmed up (thinking of coil & condenser here).

Geo