Subject: Re: [TR] TR4A carburetors woes

From: "Randall" <[email-masked]>
Date: Sat, 5 Jul 2014 17:39:57 -0700

> When I take it for a spin though I can only get about 2 
> blocks and it starts
> missing badly.  I get it home and pull the plugs and they are 
> really sooty.

Others will disagree, I'm sure.  But my first step would be to replace the Grose Jets with the proper needle valves.  I don't fully
understand why, but I've fixed several cars with similar symptoms that way.

Or if you happen to have an adjustable fuel pressure regulator installed, try turning it down a bit.

Randall

** [email-masked] **

Archive: http://www.team.net/archive

---

From: "Randall" <[email-masked]>
Date: Sun, 6 Jul 2014 18:47:20 -0700

> My fuel pump is
> the stock mechanical pump.  Can that put out to much pressure?

Normally, no.  But I have seen pumps that were assembled wrong (spring out of place) do it.  And some reproductions seem to just
have the wrong spring installed (also causing pressure too high).

Wouldn't hurt to hang a fuel pressure gauge on it (most vacuum test gauges will also read fuel pump pressure); but if the Viton
valves don't help, I'd take Geo's advice and look at ignition next.

Randall