Subject: [TR] Jaeger clock in a TR3

From: <[email-masked]>
Date: Wed, 15 Jan 2014 00:06:13 -0600

I recently took a good look at the clock I removed from the glove box door
and noticed that was made by the Jaeger Watch Co. of W. York.  Were these
ever offered as options on a TR3?  As it was a rather inelegant installation
I just assumed that some DPO had installed it.
 
Of course the real question is, Does it have any value?
 
Bill
 
Bill Beecher
'62 TR3B TCF/2549L " Aunt B" (in rehab)
'68 Land Rover Series IIa 88" "The Beast"

"Keep Calm and Carry On"

** [email-masked] **

Archive: http://www.team.net/archive

---

From: Randall <[email-masked]>
Date: Thu, 16 Jan 2014 0:43:07 +0000

> I have never seen a clock in a TR3, 4, 250, 6 or Spitfire. Maybe a Stag?

Stags did come with clocks, but marked either Kienzle or Smiths I believe.  Never seen one with a Jaeger clock.  And many folks replace them with oil pressure gauges.

Randall