Subject: [TR] Drum Brake Questions

From: William Brewer <[email-masked]>
Date: Wed, 25 Dec 2013 16:52:32 -0800 (PST)

So, I have a 1952 Triumph Renown. 3 times now the 4 drum brakes have all
got hot and seized up while I was driving. It happens at about the 45 minute
mark on an easy drive. I keep adjusting the shoes on the drum thinking that
they are just out of adjustment after so little use for so long. I don't see
any brake fluid leaking from the brake cylinders that would have soaked the
shoes. 
     I am trying to avoid taking on another project. Can this brake
problem be anything other than needing to put in new brake wheel cylinders and
shoes? I keep backing off on the adjusters, but that is not working so far.

   -Bill Brewer

** [email-masked] **

Archive: http://www.team.net/archive

---

From: "Randall" <[email-masked]>
Date: Wed, 25 Dec 2013 17:14:53 -0800

> shoes? I keep backing off on the adjusters, but that is not 

Sure sounds to me like the return valve in the MC is not opening (or possibly the residual pressure valve).  Next time it happens,
try loosening the fitting at the MC and let a few drops of fluid out (onto a rag or something).  If the brakes release, then it's
clearly a MC problem.

Could be as simple as adjusting the pedal linkage or stop; or possibly a binding pedal pivot.

Randall