Subject: Re: [TR] TR4A rear dampers (shock absorbers)

From: "G.D. Huggins" <[email-masked]>
Date: Mon, 30 Dec 2013 17:52:05 -0600

I would expect them to be roughly equal.

You might try draining each, inspecting/cleaning the inside "valve", refilling
and checking again.
If they are still not even, then I suspect one of the "valves" is bad.

Right or wrong, I used Harley Davidson fork oil in mine.

On Dec 30, 2013, at 3:19 PM, [email-masked] wrote:

> Hello List,
>
> Am going through rear suspension components in preparation for reassembly.
> Have Armstrong dampers.  About twice the force is required to move one
damper
> arm vs. the other.  Seems like the resistance of the two dampers should be
> close.  Fluid levels are equal.
>
> So, should the resistance of the dampers be close to the same?  If they
> aren't, is there an easy fix?  BTW, is there an off-the-shelf oil that can
be
> used, or is TR shock absorber fluid required.  Thanks.
>
> John DeLuca
> TR4A in Restoration
>
> ** [email-masked] **
>
> Donate: http://www.team.net/donate.html
> Archive: http://www.team.net/archive
> Forums: http://www.team.net/forums
> Unsubscribe/Manage:
http://autox.team.net/mailman/options/triumphs/[email-masked]

** [email-masked] **

Archive: http://www.team.net/archive

---

From: Geo Hahn <[email-masked]>
Date: Mon, 30 Dec 2013 17:06:39 -0700

I, too, use fork oil from a local motorcycle shop.  It is available is
various weights (10, 20 & others).

Geo

On Mon, Dec 30, 2013 at 2:19 PM, <[email-masked]> wrote:

> http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: "James Henningsen" <[email-masked]>
Date: Mon, 30 Dec 2013 19:18:09 -0500

I noticed that some shops rebuild the dampers for heavy duty.  Is there a
special weight of oil to upgrade the dampers or is there a rebuild and valve
switch out required. I too need to rebuild my dampers and want to upgrade
their performance as I have Moss competition leaf springs and ARE bronze
bushings ready to install. 
Thanks,
Jim Henningsen
62 TR4 x2
75 TR6
Ocala, FL

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of Geo Hahn
Sent: Monday, December 30, 2013 7:07 PM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [TR] TR4A rear dampers (shock absorbers)

Geo

On Mon, Dec 30, 2013 at 2:19 PM, <[email-masked]> wrote:

> damper arm vs. the other.  Seems like the resistance of the two 
> dampers should be close.  Fluid levels are equal.
>
> So, should the resistance of the dampers be close to the same?  If 
> they aren't, is there an easy fix?  BTW, is there an off-the-shelf oil 
> that can be used, or is TR shock absorber fluid required.  Thanks.
>
> John DeLuca
> TR4A in Restoration
>

Archive: http://www.team.net/archive
http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: "Dave" <[email-masked]>
Date: Mon, 30 Dec 2013 19:11:45 -0600

http://www.ranteer.com/davescars/tr6/ShockRec.jpg

I highly recommend these people.  itbs a heavy duty valve according to them. 
I went with the heavy duty as you can see on the receipt.  one of mine was 
leaking, and of course I could tell a significant difference right away.

what I think is funny is that if I had gone with a tube shock conversion, I 
would be extolling its virtues and saying how much better it is.