Subject: [TR] Correct Jets for HS-2 Carbs

From: Berger Bob <[email-masked]>
Date: Tue, 19 Nov 2013 06:29:30 -0600

I took black jets off of my carbs when I disassembled them but the new rebuild
kit came with red jets.  Other than the black jets having longer hoses to the
float bowels they look identical to the red ones.  What carb are the black
jets supposed to go on?

Thanks

Berger Bob
78 Spitfire
St. Louis, MO
NASS #627

** [email-masked] **

Archive: http://www.team.net/archive

---

From: [email-masked]
Date: Tue, 19 Nov 2013 08:05:47 -0600 (CST)