Subject: [TR] looking for part no. 628012 door lock clip

From: Sujit Roy <[email-masked]>
Date: Tue, 1 Oct 2013 13:53:40 -0700

Any know where I can get this part? Usual places show - not available. Any
other make use something similar?

Sujit

** [email-masked] **

Archive: http://www.team.net/archive

---

From: Randall <[email-masked]>
Date: Tue, 1 Oct 2013 22:42:56 +0000

> other make use something similar?

Would one of these work?
http://www.dormanproducts.com/c-277-door-lock-rod-clips.aspx

If all else fails, I think a pair of "push nuts" would probably work; but you might have to add a sleeve between them.
http://www.mcmaster.com/#push-nuts/=or2vx9

Randall