Subject: Re: [TR] looking for part no. 628012 door lock clip

From: [email-masked]
Date: Tue, 1 Oct 2013 17:32:47 -0400

Just looking in other Rimmer catalogs but it looks similar to DZA943 used
on the TR7 TR8.

Greg G.
Osseo, MN

 > Any know where I can get this part? Usual places show - not available. Any
> other make use something similar?
>
> Sujit
>
> ** [email-masked] **
>
> Donate: http://www.team.net/donate.html
> Archive: http://www.team.net/archive
> Forums: http://www.team.net/forums
> Unsubscribe/Manage:
> http://autox.team.net/mailman/options/triumphs/[email-masked]

** [email-masked] **

Archive: http://www.team.net/archive

---

From: "Alex&Janet Thomson" <[email-masked]>
Date: Tue, 1 Oct 2013 18:50:27 -0400

You could try the Au-Ve-Co company (Auto Vehicle Part Co.). They specialize
in automotive fasteners, clips, etc. http://www.auveco.com/ 

Alex Thomson

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of Sujit Roy
Sent: Tuesday, October 01, 2013 4:54 PM
To: Triumphs
Subject: [TR] looking for part no. 628012 door lock clip

Sujit

Archive: http://www.team.net/archive
http://autox.team.net/mailman/options/triumphs/[email-masked]