Subject: Re: [TR] Ever use "ScrewGrab"?

From: Don Hiscock <[email-masked]>
Date: Mon, 2 Sep 2013 16:24:06 +0200

Yup, Randall -- they state it's "not a glue".  I've had pm from others on
the list also mentioning valve lapping compound.  It does seem that that's
a best guess as to the basic composition of the stuff in the ScrewGrab
bottle.

On Mon, Sep 2, 2013 at 4:21 PM, Randall <[email-masked]> wrote:

>
> > Subject: [TR] Ever use "ScrewGrab"?
> >
> > Sounds like a Locktite variant, and although I've never used
> > it -- or even
> > heard of it, to tell the truth -- I know folks who give it a personal
> > recommendation.
>
> I'd never heard of it either; but from a quick Google I don't think it is
> like Loctite.  It's apparently an abrasive grit suspended in a gel,
> intended
> to help a tool bit get a grip on a rounded/damaged fastener.  Kind of like
> Vice Grips in a bottle.
>
> http://www.screwgrab.com/
>
> Slick idea.  But I wonder if valve grinding compound wouldn't work almost
> as
> well.
>
> Randall

** [email-masked] **

Archive: http://www.team.net/archive

---

From: john Mitchell <[email-masked]>
Date: Mon, 02 Sep 2013 10:28:38 -0400

Ive never heard of it, but I'll give it a try.
On 9/2/2013 9:41 AM, Don Hiscock wrote:
> Sounds like a Locktite variant, and although I've never used it -- or even
> Any input from the list?  Couldn't find a mention in the Triumphs or FOT
> list archives.
>
> Donate: http://www.team.net/donate.html
> Forums: http://www.team.net/forums
> Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: Jeff <[email-masked]>
Date: Mon, 02 Sep 2013 10:35:30 -0400

On 9/2/2013 10:21 AM, Randall wrote:
>   Kind of like
> Slick idea.

Isn't it actually just the opposite?