Subject: Re: [TR] TR Grease Cap Removal

From: Bud R <[email-masked]>
Date: Tue, 3 Sep 2013 00:53:25 -0600

A set of needle nose vise grips has never failed to get them off for  
me. Lock em down and a little wiggling and Bob's your uncle.

Bud Rolofson

Extreme Parts Racing (more than just a haircut)
71 Spitfire MK IV Race Car #3
71TR6 CC57365 (Good 6)
93 Minnie Winnie Race Support Vehicle
77 Z-50A Hardly Davidson Honda Mini-Trail Bike (Triumph Pit Bike)

On Sep 2, 2013, at 10:13 PM, William Brewer wrote:

>     I had to remove a grease cap off of the front hub on my TR6. It  
> was
> seriously on there and banged up from whoever last tried to get it  
> off. I
> ended up hitting it with a cold chisel to finally get it off. What a  
> PITA.
>
> Is there a way to set up grease caps so you can get them off easier  
> for next
> time? I was thinking of drilling a hole through the center and mig  
> welding a
> nut on the outside so I could thread a bolt through and push against  
> the stub
> axle to push it off. Likewise, I thought about just putting a little  
> blob of
> weld on the outside of the cap so I could butt up a drift to it to  
> tap it off
> easier.
>     Has anyone got any tricks to getting these grease caps off
> easier?
>     TIA,
>
>     Bill in Tehachapi
>
> ** [email-masked] **
>
> Donate: http://www.team.net/donate.html
> Archive: http://www.team.net/archive
> Forums: http://www.team.net/forums
> Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]

** [email-masked] **

Archive: http://www.team.net/archive

---

From: Geo Hahn <[email-masked]>
Date: Tue, 3 Sep 2013 06:27:49 -0700

On Tue, Sep 3, 2013 at 2:24 AM, Randall <[email-masked]> wrote:

> There should already be a 10-32 hole for that.  But I find that the threads
> are usually not strong enough, so I epoxy a nut inside the cap.
>

I keep a 10/32 eye bolt (about 2" long) in the mini tool kit (Lucas points
tool, SU wrench, etc) which threads in and pushes the cap out w/o any
wrench required.

http://wedo.hillmangroup.com/ImgMedium/320754.jpg

Geo

---

From: Chris Simo <[email-masked]>
Date: Tue, 3 Sep 2013 11:39:35 -0400

Maybe I bought poor caps, but the 10-32 screw route rarely worked for me.

Maybe I whack the cap in place too tightly with my rubber hammer....

Caps are pretty cheap,  I keep two in the spares kitty. I might weld a
small nub on opposing sides next time to aid in removal next time.

---

From: Frank Fisher <[email-masked]>
Date: Tue, 3 Sep 2013 08:40:25 -0700 (PDT)

snap on makes a tool specifically for this task.
I love tools
 
Frank
________________________________
 From: William Brewer <[email-masked]>
To: Triumphs <[email-masked]> 
Sent: Monday, September 2, 2013 9:13
PM
Subject: [TR] TR Grease Cap Removal

     I had to remove a grease cap
off of the front hub on my TR6. It was
seriously on there and banged up from
whoever last tried to get it off. I
ended up hitting it with a cold chisel to
finally get it off. What a PITA.
  
Is there a way to set up grease caps so
you can get them off easier for next
time? I was thinking of drilling a hole
through the center and mig welding a
nut on the outside so I could thread a
bolt through and push against the stub
axle to push it off. Likewise, I
thought about just putting a little blob of
weld on the outside of the cap so
I could butt up a drift to it to tap it off
easier.
     Has anyone got any
tricks to getting these grease caps off
easier?
     TIA,

     Bill in
Tehachapi

Donate:
Archive: http://www.team.net/archive
Forums:
http://www.team.net/forums
http://autox.team.net/mailman/options/triumphs/[email-masked]