Subject: Re: [TR] TR3 harmonic Balancer

From: Tony Drews <[email-masked]> >
Date: Thu, 26 Sep 2013 11:19:53 -0500

I bought mine from Ken Gillanders at British Frame and Engine
http://www.britishframeandengine.com/

It has no timing marks, they must be added.  Also, it is a good idea 
to paint it or it will rust (oops).

Tony Drews

At 11:11 AM 9/26/2013, William Brewer wrote:
>      After snapping my TR3A crank I am considering a harmonic balancer on my
>upcoming rebuild. I searched on google, but really didn't turn up anything. I
>found one place with a harmonic balancer with the timing marks indexed, but no
>price. Anyone have a good source for a harmonic balancer or any advice? maybe
>I just don't need one if I keep my revs down.
>
>
>
>http://www.atiracing.com/products/dampers/charts/dam-triumph.htm
>
>
>      -Bill
>in Tehachapi
>      1960 TR3A
>      1974 TR6 Mallard
>      1952 Triumph Renown
>
>** [email-masked] **
>
>Donate: http://www.team.net/donate.html
>Archive: http://www.team.net/archive
>Forums: http://www.team.net/forums
>Unsubscribe/Manage: 
>http://autox.team.net/mailman/options/triumphs/[email-masked]

** [email-masked] **

Archive: http://www.team.net/archive

---

From: "TeriAnn J. Wakeman" <[email-masked]>
Date: Thu, 26 Sep 2013 09:26:48 -0700

> I just don't need one if I keep my revs down.
British Frame and Engine and Racetorations immediately come to mind. 
Mine came from Ken at British Frame & engine.

TeriAnn

---

From: "Chuck Arnold and/or Kathleen Kelley" <[email-masked]>
Date: Thu, 26 Sep 2013 09:31:44 -0700

Good Parts has one -- not sure if it fits a 3. I got mine from ATI directly
-- but the timing marks were off so I had to paste on a timing strip.

On Thu, Sep 26, 2013 at 9:11 AM, William Brewer <[email-masked]> wrote:

> http://autox.team.net/mailman/options/triumphs/[email-masked]