Subject: [TR] 1974 Brake calipers

From: John Summers <[email-masked]>
Date: Tue, 27 Aug 2013 03:29:48 -0400

I guess my subject line ask's the question.  My right front
caliper is broken; so says my mechanic.  AND he can't
seem to find a new one.  Says they are "on national back order".  Come on
Triumph owners, let's show him the
error of his ways.  Know where I can lay my hands on one?
Thanks

** [email-masked] **

Archive: http://www.team.net/archive

---

From: [email-masked]
Date: Tue, 27 Aug 2013 08:30:55 -0400 (EDT)

What car?  Have you considered getting a used one and having it 
professionally refurbished?

---

From: "Dave" <[email-masked]>
Date: Tue, 27 Aug 2013 09:44:36 -0500

I know of at least one place that will rebuild them.  contact me if you need 
that info.  their shipping is quite reasonable.  unless its physically 
broken up

---

From: Chad <[email-masked]>
Date: Tue, 27 Aug 2013 08:36:09 -0700 (PDT)

Oreillyauto.com has them listed in stock for $46.99 + CORE.....limited lifetime warranty.

Chad in Tulsa

Sent from Yahoo! Mail on Android