Subject: Re: [TR] Brighter Dash Lights

From: "John & Pat Donnelly" <[email-masked]>
Date: Tue, 13 Aug 2013 20:06:22 -0700

Hmmm. The only dash lights I find at Litezupp are green ones. I'm driving a
Triumph, not a Honda Civic.
Johnnie

> 
> Check out Litezupp http://www.litezupp.com/
> 
> Carl
> 1960 Triumph TR3A - TS81802LO
> http://mysite.verizon.net/cfmtr3a/
> Tampa, FL
> 
> 
> Many years ago there was a thread about replacement light bulbs for the
> dash gauges. I searched the archives but I didn't find anything that
> looked familiar. The bulbs were LEDs, not incandescent, as I recall.
> The folks who did it swore by it.
> 
> Anybody do this change and know what bulb numbers they were?
> 
> Johnnie

** [email-masked] **

Archive: http://www.team.net/archive

---

From: "Greg Lemon" <[email-masked]>
Date: Tue, 13 Aug 2013 23:24:45 -0500

The lucas dash lights in old TRs, MGs, and Healeys, as well as probably most 
other british stuff from the 50s and 60s, use what is called an E10 screw 
base, if you google E10 LED you will get some options like this:

http://www.ledlight.com/e10-screw-base-auto-led-lights.aspx

http://autolumination.com/otherleds.htm

Couple things to remember, most if not all LEDs are polarity sensitive, if 
made for cars they will probably be negative, ground, they are also more 
directional, and a flashlight or spotlight type LED may not give you the 
soft even glow you are looking for for dash lights, but they make multiple 
light leds that shine in different directions, as well as lenses that 
diffuse the light, also the shape may differ and the wider or longer ones 
will probably not fit in your instrument light housing, I went with some 
higher watt incandescents from LBCARCO for the dash lights, and an LED for 
my turn signal indicator, which I could never see on a bright sunny day 
before.

http://www.youtube.com/watch?v=3om56PrC9Rs  (before)

http://www.youtube.com/watch?v=B80m6kPyero   (after)

Greg Lemon

--------------------------------------------------
From: "John & Pat Donnelly" <[email-masked]>
Sent: Tuesday, August 13, 2013 10:06 PM
To: <[email-masked]>; <[email-masked]>
Subject: Re: [TR] Brighter Dash Lights

> Donate: http://www.team.net/donate.html
> Forums: http://www.team.net/forums
> Unsubscribe/Manage: 
> http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: "Greg Lemon" <[email-masked]>
Date: Tue, 13 Aug 2013 23:40:05 -0500

PS, with such riveting stuff on my youtube channel I cannot fathom why I am 
not getting millions of hits and royalties yet..........

--------------------------------------------------
From: "Greg Lemon" <[email-masked]>
Sent: Tuesday, August 13, 2013 11:24 PM
To: "John & Pat Donnelly" <[email-masked]>; <[email-masked]>
Subject: Re: [TR] Brighter Dash Lights

> The lucas dash lights in old TRs, MGs, and Healeys, as well as probably 
> most other british stuff from the 50s and 60s, use what is called an E10 
> screw base, if you google E10 LED you will get some options like this:
>