Subject: [TR] Trip to TRF Summer Party and Lotus Owners Gathering

From: [email-masked]
Date: Thu, 15 Aug 2013 18:55:39 +0000 (UTC)

Trip to Lotus Owners Gathering.

Thursday.
Stopped in on The Roadster Factory Summer Party in Armagh PA on the way there. Been there, done that, got the T-shirt (and the dash plaque).
http://www.flickr.com/photos/pethier/sets/72157634908275592/

Friday.
Fast touring at Watkins Glen. Lunch at the Glen Club. Shot some photos on track before rescuing a Seven that was broken by a rock in an infield road. Welcome party at hotel.
http://www.flickr.com/photos/pethier/sets/72157634910376982/

Saturday.
Parked for the Panoramic Photo at Watkins Glen. Lunch at the Glen Club. Shot some photos on track again. Been there, done that, gut the two coffee mugs. Banquet at hotel in Corning.
http://www.flickr.com/photos/pethier/sets/72157634920702374/

Sunday.
Horseheads NY: PAXed 6th overall at the Glen Region autocross (but the son of two Canadian National AutoSlalom Champions PAXed 1st in his Green and Yellow Elise). I therefore got a 2nd-place LOG trophy and a 2nd-place Glen Region trophy. Buffet at hotel in Corning.
http://www.flickr.com/photos/pethier/sets/72157634932528381/with/9439445985/

Glen Region autocross results:
http://www.glen-scca.org/Solo/2013/Results20130804.asp
PAX results:
http://www.glen-scca.org/Solo/2013/PAX20130804.asp

Monday.
Drove the Lotus into Canada to view Niagara Falls. Stripped off the autocross statics, since I didn't need anything extra to have Customs ask about.
http://www.flickr.com/photos/pethier/sets/72157635012510828/with/9460489495/

Tuesday.
On the way back home (and the previous Tuesday on the way to LOG), I shot some iPhone at this neat lodge I like in an Indiana state park.  Tiny room in historic section on the way to LOG; big room in the new horseshoe section on the way home.
http://www.flickr.com/photos/pethier/sets/72157635012349806/

It was a great trip. The solo trips I took to LOGs in the past were shorter drives, Lake Geneva and Saint Louis. I was gone a week and half on this one.

Awards:

http://www.flickr.com/photos/pethier/9504930697/
http://www.flickr.com/photos/pethier/9507726624/

Phil Ethier West Side Saint Paul Minnesota USA
1973 Triumph Stag LE22439UBW "uncle jack", Sapphire Blue
2004 Suburban 8.1, Sport Red, the only automatic of the bunch
2005 Lotus Elise, Bordeaux Red Pearl
2007 Saturn Ion 3 2.4, Berry Red
[email-masked]
http://www.flickr.com/photos/pethier
http://www.flickr.com/groups/triumphtransamerica
http://www.mnautox.com
http://www.mntriumphs.org

** [email-masked] **

Archive: http://www.team.net/archive

---

From: [email-masked]
Date: Thu, 29 Aug 2013 04:57:52 +0000 (UTC)

Some pix on the LOONY site.  

Some autocross pix
http://www.lotusowners.com/2013Meetings/LOG33/Set11/pages/P1000317_jpg.htm
http://www.lotusowners.com/2013Meetings/LOG33/Set11/pages/P1000334_jpg.htm

Got in a plug for TRF whilst showing off my trophies.  The young chap is Brian Vaccaro, the co- Meet Head.

http://www.lotusowners.com/2013Meetings/LOG33/Set11/pages/P1000356_jpg.htm