Subject: Re: [TR] TR3 Mystery Part and TR3 Bonnet Latch

From: George Richardson <[email-masked]>
Date: Tue, 23 Jul 2013 05:28:22 -0400

Looks like the spring that goes around the plunger next to the bonnet 
latch on my TR3.

George Richardson
Key Men - Keys for Classics
www.key-men.com

On 7/22/2013 9:53 PM, Keith Stewart wrote:
> When I took the 57 TR3 out of storage this season, I found a spring on the
> floor in the drivers compartment. I have no idea where it came from - any
> ideas?
>
> It can be seen at:
> http://www.triumphowners.com/registry.cgi?sectionID=111014&vehicleID=1881
>
> There are about 5 coils, the length is about 1.875 in. in length and just
> under 1 in. in diameter.
>
> Question #2, the latch on the bonnet broke off. Any thoughts on removal from
> the bracket and suggestions for reattachment.
>
> As always, thanks in advance for your help.
>
> Keith Stewart
> keithstewartATexeculinkDOTcom
>
> ** [email-masked] **
>
> Donate: http://www.team.net/donate.html
> Archive: http://www.team.net/archive
> Forums: http://www.team.net/forums
> Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]

** [email-masked] **

Archive: http://www.team.net/archive

---

From: [email-masked]
Date: Tue, 23 Jul 2013 07:28:55 -0400

Is your headlight dimmer switch still intact?

Greg G.
Osseo, MN

---

From: Keith Stewart <[email-masked]>
Date: Tue, 23 Jul 2013 08:43:15 -0400

Thanks Tony, Greg, Tom and Dave. I only moved the car a short distance in the
storage facility. I will take a look at that switch the next time I go to the
storage building. You guys are the BEST.

On 2013-07-23, at 8:23 AM, "davewillner" <[email-masked]> wrote:

> I agree with Greg, it looks like the spring from your dip switch that may
have come apart. Sometimes the rivet or weld comes apart and the "casing" pops
off along with the spring. Happened to me last year...

Keith Stewart