Subject: [TR] Brake light Switch

From: marty sukey <[email-masked]>
Date: Thu, 25 Jul 2013 21:53:59 -0400 FILETIME=[FEEB3DE0:01CE89A2]

A buddy of mine is looking for a brake light switch for his TR4. Would prefer
to not use the plastic versions sold for the Triumphs these days. I seem to
recall one from another car being a direct replacement. Is it Honda? Anybody
remember the details?

Thanks,

** [email-masked] **

Archive: http://www.team.net/archive

---

From: [email-masked]
Date: Thu, 25 Jul 2013 19:05:40 -0700

I believe honda but can't help more than that.  I would also like to know.

-------- Original Message --------
Subject: [TR] Brake light Switch
From: marty sukey <[email-masked]>
Date: Jul 25, 2013 8:54 PM
To: "Triumph List" <[email-masked]>
CC:

Thanks,