Subject: Re: [TR] Source for durable brake light switch

From: "Joseph Laurito" <[email-masked]>
Date: Sun, 16 Jun 2013 22:21:32 -0400

Guy;

The only thing that really matters is the diameter and pitch of the threaded
fitting. Take your old one to your local parts house and ask the clerk to
fix you up with a good metal brake switch.

Joe

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of G.D. Huggins
Sent: Sunday, June 16, 2013 9:51 PM
To: [email-masked]
Subject: [TR] Source for durable brake light switch

Listers,

Can anyone point me to a source for a reliable, quality brake light switch
for a TR4A.
I just went through a second, plastic, POS switch and DO NOT want to buy
another one.

Cheers,

Guy D. Huggins
1965 Triumph TR4A
CTC 63569LO

Online project diary at http://www.genfiniti.com/triumph

** [email-masked] **

Archive: http://www.team.net/archive

---

From: "Bob" <[email-masked]>
Date: Sun, 16 Jun 2013 22:23:36 -0400 46V6BqZfFuxw7LBaeSKMDvoFU1HYkLGl5D032jX8pZ0iNM9k1U 8FsPkWD+4XIwjiB1q5ujsB58GcBEvsrdr+21WSthjECqE3l2Lw ZoeqKo6yu+CKQyB/BjXniF67rZFlxS3V7d3ZV4hpn5NIS5Mh4j VvQuAqE4bFYSedIAgMBmTqEiY891Pmn06cobRyW/+XFti+Uq6S CZIN9gt636a/ss1GqRjmYcv6G+Ocifx0F93rrHLnSs66msnm2Z XUCN1uLyT9qh2wE2t9+uadXN9ZpHNeloWtyxoGdivQqI/wI6Oy 97vsmF2PTSoEiVntVOkNLs2ZmVaKQ+60kbgltFBN2

If the TR4 switch works like the TR6 switch, here's a couple of quality 
alternatives... http://tr6.danielsonfamily.org/AltBrakeSwitch.htm

Bob

Bob Danielson
http://tr6.danielsonfamily.org/

1975 TR6 modified with:
-Throttle Body Injection
-Toyota 5 Speed
-Nissan Differential
-AAW Wire Harness
-CVJs... and more

-----Original Message----- 
From: G.D. Huggins
Sent: Sunday, June 16, 2013 9:50 PM
To: [email-masked]
Subject: [TR] Source for durable brake light switch

Listers,

for
a TR4A.

Cheers,

Guy D. Huggins
1965 Triumph TR4A
CTC 63569LO

Archive: http://www.team.net/archive
http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: David Templeton <[email-masked]>
Date: Mon, 17 Jun 2013 02:32:34 +0000

Guy

When I added my secondary switch to the TR3a, I went with a standard two wire
brake switch off a GM I think.  It was $15( cdn :-) )  at the local parts
store.  The best part was the two nuts provided allowed for exacting
positioning.

Regards
David Templeton

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
On Behalf Of G.D. Huggins
Sent: Sunday, June 16, 2013 9:51 PM
To: [email-masked]
Subject: [TR] Source for durable brake light switch

Listers,

Can anyone point me to a source for a reliable, quality brake light switch for
a TR4A.
I just went through a second, plastic, POS switch and DO NOT want to buy
another one.

Cheers,

Guy D. Huggins
1965 Triumph TR4A
CTC 63569LO

Archive: http://www.team.net/archive
http://autox.team.net/mailman/options/triumphs/[email-masked]