Subject: [TR] Tranny/Overdrive oil

From: John Wise <[email-masked]>
Date: Thu, 13 Jun 2013 08:13:02 -0400

First thanks for everyone confirming my hypothesis of the tranny/overdrive
needing some oil.  My plan is to drain & refill it.

I looked at my records and found 3 different brands/weights over the past 10
or so years.  The same goes true on the recommendations that I have recorded
from the time the car was living in Phoenix.

What is the current wisdom for tranny/overdrive oil in a car that will likely
be staying  Florida??

Thanks in advance

John

John Wise
Ormond Beach, FL

1960 TR3A
http://wisegroupllc.org/_/TR3A.html

1977 Porsche 911S ('86 3.2 engine)
http://wisegroupllc.org/_/Porsche.html

** [email-masked] **

Archive: http://www.team.net/archive

---

From: [email-masked]
Date: Thu, 13 Jun 2013 12:58:52 +0000 (UTC)

Redline MT90

---

From: Mark Hooper <[email-masked]>
Date: Thu, 13 Jun 2013 10:44:00 -0400

For me it's:

Castrol 20/50 in engine
Valvoline 20/50 racing in transmission

Mark
1972 TR6

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
On Behalf Of John Wise
Sent: June-13-13 8:13 AM
To: car discussion Sports Triumph
Subject: [TR] Tranny/Overdrive oil

Thanks in advance

John

John Wise
Ormond Beach, FL

1960 TR3A