Subject: [TR] Replacement starter for my TR3A

From: "Rick" <[email-masked]>
Date: Fri, 7 Jun 2013 13:36:15 -0700

I've been looking at the replacement Hi-Torq starter (Moss and others) for
my post-TS50000 TR3A. Is this a straightforward plug-and-play replacement
part, or is some modification involved? Any satisfied listers out there who
have installed this part?

Rick in Seattle

1960 TR3A

1970 BSA Victor Special

1973 Norton 750 Commando Combat 

1975 Norton 850 Commando Mk3

** [email-masked] **

Archive: http://www.team.net/archive

---

From: Carl TR <[email-masked]>
Date: Fri, 07 Jun 2013 20:42:51 -0500 (CDT)

In my case it was a straightforward replacement.   I can't remember where I got it - I think TSI.

Carl
1961 TR3A - TS81802LO
mysite.verizon.net/cfmtr3a
Tampa, Florida

On 06/07/13, Rick wrote:

Rick in Seattle

1960 TR3A

1970 BSA Victor Special

---

From: "Dave" <[email-masked]>
Date: Fri, 7 Jun 2013 22:03:59 -0500

highly recommend tsi

-----Original Message----- 
From: Carl TR
Sent: Friday, June 07, 2013 8:42 PM
To: [email-masked] ; [email-masked]
Subject: Re: [TR] Replacement starter for my TR3A

In my case it was a straightforward replacement.   I can't remember where I 
got it - I think TSI.

Carl
1961 TR3A - TS81802LO

On 06/07/13, Rick wrote:

Rick in Seattle