Subject: [TR] TR3 Sway bar

From: <[email-masked]>
Date: Wed, 29 May 2013 15:01:24 -0500

As I now have the TR3B to the "Chassis Complete" stage and am waiting on the
body shop I am thinking of other things I can do.  I have determined that an
anti-sway bar might be a good upgrade at reasonable cost, but I have never
shopped for nor installed one before.
 
What is the List consensus on sway bars?  Front vs Rear, should I do both?
Who are the Good/Better/Best equipment providers?  I don't go racing but am
a fairly spirited country roads driver.
 
Many thanks,
Bill
 
Bill Beecher
'58 TR3A TS/30766L "Tarbaby"
'62 TR3B TCF/2549L " Aunt B" (in rehab)
 <http://www.triumphowners.com/1566> www.triumphowners.com/1566
'68 Land Rover Series IIa 88" "The Beast"
"Keep Calm and Carry On

** [email-masked] **

Archive: http://www.team.net/archive

---

From: "TeriAnn J. Wakeman" <[email-masked]>
Date: Wed, 29 May 2013 15:19:24 -0700

> a fairly spirited country roads driver.
Bill, front sway bars make a huge difference in cornering.  My 3 has a 
front sway bar, factory competition spec front springs & SPAX shocks 
adjusted to the firm side.

Most people agree that for a 3 you want to have a tight front end and a 
loose rear end to help keep both rear wheels on the ground. Rear sway 
bars seem to give you good cornering up to an unpredictable point where 
the rear end goes off on its own direction.  I'm not positive but I 
think the point is when a rear tyre gets lifted enough to loose 
traction.  For predictable handling on high speed curves you don't want 
a rear sway bar.

For years the go to person for front sway bars has been Ted.

http://tsimportedautomotive.com/index.html

TeriAnn

---

From: davehogye <[email-masked]>
Date: Wed, 29 May 2013 22:29:00 +0000 (UTC)

Definitely add a front anti-sway bar only. 5/8" minimum. I have a 7/8" on my TR3 and it works great. The springs and shocks will affect the ride comfort, not the bar. I think Addco can supply a bar if you don't find one through the main British suppliers. I think TR3 bars are harder to come by than the TR4. TR4 will work but it's wider to fit the wider TR4 frame. If you can find one for the TR3 specifically, that would be the one to get. Addco will make one for you to your specs for a very reasonable price. There are a couple companies from the UK that might make one to fit just the TR3, but the price with shipping can be an issue. 

Dave H. 

----- Original Message -----
From: [email-masked] 
To: "list Triumph" <[email-masked]> 
Sent: Wednesday, May 29, 2013 1:01:24 PM 
Subject: [TR] TR3 Sway bar 

Many thanks, 
Bill 

Bill Beecher

---

From: davehogye <[email-masked]>
Date: Thu, 30 May 2013 01:41:30 +0000 (UTC)

The problem with putting a TR4-TR6 bar on a TR3 is the tires could rub on the bar. TR3 bars have 2 bends each side or one close to the frame. Also, some TR3 bars with one bend, attach to the middle of the lower A-arm. The 2 bend bars reach further out on the A-arm for better leverage and effect. 

Dave 

----- Original Message -----
From: "davehogye" <[email-masked]> 
To: [email-masked] 
Cc: "list Triumph" <[email-masked]> 
Sent: Wednesday, May 29, 2013 3:29:00 PM 
Subject: Re: [TR] TR3 Sway bar 

Dave H. 

----- Original Message ----- 
From: [email-masked] 
To: "list Triumph" <[email-masked]> 
Sent: Wednesday, May 29, 2013 1:01:24 PM 
Subject: [TR] TR3 Sway bar 

Many thanks, 
Bill 

Bill Beecher

---

From: [email-masked]
Date: Thu, 30 May 2013 03:48:45 +0000 (UTC)

Front bar on a TR4 or TR3,

Phil Ethier West Side Saint Paul Minnesota USA
1973 Triumph Stag LE22439UBW "uncle jack", Sapphire Blue
2004 Suburban 8.1, Sport Red, the only automatic of the bunch
2005 Lotus Elise, Bordeaux Red Pearl
2007 Saturn Ion 3 2.4, Berry Red
[email-masked]
http://www.flickr.com/photos/pethier
http://www.flickr.com/groups/triumphtransamerica
http://www.mnautox.com
http://www.mntriumphs.org

----- Original Message -----
> Sent: Wednesday, May 29, 2013 3:01:24 PM