Subject: [TR] Tr3 Brake servo installation

From: Chris Simo <[email-masked]>
Date: Thu, 30 May 2013 16:50:37 -0400

Does anyone have any pictures of TR 3 brake servo installations I saw one
picture in how to restore or tr2 to tr 3s.  It look like it was on the
inside of the drivers fender well.

Thanks Chris

** [email-masked] **

Archive: http://www.team.net/archive

---

From: Chris Simo <[email-masked]>
Date: Thu, 30 May 2013 16:54:08 -0400

Sorry I should clarify remote brake servo