Subject: [TR] it runs again

From: "Dave" <[email-masked]>
Date: Thu, 9 May 2013 22:28:35 -0500

TCF 1402 L ran again tonight after I donbt know how many years.  we think it
was restored years ago (donbt really know) then left in a storage unit.  btw
they really skimped on the paint job (sigh)

after changing the oil, a new starter, unsticking the back float,  cleaning
out the gas line and putting some petrol in the tank, it ran with some help
from some starter fluid to get it going.

it leaks quite a bit from the bottom of the sediment bowl at the fuel pump so
obviously I need to get that taken care of.  likely just a gasket?  if I
unscrew the little wingnut at the bottom, it will (fall out and break) come
out easily enough?  and the gasket goes around the top?

** [email-masked] **

Archive: http://www.team.net/archive

---

From: Randall <[email-masked]>
Date: Fri, 10 May 2013 18:21:52 +0000

> out easily enough?  and the gasket goes around the top?

If it is that old, and leaking that badly; my suggestion would be to go ahead and remove the pump to "rebuild" it with new seals and a new diaphragm.  The original diaphragms will not stand up for long when exposed to modern E10 fuel.  With it off the engine, it will be much easier to check the surface that the sediment bowl seals against; as well as understand better how that bail works.

The rebuild kit from TRF includes a nice soft synthetic rubber seal for the sediment bowl, that will both resist E10 and work much better than the original cork, IMO.  The cost of the kit is significantly more than other sources, but I feel the quality is worth the price.
http://goo.gl/tlnZG

Get a 1/4" drive swivel socket in the right size (I forget offhand whether it's 7/16" or 1/2"). Sears has them.  It will make the R&R of the pump MUCH easier.  Justin Wagner had a photo on his web site but I don't have the link handy.  So here is a shot of it installing carbs:
http://goo.gl/z8KgE

You might also want to replace the soft fuel lines.  They aren't likely to be original, but still might not be resistant to E10.  It's frustrating when they fail, because frequently the first indication is the front carb overflowing.

Randall

---

From: [email-masked]
Date: Fri, 10 May 2013 13:42:16 -0500 (CDT)

I sent the whole thing off to TRF from my 72 TR6 and for $90, came back looking brand new.

Got the soft lines from Moss, easy to replace.

Craig

On 05/10/13, Randall<[email-masked]> wrote:

Randall