Subject: Re: [TR] TR3/TR4 block drain valve?

From: Allen Hess <[email-masked]>
Date: Sun, 19 May 2013 20:19:58 -0400

The block drain valve is the same as the radiator drain valve (or  
should be) and you can get a much better look at that one. I recall it  
being substantial enough that it should come out without much trouble  
but the usual "proceed with caution" applies. I think it is more  
likely that the drain lever will be stuck. It is a taper held in the  
body with a spring, washer and cotter pin. You may be able to tap it  
from underneath and free it. Removing the valve from the block  
provides a larger hole for the crud to come out and you can bend a  
stiff wire (coat hanger) to loosen the crud towards the rear of #4  
cylinder. As usual, been there, done that.

Allen
On May 19, 2013, at 2:00 PM, [email-masked] wrote:

> How sturdy are the block drain valves?  The one on my TR4 is  
> clogged.  I've
> been hesitant to remove it, fearing that it would crumble into  
> pieces and
> screw up the threads.  Too many bad adventures with home plumbing  
> have left
> me gun shy.

** [email-masked] **

Archive: http://www.team.net/archive

---

From: "Randall" <[email-masked]>
Date: Sun, 19 May 2013 17:53:58 -0700

> The block drain valve is the same as the radiator drain valve 
> (or should be) and you can get a much better look at that 
> one.

Although identical otherwise, I believe they had different threads and
should not be interchanged.

My radiator shop more or less insists on replacing the radiator valve, so it
may not be as original.

-- Randall

---

From: davehogye <[email-masked]>
Date: Mon, 20 May 2013 01:42:46 +0000 (UTC)

The drain valve is pretty sturdy and it should have a fiber washer between it and the block. So it should come loose with a quick "surprise" twist of a wrench. 

Dave H. 

----- Original Message -----
From: "Allen Hess" <[email-masked]> 
To: [email-masked] 
Sent: Sunday, May 19, 2013 5:19:58 PM 
Subject: Re: [TR] TR3/TR4 block drain valve? 

Allen

---

From: davehogye <[email-masked]>
Date: Mon, 20 May 2013 02:09:12 +0000 (UTC)

Oh, and it's brass, or should be, so it shouldn't be frozen with corrosion. 

----- Original Message -----
From: "davehogye" <[email-masked]> 
To: "Allen Hess" <[email-masked]> 
Cc: [email-masked] 
Sent: Sunday, May 19, 2013 6:42:46 PM 
Subject: Re: [TR] TR3/TR4 block drain valve? 

Dave H. 

----- Original Message ----- 
From: "Allen Hess" <[email-masked]> 
To: [email-masked] 
Sent: Sunday, May 19, 2013 5:19:58 PM 
Subject: Re: [TR] TR3/TR4 block drain valve? 

Allen