Subject: [TR] rear oil seal TR3

From: Frank Fisher <[email-masked]>
Date: Tue, 7 May 2013 08:19:11 -0700 (PDT)

would love to hear testimony from those who have used the "new" rear oil seal for the TR3 motors.
the one that does not require the crank be machined.
Frank

** [email-masked] **

Archive: http://www.team.net/archive

---

From: "[email-masked]" <[email-masked]>
Date: Tue, 07 May 2013 10:33:54 -0500 s=q20121106; t=1367940836; bh=cNINbvvCzoEM9sCgOz5UmdJEw2nnrK75HGsMqaaYF9A=; h=Received:Received:To:From:Subject:Date:MIME-Version:Content-Type; b=matFA5tpnG4oQhL5nuRB067E4uFE/2mV9xuwl88j2s6xOJN1dCh6kBgo93f1DU21O uF4gAnkKVhWSnzUP79MWrj7f0ICquDh9fM69Qh3040Em4NxWy9lpmSgmYcGFrSlPr7 POO3WBQSV3NB4IVa2aA6CTaoowTUafQBLRX/c6hmOQWRTRNzwlIFfAW6s6OxJR2zQQ riTIwZDP6+1qm+XOh2t73ynlxhZNcdxHosKCMhfSJ74f6sKoDdL/fxNODi9jXjq38F 6T8zT/uxdP+qI1fXhrRuyY/zI3mK1wDWFzFcnZy5v412diqDz4U2FyZa+L0onRzp+I HATUBt2wS6ftg==

Me, too.

Sent from my Verizon Wireless Phone

---

From: Randall <[email-masked]>
Date: Tue, 7 May 2013 22:24:38 +0000

---- "[email-masked]" <[email-masked]> wrote: 
> Alexander Racing Enterprises 
> http://the-vintage-racer.com//index.php
> Click on
> engine componants - second page middle.
> No picture but from the price and
> mention of a core charge you send in your old aluminum seal 
> and get a
> machined one in return along with the new Viton seal.

Joe doesn't do that any more; too much hassle with the cores (and people who didn't have a core available).  Instead, he now has a shipment of new alloy seal housings.  So it is a fully bolt-on kit, except that they recommend some light polishing of the crank surface where the seal rides.  You can also get the same kit through TRF (who gets them from Joe).

Here's a photo of the new kit
http://goo.gl/gfv2R

and a copy of the older installation instructions (ignore the section on how to modify the old housing)
http://goo.gl/bqIF3

Randall

---

From: Chris Simo <[email-masked]>
Date: Tue, 7 May 2013 18:40:52 -0400

I'm happy with it. Very little oil on the floor.  Pretty much a fifty cent
piece puddle after a drive.  Some is from the breather for sure.  I need to
put it on the lift and check oil pan bolts. Im pretty sure it aint the seal.