Subject: [TR] timing chain prep

From: Greg <[email-masked]>
Date: Mon, 20 May 2013 20:01:58 -0700

List,

Do I recall correctly that you're supposed to soak a new timing chain in oil
before installing it?  if not, do I use assembly lube on the chain/new gears
when I install them?

thanks,
Greg

** [email-masked] **

Archive: http://www.team.net/archive

---

From: Greg <[email-masked]>
Date: Mon, 20 May 2013 20:32:53 -0700

Thanks, Michael.  I like the belt and suspenders approach!

g

On May 20, 2013, at 8:22 PM, Michael Porter wrote:

> On 5/20/2013 9:01 PM, Greg wrote:
>> List,
>>
> More lubrication, rather than less, is never wrong.  All roller chains
depend upon splash, and it does take a little time for engine oil to work its
way into the spaces between the pins and the rollers.
>
> Do both! :)
>
>
> Cheers.
>
> --
>
>
> Michael Porter
> Roswell, NM
>
>
> Never let anyone drive you crazy when you know it's within walking
distance....