Subject: [TR] engine stands

From: "Andrew Uprichard" <[email-masked]>
Date: Fri, 12 Apr 2013 15:09:06 -0400

I am thinking of getting an engine stand.  I see Harbor Freight has a couple
of 1000lb stands.  Questions:  is 1000 Ok for a TR3 engine and (overdrive)
gearbox combination and does anyone have experience with the Harbor Freight
ones?

Andrew Uprichard

** [email-masked] **

Archive: http://www.team.net/archive

---

From: Randall <[email-masked]>
Date: Fri, 12 Apr 2013 19:23:05 +0000

> gearbox combination and does anyone have experience with the Harbor Freight

What HF calls an "engine stand" is not intended for hanging an engine plus gearbox on.  The engine mounts to it via the rear flange.

I have the discontinued 750 lb engine stand from HF, it works well enough for me.  
http://goo.gl/kEQVs
The main difference is that it only has 3 wheels and is correspondingly less stable (which can be a concern if you are trying to move it over a rough floor with an engine on).  It's had a TR4 engine block hanging on it for probably 20 years now and is still holding fine.

IIRC I had to source some suitable bolts, though.  The ones that came with it were not long enough.

Randall

---

From: Darrell Walker <[email-masked]>
Date: Fri, 12 Apr 2013 19:40:13 +0000 (GMT)

On Apr 12, 2013, at 12:32 PM, Andrew Uprichard <[email-masked]>
wrote:

Rather like the time I was thinking of getting a tonneau cover for my
TR3
and was then reminded it had a roll bar.......

I had both a tonnueau
and roll bar on my TR4a for a long time.  Just had cutouts made to go around
the roll bar.  Maybe not quite so easy on a TR3, since it wouldn't be so flat.
-Darrell

---

From: Carl TR <[email-masked]>
Date: Fri, 12 Apr 2013 17:44:15 -0500 (CDT)

If you have a sturdy work bench. you may want to move to the top for clutch/tranny installation.  no need to bend over, etc as well as much less 'lifting' even with a hoist.  see: http://s1001.photobucket.com/user/cfmtr3a/media/TS81802LO/07-Tran1.jpg.html 
 
I did end up putting down on the floor as there was a delay in getting it into the frame.  but if all had been as I wanted, it would have been straight to the frame from the workbench (it is on rollers)

Carl
1961 TR3A - TS81802LO
mysite.verizon.net/cfmtr3a
Tampa, Florida

On 04/12/13, Bob Labuz wrote:

When it came time to mount the transmission, I just hooked the engine up 
to my chain-fall and then lowered the engine on a pallet where I 
assembled the clutch and transmission prior to installation into the 
engine.