Subject: [TR] TR6 carb neadles

From: Frank Fisher <[email-masked]>
Date: Mon, 11 Mar 2013 09:39:10 -0700 (PDT)

kept my buddy company this week as he attempted to rebuild his zenith carbs
from his 73 TR6.
 
first frustration is buying a "rebuild kit" that contains
only 1/2 the parts you need to rebuild! got new jets but no new needle. what
the heck?
 
couple questions:
 
first how do you get that jet out?
 
second.
how do you get the needle out?
and the needle was wobbly. you could push it
sideways a little. is that normal? yes we had the little grub screw screwed in
and the little brass collar turned so the slot lined up with the grub screw..
 
also we could pull the needle down and it would pop back in like its on a
spring. is that normal?
 
thanks
Frank

** [email-masked] **

Archive: http://www.team.net/archive

---

From: [email-masked]
Date: Mon, 11 Mar 2013 12:58:19 -0400 (EDT)

In a message dated 3/11/2013 12:40:40 P.M. Eastern Daylight Time,  
[email-masked] writes:

first  frustration is buying a "rebuild kit" that contains
only 1/2 the parts you  need to rebuild! got new jets but no new needle. 
what
the  heck?

I have never seen a ZS rebuild kit that came with jets  or needles - it 
would be unusual to need needles, and even more unusual to  need jets. the jets 
on a 73 have to be pressed out.

second.
how do you get the needle out?
and the needle was  wobbly. you could push it
sideways a little. is that normal? 
 
yes, that is normal. to get the needle out, first you  will need to screw 
the adjusting screw all the way out of the needle  carrier (from above with a 
ZS adjustment tool) - then remove that grub screw and  pull the needle out.

..

yes, that is normal
 
Cheers,
Jack Mc

---

From: Frank Fisher <[email-masked]>
Date: Mon, 11 Mar 2013 10:10:46 -0700 (PDT)

thank you Jack.
i can confirm that his kit did contain a set of jets. but did
not contain a needle.
 
so basically a rebuild kid is a new diaphragm, screws
and gaskets? just being a ass here on this comment :-)
 
 thanks
Frank

From:
"[email-masked]" <[email-masked]>
To: [email-masked];
[email-masked] 
Sent: Monday, March 11, 2013 9:58 AM
Subject: Re:
[TR] TR6 carb neadles

In a message dated 3/11/2013 12:40:40 P.M. Eastern
Daylight Time, [email-masked] writes:
first frustration is buying a
"rebuild kit" that contains
>only 1/2 the parts you need to rebuild! got new
jets but no new needle. what

I have never seen a ZS rebuild kit
that came with jets or needles - it would be unusual to need needles, and even
more unusual to need jets. the jets on a 73 have to be pressed out.
 
>sideways a little. is that normal? 

yes, that is normal. to get the
needle out, first you will need to screw the adjusting screw all the way out
of the needle carrier (from above with a ZS adjustment tool) - then remove
that grub screw and pull the needle out.

..
>also we could pull the
needle down and it would pop back in like its on a
yes, that is normal
 
Cheers,
Jack Mc

---

From: [email-masked]
Date: Mon, 11 Mar 2013 13:34:10 -0400 (EDT)

The rebuild kits are generic but the needles are specific to the model, 
market and year of the car so other than including all possible needle 
selections the only option is to supply none.  (Makes for a less expensive kit)  

Yes, the needle is spring loaded.  This eliminates the need to center the 
jet (which you can't do on a ZS carb anyway).  To remove you remove the grub 
screw on the side of the piston and then back off the adjustment and the 
needle assembly will withdraw from the bottom of the piston.

The jets themselves are pressed in.  I've never changed one so I don't know 
the best way to go about this.  Pressing one in means you have to set the 
proper depth so be sure to measure the depth before you remove the old one.

Dave (I've got a couple of kits coming in the mail myself)

---

From: Randall <[email-masked]>
Date: Mon, 11 Mar 2013 18:45:00 +0000

> got new jets but no new needle. what 
> the heck? 

That's so you can substitute the B1E needles that supposedly work better with E10 (according to Joe Curto).

> first how do you get that jet out?

This will sound somewhat heretical, but what about just leaving the jet alone?  Unlike the earlier fixed needle carbs, the jets rarely wear on the later carbs with the spring-loaded needles.

As noted, it is pressed into place.  Some simple mandrels are called for, you probably don't want to put pressure on the entire carb body.  And there is no positive location for position (even though the position is somewhat critical), so be sure to measure the old position and duplicate it.

> how do you get the needle out?

Read the excellent series of articles on how to rebuild ZS carbs at
http://www.buckeyetriumphs.org/technical/technical.htm

> also we could pull the needle down and it would pop back in like its on a

Yes, and yes.  Obviously you don't want to pull too hard as the spring is what locates the needle in normal operation.

--- Randall