Subject: [TR] Stuck SU needle

From: [email-masked]
Date: Wed, 13 Mar 2013 16:44:34 -0400 (EDT)

Hi everyone;
 
Does any one have any tips to get the needle out of the piston on an SU? I  
have removed the needle securing screw, but the needle won't move.
 
Thanks;
 
Tim (TR3A TS22930LO)

** [email-masked] **

Archive: http://www.team.net/archive

---

From: Randall <[email-masked]>
Date: Wed, 13 Mar 2013 21:23:30 +0000

> have removed the needle securing screw, but the needle won't move.

At some point, the needle becomes disposable and you can just grab it with vise-grips.

- Randall

---

From: "Pete Ryner" <[email-masked]>
Date: Wed, 13 Mar 2013 20:01:54 -0400

Try soaking in mystery oil or similar.  If it still doesn't budge, Randall 
has a good point.  Just be careful to get all of the needle out and don't 
damage the piston.
Pete

-----Original Message----- 
From: Randall
Sent: Wednesday, March 13, 2013 5:23 PM
To: [email-masked] ; [email-masked]
Subject: Re: [TR] Stuck SU needle

> have removed the needle securing screw, but the needle won't move.

At some point, the needle becomes disposable and you can just grab it with 
vise-grips.

- Randall

Archive: http://www.team.net/archive
http://autox.team.net/mailman/options/triumphs/[email-masked]