Subject: [TR] Tax Discs (formerly Tax Stamp)

From: [email-masked]
Date: Mon, 11 Mar 2013 09:55:21 -0400 (EDT)

List,
 
Thanks to all who replied to my search for a tax disc.  I originally  
called it a tax stamp which got no hits on google so I should have suspected  
that I was calling it incorrectly!
 
Anyway....FYI - here's the website I selected to order my tax disc:   
_www.britishtaxdiscs.co.uk_ (http://www.britishtaxdiscs.co.uk) 
 
The company's name is Earlswood Vintage & Classic
 
Chip Krout
Delaware Valley Triumphs, Ltd.
Skippack, PA 
1962 TR4  CT2052L

** [email-masked] **

Archive: http://www.team.net/archive

---

From: Robert Jones <[email-masked]>
Date: Mon, 11 Mar 2013 09:21:58 -0500

Chip:

I got mine from Greg Powell.  Nicely done, multiple copies, and great price.

[email-masked]

Bob
On Mar 11, 2013, at 8:55 AM, [email-masked] wrote:

> Donate: http://www.team.net/donate.html
> Forums: http://www.team.net/forums
> Unsubscribe/Manage:
http://autox.team.net/mailman/options/triumphs/[email-masked]