Subject: Re: [TR] restoring/cleaning the plastic radiator overflow bottle

From: "Andrew S. Mace" <[email-masked]>
Date: Sat, 16 Mar 2013 14:31:46 -0400 (EDT)

Automatic dishwashing detergents often help brighten those up quite a bit;
same with master cylinder reservoirs. Probably best not to run them through
the diswasher along with the good dinnerware, though.... ;)

--Andy Mace

*Mrs Irrelevant: Oh, is it a jet?
*Man: Well, no ... It's not so much of a jet, it's more your, er, Triumph
Herald engine with wings.
-- Cut-price Airlines Sketch, Monty Python's Flying Circus (22)

Triumph 10 / Herald / Sports 6 vehicle consultant, The Vintage Triumph
Register: http://www.vtr.org

Check out the North American Triumph Sports 6 (Vitesse 6) and Triumph Herald
Database: http://triumph-herald.us

-----Original Message-----
From: Dave Connitt <[email-masked]>
To: triumphs <[email-masked]>
Sent: Sat, Mar 16, 2013 2:21 pm
Subject: [TR] restoring/cleaning the plastic radiator overflow bottle

List,
Does anyone have any suggestions on cleaning/restoring my radiator overflow
bottle? I might also add that I have the original windshield washer fluid
bottle and would really like to use that too. The radiator overflow bottle
looks like it has the usual rust and coolant residue inside it so I was kind
of leaning towards trying CLR or something like that..
I already zinc plated the two original mounting brackets, now the original
bottles REALLY look crappy...
Thanks in advance,
Dave Connitt
'67 TR4A IRS
http://home.fuse..net/davestr4a

** [email-masked] **

Archive: http://www.team.net/archive
http://autox.team.net/mailman/options/triumphs/[email-masked]

** [email-masked] **

Archive: http://www.team.net/archive

---

From: Don Hiscock <[email-masked]>
Date: Sat, 16 Mar 2013 13:43:37 -0500

One of the strongest cleaners I know is "SuperClean", a liquid
degreaser that comes in a purple bottle in any auto parts store and
some big-box stores.  Polyphosphate based detergent, IIRC.

The stuff is strong.  It's a very good degreaser. Good for
reblackening oxidized hard rubber.  Hard on some materials and
finishes so use with caution.  It does the best of any material I've
found on old plastics.  It's what I'd try.

Did I say it's strong?  Remember to tet it in any unknown finish,
including some platings. Can be used diluted, too.

I'm experimenting with Evapo-Rust rust remover right now.  This stuff
is kind of interesting. super on ferrous metals.  Dunno about stains
on plastic, but might be worth checking.

Don
1962 TR3B TSF202L

On 3/16/13, Dave Connitt <[email-masked]> wrote:
> Donate: http://www.team.net/donate.html
> Forums: http://www.team.net/forums
> Unsubscribe/Manage:
> http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: Geo Hahn <[email-masked]>
Date: Sat, 16 Mar 2013 11:45:54 -0700

I have used Soft Scrub with some success on such bottles -- though some of
the staining may be really in the plastic rather than on the surface and
that you may have to live with or replace

Geo

On Sat, Mar 16, 2013 at 11:21 AM, Dave Connitt <[email-masked]> wrote:

> bottle?

---

From: "Dixie4" <[email-masked]>
Date: Sat, 16 Mar 2013 20:41:29 -0000

Dave,

It may sound too simple but a complete submersion in cheapo household bleach 
for 48 hours worked for me. After treatment I noticed that the rad expansion 
bottle was slightly yellowed on the outside. A very light sanding on the 
outside with fine wet/dry paper worked perfectly. Bright white is for repro 
bottles only, the original ones were always an off white slightly creamy 
colour.
Oh! and by the way pour the bleach back in the bottle and use down the 
toilet in the normal way.
That is real recycling.
Regards,
Adrian
1966 TR4A CT64306 O
Wales UK
----- Original Message ----- 
From: "Dave Connitt" <[email-masked]>
To: <[email-masked]>
Sent: Saturday, March 16, 2013 6:21 PM
Subject: [TR] restoring/cleaning the plastic radiator overflow bottle

> http://autox.team.net/mailman/options/triumphs/[email-masked]
>
>
> -----
> No virus found in this message.
> Checked by AVG - www.avg.com
> Version: 2013.0.2904 / Virus Database: 2641/6180 - Release Date: 03/15/13