Subject: Re: [TR] Carelli carpet sets on Ebay and other interior pieces for Triumphs

From: alan salvatore <[email-masked]>
Date: Fri, 29 Mar 2013 21:52:01 -0400

Its an OK carpet for the money.

Depends on your budget.

I put one in a car.  Its a very stiff carpet because of the jute backing.
I used a rubber hammer to massage it into shape.
The emergency brake cover is flimsy.
I didn't care for the rubber mat being place on the passenger side.

TRF carpet is more but its better quality.and like the factory carpet.
TRF carpet has a rubber backing and lays over the rockers and tranny cover
for a better fit.

Al

.

On Fri, Mar 29, 2013 at 8:50 PM, Dave Connitt <[email-masked]> wrote:

> List,
> One more thing..
> Has anyone on the list purchased a carpet set from Cover-zone/Carelli? They
> look decent and are around $165.00. But, it's just a picture. They claim
> to be
> a UK company, not that that is anything special but just a interesting
> note.
> Also, does anyone have any suggestions on door panels and other upholstery
> items such as the wheel covers and the piece that runs around the back of
> the
> interior? Moss sells a kit but they want $700.00, ouch..
> Just wanted to see what else, if anything is out there.
> Thanks again,
> Dave Connitt
>
> ** [email-masked] **
>
> Donate: http://www.team.net/donate.html
> Archive: http://www.team.net/archive
> Forums: http://www.team.net/forums
> Unsubscribe/Manage:
> http://autox.team.net/mailman/options/triumphs/[email-masked]

** [email-masked] **

Archive: http://www.team.net/archive

---

From: "Bob" <[email-masked]>
Date: Sat, 30 Mar 2013 14:23:54 -0400 P6zO9JcH8B4kkMr3akWWX/rJN/wWWmizYOVwpOziRkeWO3narI c+yqeC0tRJ1n7LiHB7PsXBawWSenYlVHxYCvUkxKuELCp8gaqX dSmP/UUAsEgLBplFMNfEHHLiIBc6SqMnyD5HoDXyq4PaKib+WR 9UBPMMg8qjWQZtpI4kHN7tVyds+VVV2XfOsglULLi/C9fV3G2P cWDoSofXMeFrya0aJpwbY4WG2BPAdJaxc9ojfcQscjZlT1wp/L pivZKaRoHN/047PovD7Uv4s7VcM0Z2oQSKOog+n0nvw5j5Ferw mhEiwO8mKcnUBVnzZAfKcbkPs10KipGA39ybKV34P

I know a guy :-) who does custom interiors for TR6....... they also happen 
to fit the TR4........ you can see his work and prices here

http://tr6.danielsonfamily.org/PanelBootSales1.htm#Completed_Kits

The downside is there's very few stock colors of vinyl by the yard available 
to purchase.......... well TRF and VB do sell it at $70/yd which is 
outrageous when you consider that most vinyl falls in to the $20-$35/yd 
range.

Bob

Bob Danielson
http://tr6.danielsonfamily.org/

1975 TR6 modified with:
-Throttle Body Injection
-Toyota 5 Speed
-Nissan Differential
-AAW Wire Harness
-CVJs... and more

-----Original Message----- 
From: Dave Connitt
Sent: Friday, March 29, 2013 8:50 PM
To: [email-masked]
Subject: [TR] Carelli carpet sets on Ebay and other interior pieces for 
Triumphs

List,
One more thing..
Has anyone on the list purchased a carpet set from Cover-zone/Carelli? They
look decent and are around $165.00. But, it's just a picture. They claim to 
be
a UK company, not that that is anything special but just a interesting note.
Also, does anyone have any suggestions on door panels and other upholstery
items such as the wheel covers and the piece that runs around the back of 
the
interior? Moss sells a kit but they want $700.00, ouch..
Just wanted to see what else, if anything is out there.
Thanks again,
Dave Connitt

Archive: http://www.team.net/archive
http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: Tony Drews <[email-masked]>
Date: Sat, 30 Mar 2013 16:26:07 -0500

FYI - Moss has a carpet, upholstery and top sale going on according 
to the flyer I got in the mail today.

Tony Drews

At 07:50 PM 3/29/2013, Dave Connitt wrote:
>look decent and are around $165.00. But, it's just a picture. They claim to be
>items such as the wheel covers and the piece that runs around the back of the