Subject: [TR] Triumph Carburetors

From: "Andrew Uprichard" <[email-masked]>
Date: Thu, 7 Feb 2013 17:55:11 -0500

I know the TR3s used the SU H 6 carb and the TR250 and 6 used Strombergs,
but what did the TR4 and 4A use?  I am thinking of building a
faster-than-my-other TR3A, and think I can get more out of SU HS 6s than I
can out of SU H 6s.  I have Webers on my TR250 and don't want to go there.
All that dyno stuff...

What does the list think of H6 vs HS6?

Andrew Uprichard

** [email-masked] **

Archive: http://www.team.net/archive

---

From: Randall <[email-masked]>
Date: Thu, 7 Feb 2013 18:56:58 -0500

---- Andrew Uprichard <[email-masked]> wrote: 
> but what did the TR4 and 4A use?

Early TR4 used H6, same as TR3.  Later TR4 through middle TR4A used non-emissions ZS carbs, then late TR4A used SU HS6 carbs.

The HS6 supposedly flow the best on a flow bench, but I understand the difference is almost unnoticeable on a dyno.  The carbs don't appear to be the limiting factor until significant other modifications are made.

If you really want low restriction, go to port injection and lose the venturi (which has to present some restriction to function) altogether.

>  I am thinking of building a

Unfortunately, those significant other modifications I mentioned are going to have the same effect : the stock needles won't be appropriate any more.  You're still going to need to do some development to get the mixture right; although you might be able to do most or even all of it on the road with a wide band O2 meter or perhaps a 4 channel EGT meter.  I haven't tried it myself yet, but I understand that "laptop dyno" works pretty good as well if you have a road to try things out on without attracting the attention of the local gendarmes.

Or perhaps your cousin Daryl could help.

Randall