Subject: Re: [TR] aluminum radiators

From: Frank Fisher <[email-masked]>
Date: Mon, 4 Feb 2013 13:48:42 -0800 (PST)

Buddy Curt has had one on his TR3 for about 2/3 years now.
no problems
your
results may vary !!
Frank

________________________________
From: Andrew
Uprichard <[email-masked]>
To: [email-masked] 
Sent:
Monday, February 4, 2013 12:17 PM
Subject: [TR] aluminum radiators

I see
aluminum radiators being advertised on eBay for not much more than the
cost of
recoring my old one.  Does anyone have experience with these
radiators?
Andrew Uprichard

** [email-masked] **

Donate:
Archive: http://www.team.net/archive
Forums:
http://www.team.net/forums
http://autox.team.net/mailman/options/triumphs/[email-masked]

** [email-masked] **

Archive: http://www.team.net/archive

---

From: "Skip Gurnee" <[email-masked]>
Date: Wed, 6 Feb 2013 10:47:34 -0800

Andrew Uprichard wrote-
"I see aluminum radiators being advertised on eBay for not much more than 
the
cost of recoring my old one.  Does anyone have experience with these
radiators?"

I bought an aluminum radiator (from Griffin Radiator in Piedmont SC) for the 
TVR.  It was expensive, and it works better than stock.  I'd say you'd take 
a big chance buying something advertised as aluminum for near the same price 
as a recore.  Aluminum, by the way, doesn't transfer heat as well as copper, 
so unless you go bigger/thicker, you save nothing but a little weight.

Skip Gurnee
64TR4
66TR4A
67 Lotus Cortina
70TVR

---

From: Jonas Payne <[email-masked]>
Date: Wed, 6 Feb 2013 11:09:11 -0800

Guy in our club just got one for his AH sprite - neat piece of work.  Can't
beat the price.

Jonas Payne
PBR Consulting
702-882-6711

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of Skip Gurnee
Sent: Wednesday, February 06, 2013 10:48 AM
To: Andrew Uprichard; [email-masked]
Subject: Re: [TR] aluminum radiators

Andrew Uprichard wrote-
"I see aluminum radiators being advertised on eBay for not much more than
the cost of recoring my old one.  Does anyone have experience with these
radiators?"

Skip Gurnee
64TR4
66TR4A
67 Lotus Cortina
70TVR

Archive: http://www.team.net/archive
http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: "TeriAnn J. Wakeman" <[email-masked]>
Date: Wed, 06 Feb 2013 12:46:37 -0700

On 2/6/13 11:47 AM, Skip Gurnee wrote:
>  Aluminum, by the way, doesn't transfer heat as well as copper, so 
> unless you go bigger/thicker, you save nothing but a little weight.
No but it does transfer heat better than brass.  Maybe one should be 
looking for a sliver radiator.

I got my aluminum radiator about 2-1/2 years ago off ebay and it does 
help my 3 stay cooler in hot weather.

TeriAnn

---

From: "Roger Wilson" <[email-masked]>
Date: Wed, 6 Feb 2013 12:33:58 -0800

Replace a radiator with a crank hole in my TR3 with an aluminum one w/o the
hole about 2 years ago. I think it stays cooler in the summer, especially in
traffic, probably more due to better flow w/o the crank hole.

Roger

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of TeriAnn J. Wakeman
Sent: Wednesday, February 06, 2013 11:47 AM
To: [email-masked]
Subject: Re: [TR] aluminum radiators

> unless you go bigger/thicker, you save nothing but a little weight.
No but it does transfer heat better than brass.  Maybe one should be looking
for a sliver radiator.

I got my aluminum radiator about 2-1/2 years ago off ebay and it does help
my 3 stay cooler in hot weather.

TeriAnn

Archive: http://www.team.net/archive
http://autox.team.net/mailman/options/triumphs/[email-masked]