Subject: [TR] Part Request

From: "James Henningsen" <[email-masked]>
Date: Thu, 3 Jan 2013 19:35:56 -0500

Looking for a working original Triumph am radio (pos or neg polarity switch
preferable) with the chrome look push buttons and handles.  It is for an
early 62 TR4.  Please email me off list. Many thanks,

Jim Henningsen

Ocala FL

62 TR4 CT5212LO

75 TR6

[email-masked]

** [email-masked] **

Archive: http://www.team.net/archive

---

From: Frank Fisher <[email-masked]>
Date: Fri, 4 Jan 2013 08:18:44 -0800 (PST)

does it have to play only oldie's?

From: James Henningsen
<[email-masked]>
To: [email-masked] 
Sent: Thursday, January 3,
2013 4:35 PM
Subject: [TR] Part Request

Looking for a working original
Triumph am radio (pos or neg polarity switch
preferable) with the chrome look
push buttons and handles.  It is for an
early 62 TR4.  Please email me off
list. Many thanks,

Jim Henningsen

Ocala FL

62 TR4 CT5212LO

75 TR6
[email-masked]

Donate:
Archive: http://www.team.net/archive
Forums:
http://www.team.net/forums
http://autox.team.net/mailman/options/triumphs/[email-masked]