Subject: [TR] Electronic flasher issue

From: Andy Graybeal <[email-masked]>
Date: Tue, 8 Jan 2013 15:16:22 -0800

Hi, all
I recently purchased from Moss Motors and installed LED replacements for the
original signal/tail lights. The lights work fine and are nice and bright, but
the electronic flasher doesn't take a rest when the turn signal stalk is in
the off position. It continues to click away but the only light affected is
the indicator light on the dash. I can't figure out how to stop it. Anyone
have that problem?

Andy Graybeal

** [email-masked] **

Archive: http://www.team.net/archive

---

From: Randall <[email-masked]>
Date: Thu, 10 Jan 2013 18:25:30 -0500

This is just a thought as I have not converted to LED tail lights.  But I have noticed that some flashers do not work correctly with the dash lamp grounded, and do work properly if you instead connect the lamp to the green circuit (switched power).  At any rate, this is an easy thing to try on a TR3 (not sure about later cars), as the lamp holder is not grounded through its mount.  You can just remove the ground wire from the tie point on the back of the panel, and instead connect it to the hot terminal on the fuel gauge.

HTH
Randall

---

From: Randall <[email-masked]>
Date: Thu, 10 Jan 2013 18:54:04 -0500

---- [email-masked] wrote: 
> I apologize for this automatic reply to your email.
> 
> To control spam, I now allow incoming messages only from senders I
> have approved beforehand.
> 
> If you would like to be added to my list of approved senders, please fill out the short request form

Sorry, Andy, I don't play those games.  If you want help with your Triumph questions, YOU need to deal with your silly anti-spam measures, not me.

Randall