Subject: [TR] British Car Suspenders

From: William Brewer <[email-masked]>
Date: Mon, 21 Jan 2013 06:01:58 -0800 (PST)

I've reached that point in life where I need suspenders to keep my pants
from sagging. I wear flannel lined pants in the winters and it is too much for
a belt to handle. I've been wearing some extra-corny red suspenders with farm
animals on them (from Germany), but wanted something less dorky, if there is
such a thing as less dorky than suspenders. I found some with fish on them and
others that looked like big tape measures with tools. Even skull & crossbones.
I finally bought a set of suspenders with British cars on them and everyone
seems to like them and think that they fit me. If you search for "car
suspenders" on Ebay they should come up. Only $9.95 and made in USA.

http://www.ebay.com/itm/2-Men-s-Womans-Antique-Car-Suspenders-Made-in-USA-/23
0868600316?pt=US_Men_s_Accessories&hash=item35c0d745fc

     Bill in Tehachapi

** [email-masked] **

Archive: http://www.team.net/archive

---

From: [email-masked]
Date: Mon, 21 Jan 2013 15:33:37 +0000 (UTC)

If they have British cars on them, you have to call them "braces".

Phil Ethier West Side Saint Paul Minnesota USA
1973 Triumph Stag LE22439UBW "uncle jack", Sapphire Blue
2004 Suburban 8.1, Sport Red, the only automatic of the bunch
2005 Lotus Elise, Bordeaux Red Pearl
2007 Saturn Ion 3 2.4, Berry Red
[email-masked]
http://www.flickr.com/photos/pethier
http://www.flickr.com/groups/triumphtransamerica
http://www.mnautox.com
http://www.mntriumphs.org

----- Original Message -----
> From: "William Brewer" <[email-masked]>
> To: "Triumphs" <[email-masked]>
> Sent: Monday, January 21, 2013 8:01:58 AM
> Subject: [TR] British Car Suspenders

---

From: [email-masked]
Date: Mon, 21 Jan 2013 11:15:23 -0500 (EST)

I have not yet made the conversion to suspenders to hold up my troosers but 
I do use a pair to keep my kilt in position when I am wearing my doublet.  
The doublet positions the kilt belt too high and it tends to work the kilt 
down to where it reaches below the knees and that is just not proper.

The sporan is no help at all.

Dave

In a message dated 1/21/2013 9:29:05 AM Central Standard Time, 
[email-masked] writes: 
> Delight!!! I'm not the only one who has made the conversion. My trousers 
> have
> been staying up this way for the last year and I've got a variety in extra
> wide in all sorts of different colours. Not too keen on the 'shark's 
> teeth'
> waistband clamp variety as there have been a few occasions when one has 
> come
> adrift under tension and I've either had a smack in the face or a clout 
> round
> the back of the head for my trouble.
> Might even wear them with shorts next
> year and I'm not in the slightest bit worried about "what people think." 
> I'm
> comfortable and that's all that matters.

---

From: [email-masked]
Date: Mon, 21 Jan 2013 11:19:04 -0500 (EST)

What?  Duct Tape suspenders?

In a message dated 1/21/2013 9:57:22 AM Central Standard Time, 
[email-masked] writes: 
> you need a pair like red green wears.
> of course you could go for the "Florida"
> look with no suspenders

---

From: [email-masked]
Date: Mon, 21 Jan 2013 12:20:42 -0500 (EST)

Are there any other kind?
;-)

In a message dated 1/21/2013 10:34:23 AM Central Standard Time, 
[email-masked] writes: 
> you say that like there is something wrong !!
>   
>  
> 
> 
> From: "[email-masked]" <[email-masked]>
> To: [email-masked] 
> Sent: Monday, January 21, 2013 8:19 AM
> Subject: Re: [TR] British Car Suspenders
> 
>

---

From: [email-masked]
Date: Mon, 21 Jan 2013 12:29:10 -0500 (EST)

It is called a "Kilt" because many have been "Kilt" for calling it a dress.

;-)

In a message dated 1/21/2013 10:36:27 AM Central Standard Time, 
[email-masked] writes: 
> Dave
>  i did not know what a kilt was until i goggled it.
>  is it like a man dress?
>   
>  :-)
>   
>  Frank....an Englishman disguised as an American

---

From: [email-masked]
Date: Mon, 21 Jan 2013 16:57:13 -0500 (EST)

Now you sound like my wife.

In a message dated 1/21/2013 3:43:57 PM Central Standard Time, 
[email-masked] writes: 
> I don't care what Dave says, that's funny right there! :) :) :)