Subject: Re: [TR] penetrating oil

From: Jeff Lee <[email-masked]>
Date: Wed, 30 Jan 2013 07:16:23 -0800 (PST)

A friend turned me on to a can of Fluid Film about 4 months ago.  This stuff
is great!!  It was developed for the navy many years ago. I have not found a
stuck corroded rusty nut it could not free yet.  It bubbles and leaves behind
rust preventative.  Has a bit of a funky smell, but don't they all?  It's made
of wool oil.

http://www.fluidfilmsalesusa.com/about/

It can be purchased from Grainger:

http://www.grainger.com/Grainger/FLUID-FILM-LubricantCorrosion-Inhibitor-10N7
83?gclid=CNa5hbaukLUCFQVgMgodXW4AFg&cm_mmc=PPC:GooglePLA-_-Fleet%20and%20Vehi
cle%20Maintenance-_-Automotive%20Chemicals-_-10N783&ci_src=17588969&ci_sku=10
N783&ef_id=jQ1Pvjkur28AAFBB:20130130150949:s

NFI
The "List" rocks!  thanks guys
Jeff Lee
63 TR4 22144
Easley, SC

** [email-masked] **

Archive: http://www.team.net/archive

---

From: Geo Hahn <[email-masked]>
Date: Wed, 30 Jan 2013 11:28:31 -0700

On Wed, Jan 30, 2013 at 8:16 AM, Jeff Lee <[email-masked]> wrote:

> is great!!

I, too, have been using Fluid Film.  I still use PBlaster for penetrating
oil but the FF seems to be a good choice for rust proofing as it is easy to
spray in cavities, creeps well and unlike most spray oils seems never to
evaporate.  Also makes cast metal parts look nice if you're detailing (e.g.
master cylinders).

I found it at a local tractor supply store (which is itself hard to find in
Tucson AZ).  I think its main ingredient is Lanolin.

Geo

---

From: [email-masked]
Date: Wed, 30 Jan 2013 19:52:09 +0000 (UTC)

I buy Fluid Film at the local John Deere dealer.  I use it every fall all over the chassis of the Suburban.  Seems that GM can find good paint for the body but not for the frame.  Right next to a perfect underbody is a frame with no paint on it at all.

I have never tried Fluid Film for bolt-and-nut removal.  PB Blaster has worked fine for me.

Phil Ethier West Side Saint Paul Minnesota USA
1973 Triumph Stag LE22439UBW "uncle jack", Sapphire Blue
2004 Suburban 8.1, Sport Red, the only automatic of the bunch
2005 Lotus Elise, Bordeaux Red Pearl
2007 Saturn Ion 3 2.4, Berry Red
[email-masked]
http://www.flickr.com/photos/pethier
http://www.flickr.com/groups/triumphtransamerica
http://www.mnautox.com
http://www.mntriumphs.org

----- Original Message -----
> From: "Jeff Lee" <[email-masked]>
> To: "list" <[email-masked]>
> Sent: Wednesday, January 30, 2013 9:16:23 AM
> Subject: Re: [TR] penetrating oil
> Donate: http://www.team.net/donate.html
> Forums: http://www.team.net/forums
> Unsubscribe/Manage:
> http://autox.team.net/mailman/options/triumphs/[email-masked]