Subject: [TR] How many TR4s

From: "Peter" <[email-masked]>
Date: Mon, 3 Dec 2012 23:50:07 -0500

OK, I'm in with a 63 TR4, bought new in July of that year. It turned over
190,000 miles in October and was put up for the winter today.

Pete Fullam

CT19207L

** [email-masked] **

Archive: http://www.team.net/archive

---

From: Mark J Bradakis <[email-masked]>
Date: Mon, 03 Dec 2012 22:25:54 -0700

I miss The Rust Rocket.

mjb.