Subject: Re: [TR] Earls Court demolition planned

From: Frank Fisher <[email-masked]>
Date: Fri, 21 Dec 2012 07:03:06 -0800 (PST)

good grief
whats the world coming to?
i used to take the train from liverpool
to london and then the tube.
there was always a bunch of guys going for a fun
weekend.
and yest the dolly birds where always so sexy

From: Don Hiscock
<[email-masked]>
To: Triumphs <[email-masked]> 
Sent: Friday,
December 21, 2012 5:21 AM
Subject: [TR] Earls Court demolition planned

The
traditional home of the British Motor Show, the site where most of our
cars
were premiered, is planned to be torn down.  A group is working to
save the
venue.
http://www.classicandsportscar.com/news/general-classic-car-news/enthusiasts-
campaign-to-save-earls-court-from-the-wrecking-ball

Don

**
[email-masked] **

Archive:
http://autox.team.net/mailman/options/triumphs/[email-masked]

** [email-masked] **

Archive: http://www.team.net/archive

---

From: John Macartney <[email-masked]>
Date: Fri, 21 Dec 2012 18:20:55 +0000 (GMT)

No nostaligia doesn't pay - but I don't feel at all nostalgic for the
horrendous headcolds and infections I used to catch after a stint of one week
"on the stand" at Earls Court for the Motor Show or the Royal Smithfield.
Jonmac

________________________________
 From: Frank Fisher
<[email-masked]>
To: Don Hiscock <[email-masked]>; Triumphs
<[email-masked]> 
Sent: Friday, 21 December 2012, 15:03
Subject: Re:
[TR] Earls Court demolition planned

>there
was always a bunch of guys going for a fun
>traditional home of the
British Motor Show, the site where most of our
>were premiered, is
planned to be torn down.  A group is working to
>Donate: http://www.team.net/donate.html
>Archive:
>http://www.team.net/archive
>Forums: http://www.team.net/forums
>Unsubscribe/Manage:
>
>Donate: http://www.team.net/donate.html
>Forums: http://www.team.net/forums
>Unsubscribe/Manage:
http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: Frank Fisher <[email-masked]>
Date: Fri, 21 Dec 2012 16:04:42 -0800 (PST)

laughing.
having worked many trade shows i now know your pain John.
but back
then i was a young kid looking to see hot cars, hot women and a  large amount
of brew.
the spectators always had more fun..well maybe. i know me and the
boys did

________________________________
From: John Macartney
<[email-masked]>
To: Frank Fisher <[email-masked]>; Don
Hiscock <[email-masked]>; Triumphs <[email-masked]>;
"[email-masked]" <[email-masked]> 
Sent: Friday, December 21, 2012
10:20 AM
Subject: Re: [TR] Earls Court demolition planned

No nostaligia
doesn't pay - but I don't feel at all nostalgic for the horrendous headcolds
and infections I used to catch after a stint of one week "on the stand" at
Earls Court for the Motor Show or the Royal Smithfield.

Jonmac
________________________________
From: Frank Fisher <[email-masked]>
To:
Don Hiscock <[email-masked]>; Triumphs <[email-masked]> 
Sent:
Friday, 21 December 2012, 15:03
Subject: Re: [TR] Earls Court demolition
planned

---

From: John Macartney <[email-masked]>
Date: Sat, 22 Dec 2012 01:06:08 +0000 (GMT)

Still recall Standard-Triumph's UK Sales Director stating that in his view,
"those few young men who populate the Company's London showroom are overpaid,
oversexed and seriously underworked." Poor man, he had three seriously
stunning daughters whjo all did crazy things in their Herald Coupes and
Spitfires. But we salesmen from the showroom had much the same excitement
about Earls Court and for the same reasons - but we still came home at the end
of the week with 'flu, no voice - and a rather serious hangover, as I recall.
Great days!

Jonmac     
________________________________
 From: Frank Fisher
<[email-masked]>
To: John Macartney <[email-masked]>; Don
Hiscock <[email-masked]>; Triumphs <[email-masked]>;
"[email-masked]" <[email-masked]> 
Sent: Saturday, 22 December 2012,
0:04
Subject: Re: [TR] Earls Court demolition planned

>having
worked many trade shows i now know your pain John.
>then i was a
young kid looking to see hot cars, hot women and a  large amount
>>i used to
take the train
>from liverpool
>>there was
always a bunch of guys
>going for a fun
Triumphs
>>December 21, 2012 5:21
AM
>>traditional home
of the British
>Motor Show, the site where most of our
>>cars
>>were
premiered, is planned to be
>torn down.  A group is working to
>>save the
>>venue.
http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: "Michael Marr" <[email-masked]>
Date: Fri, 21 Dec 2012 21:43:31 -0600

Dolly birds?  You're a child of the 60s, Frank!

Personally, my best memories of Earls Court was the boat show and the annual 
military tattoo, especially the Navy's field gun contest.  My dad would yell 
himself hoarse if the lads from Pompey (Portsmouth) looked like they would 
beat the Devonport barracks.

Mike

--------------------------------------------------
From: "Frank Fisher" <[email-masked]>
Sent: Friday, December 21, 2012 9:03 AM
To: "Don Hiscock" <[email-masked]>; "Triumphs" 
<[email-masked]>
Subject: Re: [TR] Earls Court demolition planned

> http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: Frank Fisher <[email-masked]>
Date: Sat, 22 Dec 2012 09:41:24 -0800 (PST)

never did the boat show.
could not afford any of those cars they where
showing, so a boat was not even in my dreams
________________________________
From: Michael Marr <[email-masked]>
To:
Frank Fisher <[email-masked]>; Don Hiscock <[email-masked]>;
Triumphs <[email-masked]> 
Sent: Friday, December 21, 2012 7:43 PM
Subject: Re: [TR] Earls Court demolition planned

Dolly birds?  You're a child
of the 60s, Frank!

Personally, my best memories of Earls Court was the boat
show and the annual 
military tattoo, especially the Navy's field gun
contest.  My dad would yell 
himself hoarse if the lads from Pompey
(Portsmouth) looked like they would 
beat the Devonport barracks.

Mike
From: "Frank Fisher"
To: "Don
Hiscock" <[email-masked]>; "Triumphs" 

<[email-masked]>
> To: Triumphs <[email-masked]>
Friday,

---

From: "Michael Marr" <[email-masked]>
Date: Sun, 23 Dec 2012 02:15:01 -0600

Boats were only in my dreams too, Frank, until I came to the States and
ultimately owned several  They say that, rather like owning a Jag, the two
happiest days of a boat-owners life are the day he buys it and the day he
sells it.

And, I should have said the Royal Tournament, rather than the military tattoo.
My addled 63 year old brain couldn't come up with the correct name at the time
I wrote my note.

Mike

From: Frank Fisher
Sent: Saturday, December 22, 2012 11:41 AM
To: Michael Marr ; Don Hiscock ; Triumphs
Subject: Re: [TR] Earls Court demolition planned

never did the boat show.
could not afford any of those cars they where showing, so a boat was not even
in my dreams

To: Frank Fisher <[email-masked]>; Don Hiscock <[email-masked]>;

Mike

---

From: "Michael Marr" <[email-masked]>
Date: Mon, 24 Dec 2012 15:08:21 -0600

So, here is what Earls Court means to me:

http://www.youtube.com/watch?v=Rxz4aPoudv8

Mike

From: Frank Fisher
Sent: Sunday, December 23, 2012 10:57 AM
To: Michael Marr ; Don Hiscock
Subject: Re: [TR] Earls Court demolition planned

add to the boat thing, that i can get sea sick on a pond and you get more idea
of why they didn't come up in my dreams

and how funny is it that i appreciate the Tattoo's now more than i did when i
lived there. not that i didn't appreciate them back then. but maybe more now
that i see so few.

Sent: Sunday, December 23, 2012 12:15 AM

Mike

From: Frank Fisher

never did the boat show.

Mike

---

From: Frank Fisher <[email-masked]>
Date: Tue, 25 Dec 2012 10:06:21 -0800 (PST)

fantastic stuff
just opened the Christmas presents. huge Union and st George
flags.
great british day.
merry Christmas guys
 
________________________________
From: Michael Marr <[email-masked]>
To:
Frank Fisher <[email-masked]>; Don Hiscock <[email-masked]>;
Triumphs List <[email-masked]> 
Sent: Monday, December 24, 2012 1:08
PM
Subject: Re: [TR] Earls Court demolition planned

So, here is what Earls
Court means to me:

Mike

From:
Frank Fisher 
To: Michael Marr ; Don
Hiscock 

add to the boat
thing, that i can get sea sick on a pond and you get more idea of why they
didn't come up in my dreams
 
and how funny is it that i appreciate the
Tattoo's now more than i did when i lived there. not that i didn't appreciate
them back then. but maybe more now that i see so few.
________________________________
From: Michael Marr <[email-masked]>
To:
Frank Fisher <[email-masked]>; Don Hiscock <[email-masked]>;
Triumphs <[email-masked]> 
Sent: Sunday, December 23, 2012 12:15 AM
Subject: Re: [TR] Earls Court demolition planned

Boats were only in my
dreams too, Frank, until I came to the States and ultimately owned several 
They say that, rather like owning a Jag, the two happiest days of a
boat-owners life are the day he buys it and the day he sells it.

And, I
should have said the Royal Tournament, rather than the military tattoo.  My
addled 63 year old brain couldn't come up with the correct name at the time I
wrote my note.
 
Mike

From: Frank Fisher 
Sent: Saturday, December 22, 2012
11:41 AM
To: Michael Marr ; Don Hiscock ; Triumphs 
Subject: Re: [TR] Earls
Court demolition planned

never did the boat show.
could not afford any of
those cars they where showing, so a boat was not even in my dreams

Mike

<[email-masked]>
Friday,

---

From: "Michael Marr" <[email-masked]>
Date: Tue, 25 Dec 2012 17:44:51 -0600

Merry Christmas to all!

From: Frank Fisher
Sent: Tuesday, December 25, 2012 12:06 PM
To: Michael Marr ; Don Hiscock ; Triumphs List
Subject: [Spam] Re: [TR] Earls Court demolition planned

fantastic stuff
just opened the Christmas presents. huge Union and st George flags.
great british day.
merry Christmas guys

Sent: Monday, December 24, 2012 1:08 PM

Mike

From: Frank Fisher

Mike

From: Frank Fisher

never did the boat show.

Mike